Erwan Gallen
Erwan Gallen

Dec 15, 2019 64 min read

How to enable NVIDIA T4 GPU with podman

thumbnail for this post

We will enable GPU with Podman on a RHEL 8.1 system with a NVIDIA Tesla T4: NVIDIA Tesla T4

Take a RHEL 8.1 system:

[egallen@lab0 ~]$ cat /etc/redhat-release 
Red Hat Enterprise Linux release 8.1 (Ootpa)

Enable sudo passwordless:

[egallen@lab0 ~]$ echo "egallen ALL=(root) NOPASSWD:ALL" | sudo tee -a /etc/sudoers.d/egallen

Register your node:

[egallen@lab0 ~]$ sudo subscription-manager register --username rhnuser
[egallen@lab0 ~]$ sudo subscription-manager attach --pool=XXXXXXXXX
[egallen@lab0 ~]$ sudo subscription-manager repos --enable=rhel-8-for-x86_64-baseos-rpms --enable=rhel-8-for-x86_64-appstream-rpms

The NVIDIA Tesla T4 PCI device is available:

[egallen@lab0 ~]$ sudo dnf install pciutils -y

[egallen@lab0 ~]$ lspci -nn | grep -i nvidia
01:00.0 3D controller [0302]: NVIDIA Corporation TU104GL [Tesla T4] [10de:1eb8] (rev a1)

Check the hardware:

[egallen@lab0 ~]$ sudo lshw -numeric -C display
  *-display                 
       description: 3D controller
       product: TU104GL [Tesla T4] [10DE:1EB8]
       vendor: NVIDIA Corporation [10DE]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff
  *-display
       description: VGA compatible controller
       product: HD Graphics 630 [8086:5912]
       vendor: Intel Corporation [8086]
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:137 memory:f5000000-f5ffffff memory:d0000000-dfffffff ioport:f000(size=64) memory:c0000-dffff

Enable EPEL repositories:

[egallen@lab0 ~]$ sudo dnf install https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm -y

Get the last updates:

[egallen@instance0 ~]$ sudo dnf upgrade -y

Install kernel-devel:

[egallen@lab0 ~]$ sudo dnf install kernel-devel -y

Reboot the node:

[egallen@lab0 ~]$ sudo systemctl reboot

Nouveau kernel module is enabled and will be disabled by the NVIDIA install:

[egallen@lab0 ~]$ sudo lsmod | grep nouveau
nouveau              2215936  0
mxm_wmi                16384  1 nouveau
ttm                   110592  1 nouveau
i2c_algo_bit           16384  2 i915,nouveau
drm_kms_helper        217088  2 i915,nouveau
drm                   524288  5 drm_kms_helper,i915,ttm,nouveau
wmi                    32768  2 mxm_wmi,nouveau
video                  45056  2 i915,nouveau

Enable NVIDIA repositories:

[egallen@lab0 ~]$ sudo dnf config-manager --add-repo http://developer.download.nvidia.com/compute/cuda/repos/rhel8/x86_64/cuda-rhel8.repo
Updating Subscription Management repositories.
Adding repo from: http://developer.download.nvidia.com/compute/cuda/repos/rhel8/x86_64/cuda-rhel8.repo

Install cuda and cuda-drivers:

[egallen@lab0 ~]$ sudo dnf install cuda -y
Updating Subscription Management repositories.
Last metadata expiration check: 0:00:35 ago on Sun 15 Dec 2019 04:02:27 PM CET.
Dependencies resolved.
========================================================================================================================================================================================
 Package                                       Architecture            Version                                                  Repository                                         Size
========================================================================================================================================================================================
Installing:
 cuda                                          x86_64                  10.2.89-1                                                cuda                                              6.1 k
Installing dependencies:
 nsight-systems-2019.5.2                       x86_64                  2019.5.2.16_b54ef97-0                                    cuda                                              109 M
 cuda-10-2                                     x86_64                  10.2.89-1                                                cuda                                              6.1 k
 cuda-command-line-tools-10-2                  x86_64                  10.2.89-1                                                cuda                                              6.2 k
 cuda-compiler-10-2                            x86_64                  10.2.89-1                                                cuda                                              6.1 k
 cuda-cudart-10-2                              x86_64                  10.2.89-1                                                cuda                                              151 k
 cuda-cudart-dev-10-2                          x86_64                  10.2.89-1                                                cuda                                              861 k
 cuda-cufft-10-2                               x86_64                  10.2.89-1                                                cuda                                              108 M
 cuda-cufft-dev-10-2                           x86_64                  10.2.89-1                                                cuda                                              206 M
 cuda-cuobjdump-10-2                           x86_64                  10.2.89-1                                                cuda                                              106 k
 cuda-cupti-10-2                               x86_64                  10.2.89-1                                                cuda                                               15 M
 cuda-curand-10-2                              x86_64                  10.2.89-1                                                cuda                                               42 M
 cuda-curand-dev-10-2                          x86_64                  10.2.89-1                                                cuda                                               43 M
 cuda-cusolver-10-2                            x86_64                  10.2.89-1                                                cuda                                              129 M
 cuda-cusolver-dev-10-2                        x86_64                  10.2.89-1                                                cuda                                               29 M
 cuda-cusparse-10-2                            x86_64                  10.2.89-1                                                cuda                                               79 M
 cuda-cusparse-dev-10-2                        x86_64                  10.2.89-1                                                cuda                                              159 M
 cuda-demo-suite-10-2                          x86_64                  10.2.89-1                                                cuda                                              4.7 M
 cuda-documentation-10-2                       x86_64                  10.2.89-1                                                cuda                                              132 M
 cuda-driver-dev-10-2                          x86_64                  10.2.89-1                                                cuda                                               20 k
 cuda-drivers                                  x86_64                  440.33.01-1                                              cuda                                              6.8 k
 cuda-gdb-10-2                                 x86_64                  10.2.89-1                                                cuda                                              3.5 M
 cuda-libraries-10-2                           x86_64                  10.2.89-1                                                cuda                                              6.3 k
 cuda-libraries-dev-10-2                       x86_64                  10.2.89-1                                                cuda                                              6.4 k
 cuda-license-10-2                             x86_64                  10.2.89-1                                                cuda                                               22 k
 cuda-memcheck-10-2                            x86_64                  10.2.89-1                                                cuda                                              180 k
 cuda-misc-headers-10-2                        x86_64                  10.2.89-1                                                cuda                                              1.7 M
 cuda-npp-10-2                                 x86_64                  10.2.89-1                                                cuda                                               86 M
 cuda-npp-dev-10-2                             x86_64                  10.2.89-1                                                cuda                                               86 M
 cuda-nsight-10-2                              x86_64                  10.2.89-1                                                cuda                                              268 M
 cuda-nsight-compute-10-2                      x86_64                  10.2.89-1                                                cuda                                              7.8 k
 cuda-nsight-systems-10-2                      x86_64                  10.2.89-1                                                cuda                                              7.3 k
 cuda-nvcc-10-2                                x86_64                  10.2.89-1                                                cuda                                               48 M
 cuda-nvdisasm-10-2                            x86_64                  10.2.89-1                                                cuda                                               21 M
 cuda-nvgraph-10-2                             x86_64                  10.2.89-1                                                cuda                                               97 M
 cuda-nvgraph-dev-10-2                         x86_64                  10.2.89-1                                                cuda                                               57 M
 cuda-nvjpeg-10-2                              x86_64                  10.2.89-1                                                cuda                                              1.7 M
 cuda-nvjpeg-dev-10-2                          x86_64                  10.2.89-1                                                cuda                                              1.8 M
 cuda-nvml-dev-10-2                            x86_64                  10.2.89-1                                                cuda                                               71 k
 cuda-nvprof-10-2                              x86_64                  10.2.89-1                                                cuda                                              3.8 M
 cuda-nvprune-10-2                             x86_64                  10.2.89-1                                                cuda                                               49 k
 cuda-nvrtc-10-2                               x86_64                  10.2.89-1                                                cuda                                              8.9 M
 cuda-nvrtc-dev-10-2                           x86_64                  10.2.89-1                                                cuda                                               14 k
 cuda-nvtx-10-2                                x86_64                  10.2.89-1                                                cuda                                               68 k
 cuda-nvvp-10-2                                x86_64                  10.2.89-1                                                cuda                                              114 M
 cuda-runtime-10-2                             x86_64                  10.2.89-1                                                cuda                                              6.1 k
 cuda-samples-10-2                             x86_64                  10.2.89-1                                                cuda                                               89 M
 cuda-sanitizer-api-10-2                       x86_64                  10.2.89-1                                                cuda                                              3.5 M
 cuda-toolkit-10-2                             x86_64                  10.2.89-1                                                cuda                                              6.7 k
 cuda-tools-10-2                               x86_64                  10.2.89-1                                                cuda                                              6.0 k
 cuda-visual-tools-10-2                        x86_64                  10.2.89-1                                                cuda                                              6.8 k
 dnf-plugin-nvidia                             noarch                  1.1-1.el8                                                cuda                                              8.5 k
 kmod-nvidia-latest-dkms                       x86_64                  3:440.33.01-1.el8                                        cuda                                               14 M
 libcublas-devel                               x86_64                  10.2.2.89-1                                              cuda                                               60 M
 libcublas10                                   x86_64                  10.2.2.89-1                                              cuda                                               58 M
 nsight-compute-2019.4.0                       x86_64                  2019.4.0.12-1                                            cuda                                              257 M
 nvidia-driver                                 x86_64                  3:440.33.01-1.el8                                        cuda                                              5.3 M
 nvidia-driver-NVML                            x86_64                  3:440.33.01-1.el8                                        cuda                                              523 k
 nvidia-driver-NvFBCOpenGL                     x86_64                  3:440.33.01-1.el8                                        cuda                                              136 k
 nvidia-driver-cuda                            x86_64                  3:440.33.01-1.el8                                        cuda                                              392 k
 nvidia-driver-cuda-libs                       x86_64                  3:440.33.01-1.el8                                        cuda                                               34 M
 nvidia-driver-devel                           x86_64                  3:440.33.01-1.el8                                        cuda                                               12 k
 nvidia-driver-libs                            x86_64                  3:440.33.01-1.el8                                        cuda                                               80 M
 nvidia-kmod-common                            noarch                  3:440.33.01-1.el8                                        cuda                                              9.8 k
 nvidia-libXNVCtrl                             x86_64                  3:440.33.01-1.el8                                        cuda                                               58 k
 nvidia-libXNVCtrl-devel                       x86_64                  3:440.33.01-1.el8                                        cuda                                               60 k
 nvidia-modprobe                               x86_64                  3:440.33.01-1.el8                                        cuda                                               77 k
 nvidia-persistenced                           x86_64                  3:440.33.01-1.el8                                        cuda                                              111 k
 nvidia-settings                               x86_64                  3:440.33.01-1.el8                                        cuda                                              2.3 M
 nvidia-xconfig                                x86_64                  3:440.33.01-1.el8                                        cuda                                              319 k
 dkms                                          noarch                  2.7.1-2.el8                                              epel                                               79 k
 make                                          x86_64                  1:4.2.1-9.el8                                            rhel-8-for-x86_64-baseos-rpms                     498 k
 libpkgconf                                    x86_64                  1.4.2-1.el8                                              rhel-8-for-x86_64-baseos-rpms                      35 k
 libmodman                                     x86_64                  2.0.1-17.el8                                             rhel-8-for-x86_64-baseos-rpms                      36 k
 pkgconf-m4                                    noarch                  1.4.2-1.el8                                              rhel-8-for-x86_64-baseos-rpms                      17 k
 pkgconf                                       x86_64                  1.4.2-1.el8                                              rhel-8-for-x86_64-baseos-rpms                      38 k
 libproxy                                      x86_64                  0.4.15-5.2.el8                                           rhel-8-for-x86_64-baseos-rpms                      74 k
 glib-networking                               x86_64                  2.56.1-1.1.el8                                           rhel-8-for-x86_64-baseos-rpms                     155 k
 avahi-libs                                    x86_64                  0.7-19.el8                                               rhel-8-for-x86_64-baseos-rpms                      63 k
 libxcrypt-devel                               x86_64                  4.1.1-4.el8                                              rhel-8-for-x86_64-baseos-rpms                      25 k
 libsoup                                       x86_64                  2.62.3-1.el8                                             rhel-8-for-x86_64-baseos-rpms                     424 k
 fontpackages-filesystem                       noarch                  1.44-22.el8                                              rhel-8-for-x86_64-baseos-rpms                      16 k
 libgusb                                       x86_64                  0.3.0-1.el8                                              rhel-8-for-x86_64-baseos-rpms                      49 k
 tar                                           x86_64                  2:1.30-4.el8                                             rhel-8-for-x86_64-baseos-rpms                     838 k
 lksctp-tools                                  x86_64                  1.0.18-3.el8                                             rhel-8-for-x86_64-baseos-rpms                     100 k
 libpciaccess                                  x86_64                  0.14-1.el8                                               rhel-8-for-x86_64-baseos-rpms                      32 k
 fontconfig                                    x86_64                  2.13.1-3.el8                                             rhel-8-for-x86_64-baseos-rpms                     275 k
 zlib-devel                                    x86_64                  1.2.11-10.el8                                            rhel-8-for-x86_64-baseos-rpms                      56 k
 binutils                                      x86_64                  2.30-58.el8                                              rhel-8-for-x86_64-baseos-rpms                     5.7 M
 elfutils-libelf-devel                         x86_64                  0.176-5.el8                                              rhel-8-for-x86_64-baseos-rpms                      54 k
 gdk-pixbuf2                                   x86_64                  2.36.12-5.el8                                            rhel-8-for-x86_64-baseos-rpms                     467 k
 gsettings-desktop-schemas                     x86_64                  3.32.0-3.el8                                             rhel-8-for-x86_64-baseos-rpms                     632 k
 glibc-devel                                   x86_64                  2.28-72.el8                                              rhel-8-for-x86_64-baseos-rpms                     1.0 M
 pkgconf-pkg-config                            x86_64                  1.4.2-1.el8                                              rhel-8-for-x86_64-baseos-rpms                      15 k
 cups-libs                                     x86_64                  1:2.2.6-28.el8                                           rhel-8-for-x86_64-baseos-rpms                     433 k
 glibc-headers                                 x86_64                  2.28-72.el8                                              rhel-8-for-x86_64-baseos-rpms                     469 k
 kernel-headers                                x86_64                  4.18.0-147.0.3.el8_1                                     rhel-8-for-x86_64-baseos-rpms                     2.7 M
 libX11-common                                 noarch                  1.6.7-1.el8                                              rhel-8-for-x86_64-appstream-rpms                  157 k
 adwaita-icon-theme                            noarch                  3.28.0-2.el8                                             rhel-8-for-x86_64-appstream-rpms                   11 M
 opencl-filesystem                             noarch                  1.0-6.el8                                                rhel-8-for-x86_64-appstream-rpms                  8.5 k
 adwaita-cursor-theme                          noarch                  3.28.0-2.el8                                             rhel-8-for-x86_64-appstream-rpms                  647 k
 xorg-x11-proto-devel                          noarch                  2018.4-1.el8                                             rhel-8-for-x86_64-appstream-rpms                  283 k
 javapackages-filesystem                       noarch                  5.3.0-1.module+el8+2447+6f56d9a6                         rhel-8-for-x86_64-appstream-rpms                   30 k
 abattis-cantarell-fonts                       noarch                  0.0.25-4.el8                                             rhel-8-for-x86_64-appstream-rpms                  155 k
 libXdmcp                                      x86_64                  1.1.2-11.el8                                             rhel-8-for-x86_64-appstream-rpms                   40 k
 libglvnd-opengl                               x86_64                  1:1.0.1-0.9.git5baa1e5.el8                               rhel-8-for-x86_64-appstream-rpms                   48 k
 xorg-x11-fonts-Type1                          noarch                  7.5-19.el8                                               rhel-8-for-x86_64-appstream-rpms                  522 k
 copy-jdk-configs                              noarch                  3.7-1.el8                                                rhel-8-for-x86_64-appstream-rpms                   27 k
 hicolor-icon-theme                            noarch                  0.17-2.el8                                               rhel-8-for-x86_64-appstream-rpms                   48 k
 libxcb                                        x86_64                  1.13-5.el8                                               rhel-8-for-x86_64-appstream-rpms                  230 k
 libwacom-data                                 noarch                  0.31-1.el8                                               rhel-8-for-x86_64-appstream-rpms                   76 k
 gl-manpages                                   noarch                  1.1-15.20161227.el8                                      rhel-8-for-x86_64-appstream-rpms                  1.2 M
 lcms2                                         x86_64                  2.9-2.el8                                                rhel-8-for-x86_64-appstream-rpms                  165 k
 mesa-libGLU-devel                             x86_64                  9.0.0-15.el8                                             rhel-8-for-x86_64-appstream-rpms                   15 k
 libXdamage-devel                              x86_64                  1.1.4-14.el8                                             rhel-8-for-x86_64-appstream-rpms                   15 k
 jbigkit-libs                                  x86_64                  2.1-14.el8                                               rhel-8-for-x86_64-appstream-rpms                   55 k
 libXi-devel                                   x86_64                  1.7.9-7.el8                                              rhel-8-for-x86_64-appstream-rpms                  111 k
 libXi                                         x86_64                  1.7.9-7.el8                                              rhel-8-for-x86_64-appstream-rpms                   49 k
 libXext                                       x86_64                  1.3.3-9.el8                                              rhel-8-for-x86_64-appstream-rpms                   45 k
 ocl-icd                                       x86_64                  2.2.12-1.el8                                             rhel-8-for-x86_64-appstream-rpms                   51 k
 libXtst                                       x86_64                  1.2.3-7.el8                                              rhel-8-for-x86_64-appstream-rpms                   22 k
 libXinerama                                   x86_64                  1.1.4-1.el8                                              rhel-8-for-x86_64-appstream-rpms                   16 k
 libglvnd-egl                                  x86_64                  1:1.0.1-0.9.git5baa1e5.el8                               rhel-8-for-x86_64-appstream-rpms                   50 k
 libmpc                                        x86_64                  1.0.2-9.el8                                              rhel-8-for-x86_64-appstream-rpms                   59 k
 libglvnd-core-devel                           x86_64                  1:1.0.1-0.9.git5baa1e5.el8                               rhel-8-for-x86_64-appstream-rpms                   24 k
 xorg-x11-xkb-utils                            x86_64                  7.7-27.el8                                               rhel-8-for-x86_64-appstream-rpms                  114 k
 libvdpau                                      x86_64                  1.1.1-7.el8                                              rhel-8-for-x86_64-appstream-rpms                   40 k
 at-spi2-core                                  x86_64                  2.28.0-1.el8                                             rhel-8-for-x86_64-appstream-rpms                  169 k
 ttmkfdir                                      x86_64                  3.0.9-54.el8                                             rhel-8-for-x86_64-appstream-rpms                   62 k
 graphite2                                     x86_64                  1.3.10-10.el8                                            rhel-8-for-x86_64-appstream-rpms                  122 k
 libXfixes-devel                               x86_64                  5.0.3-7.el8                                              rhel-8-for-x86_64-appstream-rpms                   19 k
 libXcursor                                    x86_64                  1.1.15-3.el8                                             rhel-8-for-x86_64-appstream-rpms                   36 k
 libXrandr                                     x86_64                  1.5.1-7.el8                                              rhel-8-for-x86_64-appstream-rpms                   33 k
 at-spi2-atk                                   x86_64                  2.26.2-1.el8                                             rhel-8-for-x86_64-appstream-rpms                   89 k
 xorg-x11-drv-libinput                         x86_64                  0.28.0-2.el8                                             rhel-8-for-x86_64-appstream-rpms                   50 k
 libwayland-egl                                x86_64                  1.15.0-1.el8                                             rhel-8-for-x86_64-appstream-rpms                   19 k
 libX11-devel                                  x86_64                  1.6.7-1.el8                                              rhel-8-for-x86_64-appstream-rpms                  977 k
 libXfont2                                     x86_64                  2.0.3-2.el8                                              rhel-8-for-x86_64-appstream-rpms                  149 k
 jasper-libs                                   x86_64                  2.0.14-4.el8                                             rhel-8-for-x86_64-appstream-rpms                  167 k
 libSM                                         x86_64                  1.2.3-1.el8                                              rhel-8-for-x86_64-appstream-rpms                   48 k
 libwayland-server                             x86_64                  1.15.0-1.el8                                             rhel-8-for-x86_64-appstream-rpms                   45 k
 libwayland-cursor                             x86_64                  1.15.0-1.el8                                             rhel-8-for-x86_64-appstream-rpms                   26 k
 libXft                                        x86_64                  2.3.2-10.el8                                             rhel-8-for-x86_64-appstream-rpms                   66 k
 libxkbfile                                    x86_64                  1.0.9-9.el8                                              rhel-8-for-x86_64-appstream-rpms                   86 k
 libXfixes                                     x86_64                  5.0.3-7.el8                                              rhel-8-for-x86_64-appstream-rpms                   25 k
 libglvnd                                      x86_64                  1:1.0.1-0.9.git5baa1e5.el8                               rhel-8-for-x86_64-appstream-rpms                   96 k
 cairo-gobject                                 x86_64                  1.15.12-3.el8                                            rhel-8-for-x86_64-appstream-rpms                   33 k
 libglvnd-gles                                 x86_64                  1:1.0.1-0.9.git5baa1e5.el8                               rhel-8-for-x86_64-appstream-rpms                   41 k
 libXau                                        x86_64                  1.0.8-13.el8                                             rhel-8-for-x86_64-appstream-rpms                   36 k
 freeglut                                      x86_64                  3.0.0-8.el8                                              rhel-8-for-x86_64-appstream-rpms                  191 k
 libepoxy                                      x86_64                  1.5.2-1.el8                                              rhel-8-for-x86_64-appstream-rpms                  225 k
 freeglut-devel                                x86_64                  3.0.0-8.el8                                              rhel-8-for-x86_64-appstream-rpms                  121 k
 egl-wayland                                   x86_64                  1.1.2-1.el8                                              rhel-8-for-x86_64-appstream-rpms                   33 k
 xorg-x11-drv-vesa                             x86_64                  2.4.0-3.el8                                              rhel-8-for-x86_64-appstream-rpms                   31 k
 libwacom                                      x86_64                  0.31-1.el8                                               rhel-8-for-x86_64-appstream-rpms                   42 k
 libXxf86vm                                    x86_64                  1.1.4-9.el8                                              rhel-8-for-x86_64-appstream-rpms                   19 k
 xorg-x11-drv-fbdev                            x86_64                  0.5.0-2.el8                                              rhel-8-for-x86_64-appstream-rpms                   27 k
 libthai                                       x86_64                  0.1.27-2.el8                                             rhel-8-for-x86_64-appstream-rpms                  203 k
 colord-libs                                   x86_64                  1.4.2-1.el8                                              rhel-8-for-x86_64-appstream-rpms                  236 k
 rest                                          x86_64                  0.8.1-2.el8                                              rhel-8-for-x86_64-appstream-rpms                   71 k
 libXdamage                                    x86_64                  1.1.4-14.el8                                             rhel-8-for-x86_64-appstream-rpms                   27 k
 libXmu-devel                                  x86_64                  1.1.2-12.el8                                             rhel-8-for-x86_64-appstream-rpms                   25 k
 libSM-devel                                   x86_64                  1.2.3-1.el8                                              rhel-8-for-x86_64-appstream-rpms                   18 k
 cairo                                         x86_64                  1.15.12-3.el8                                            rhel-8-for-x86_64-appstream-rpms                  721 k
 harfbuzz                                      x86_64                  1.7.5-3.el8                                              rhel-8-for-x86_64-appstream-rpms                  294 k
 libXxf86vm-devel                              x86_64                  1.1.4-9.el8                                              rhel-8-for-x86_64-appstream-rpms                   20 k
 mesa-libGLU                                   x86_64                  9.0.0-15.el8                                             rhel-8-for-x86_64-appstream-rpms                  185 k
 libXcomposite                                 x86_64                  0.4.4-14.el8                                             rhel-8-for-x86_64-appstream-rpms                   29 k
 libfontenc                                    x86_64                  1.1.3-8.el8                                              rhel-8-for-x86_64-appstream-rpms                   37 k
 libwayland-client                             x86_64                  1.15.0-1.el8                                             rhel-8-for-x86_64-appstream-rpms                   39 k
 libX11-xcb                                    x86_64                  1.6.7-1.el8                                              rhel-8-for-x86_64-appstream-rpms                   14 k
 libxcb-devel                                  x86_64                  1.13-5.el8                                               rhel-8-for-x86_64-appstream-rpms                  1.1 M
 libX11                                        x86_64                  1.6.7-1.el8                                              rhel-8-for-x86_64-appstream-rpms                  612 k
 fribidi                                       x86_64                  1.0.4-6.el8                                              rhel-8-for-x86_64-appstream-rpms                   89 k
 libXrender                                    x86_64                  0.9.10-7.el8                                             rhel-8-for-x86_64-appstream-rpms                   33 k
 atk                                           x86_64                  2.28.1-1.el8                                             rhel-8-for-x86_64-appstream-rpms                  272 k
 libdatrie                                     x86_64                  0.2.9-7.el8                                              rhel-8-for-x86_64-appstream-rpms                   33 k
 libxshmfence                                  x86_64                  1.3-2.el8                                                rhel-8-for-x86_64-appstream-rpms                   13 k
 giflib                                        x86_64                  5.1.4-3.el8                                              rhel-8-for-x86_64-appstream-rpms                   51 k
 libXext-devel                                 x86_64                  1.3.3-9.el8                                              rhel-8-for-x86_64-appstream-rpms                   80 k
 libevdev                                      x86_64                  1.5.9-5.el8                                              rhel-8-for-x86_64-appstream-rpms                   42 k
 isl                                           x86_64                  0.16.1-6.el8                                             rhel-8-for-x86_64-appstream-rpms                  841 k
 libXau-devel                                  x86_64                  1.0.8-13.el8                                             rhel-8-for-x86_64-appstream-rpms                   20 k
 pixman                                        x86_64                  0.36.0-1.el8                                             rhel-8-for-x86_64-appstream-rpms                  257 k
 libXmu                                        x86_64                  1.1.2-12.el8                                             rhel-8-for-x86_64-appstream-rpms                   74 k
 mtdev                                         x86_64                  1.1.5-12.el8                                             rhel-8-for-x86_64-appstream-rpms                   24 k
 xorg-x11-font-utils                           x86_64                  1:7.5-40.el8                                             rhel-8-for-x86_64-appstream-rpms                  103 k
 libglvnd-glx                                  x86_64                  1:1.0.1-0.9.git5baa1e5.el8                               rhel-8-for-x86_64-appstream-rpms                  131 k
 libglvnd-devel                                x86_64                  1:1.0.1-0.9.git5baa1e5.el8                               rhel-8-for-x86_64-appstream-rpms                   16 k
 libXt                                         x86_64                  1.1.5-12.el8                                             rhel-8-for-x86_64-appstream-rpms                  185 k
 tzdata-java                                   noarch                  2019c-1.el8                                              rhel-8-for-x86_64-appstream-rpms                  189 k
 gcc                                           x86_64                  8.3.1-4.5.el8                                            rhel-8-for-x86_64-appstream-rpms                   23 M
 mesa-libEGL                                   x86_64                  19.1.4-2.el8                                             rhel-8-for-x86_64-appstream-rpms                  131 k
 mesa-libGL-devel                              x86_64                  19.1.4-2.el8                                             rhel-8-for-x86_64-appstream-rpms                  177 k
 libjpeg-turbo                                 x86_64                  1.5.3-10.el8                                             rhel-8-for-x86_64-appstream-rpms                  156 k
 mesa-vulkan-drivers                           x86_64                  19.1.4-2.el8                                             rhel-8-for-x86_64-appstream-rpms                  2.6 M
 mesa-libglapi                                 x86_64                  19.1.4-2.el8                                             rhel-8-for-x86_64-appstream-rpms                   61 k
 alsa-lib                                      x86_64                  1.1.9-4.el8                                              rhel-8-for-x86_64-appstream-rpms                  429 k
 gcc-c++                                       x86_64                  8.3.1-4.5.el8                                            rhel-8-for-x86_64-appstream-rpms                   12 M
 libXt-devel                                   x86_64                  1.1.5-12.el8                                             rhel-8-for-x86_64-appstream-rpms                  452 k
 xorg-x11-server-common                        x86_64                  1.20.3-11.el8                                            rhel-8-for-x86_64-appstream-rpms                   40 k
 xorg-x11-server-Xorg                          x86_64                  1.20.3-11.el8                                            rhel-8-for-x86_64-appstream-rpms                  1.5 M
 cpp                                           x86_64                  8.3.1-4.5.el8                                            rhel-8-for-x86_64-appstream-rpms                   10 M
 gtk-update-icon-cache                         x86_64                  3.22.30-4.el8                                            rhel-8-for-x86_64-appstream-rpms                   33 k
 pango                                         x86_64                  1.42.4-6.el8                                             rhel-8-for-x86_64-appstream-rpms                  298 k
 libtiff                                       x86_64                  4.0.9-15.el8                                             rhel-8-for-x86_64-appstream-rpms                  188 k
 mesa-libgbm                                   x86_64                  19.1.4-2.el8                                             rhel-8-for-x86_64-appstream-rpms                   55 k
 libdrm                                        x86_64                  2.4.98-2.el8                                             rhel-8-for-x86_64-appstream-rpms                  165 k
 lua                                           x86_64                  5.3.4-11.el8                                             rhel-8-for-x86_64-appstream-rpms                  193 k
 libICE-devel                                  x86_64                  1.0.9-15.el8                                             rhel-8-for-x86_64-appstream-rpms                   55 k
 mesa-khr-devel                                x86_64                  19.1.4-2.el8                                             rhel-8-for-x86_64-appstream-rpms                   33 k
 libdrm-devel                                  x86_64                  2.4.98-2.el8                                             rhel-8-for-x86_64-appstream-rpms                  156 k
 vulkan-loader                                 x86_64                  1.1.114.0-3.el8                                          rhel-8-for-x86_64-appstream-rpms                  113 k
 java-1.8.0-openjdk                            x86_64                  1:1.8.0.232.b09-2.el8_1                                  rhel-8-for-x86_64-appstream-rpms                  317 k
 gdk-pixbuf2-modules                           x86_64                  2.36.12-5.el8                                            rhel-8-for-x86_64-appstream-rpms                  109 k
 mesa-libGL                                    x86_64                  19.1.4-2.el8                                             rhel-8-for-x86_64-appstream-rpms                  184 k
 gtk3                                          x86_64                  3.22.30-4.el8                                            rhel-8-for-x86_64-appstream-rpms                  4.5 M
 java-1.8.0-openjdk-headless                   x86_64                  1:1.8.0.232.b09-2.el8_1                                  rhel-8-for-x86_64-appstream-rpms                   33 M
 llvm-libs                                     x86_64                  8.0.1-1.module+el8.1.0+3866+6be7f4d8                     rhel-8-for-x86_64-appstream-rpms                   18 M
 libstdc++-devel                               x86_64                  8.3.1-4.5.el8                                            rhel-8-for-x86_64-appstream-rpms                  2.0 M
 libinput                                      x86_64                  1.13.2-1.el8                                             rhel-8-for-x86_64-appstream-rpms                  198 k
 libICE                                        x86_64                  1.0.9-15.el8                                             rhel-8-for-x86_64-appstream-rpms                   74 k
Installing weak dependencies:
 dconf                                         x86_64                  0.28.0-3.el8                                             rhel-8-for-x86_64-appstream-rpms                  109 k
 gtk2                                          x86_64                  2.24.32-4.el8                                            rhel-8-for-x86_64-appstream-rpms                  3.4 M
Enabling module streams:
 javapackages-runtime                                                  201801                                                                                                          
 llvm-toolset                                                          rhel8                                                                                                           
 nvidia-driver                                                         latest-dkms                                                                                                     

Transaction Summary
========================================================================================================================================================================================
Install  224 Packages

Total download size: 2.6 G
Installed size: 5.1 G
Downloading Packages:
(1/224): cuda-10-2-10.2.89-1.x86_64.rpm                                                                                                                 330 kB/s | 6.1 kB     00:00    
(2/224): cuda-10.2.89-1.x86_64.rpm                                                                                                                      322 kB/s | 6.1 kB     00:00    
(3/224): cuda-compiler-10-2-10.2.89-1.x86_64.rpm                                                                                                        603 kB/s | 6.1 kB     00:00    
(4/224): cuda-command-line-tools-10-2-10.2.89-1.x86_64.rpm                                                                                              567 kB/s | 6.2 kB     00:00    
(5/224): cuda-cudart-10-2-10.2.89-1.x86_64.rpm                                                                                                          5.6 MB/s | 151 kB     00:00    
(6/224): cuda-cudart-dev-10-2-10.2.89-1.x86_64.rpm                                                                                                      9.4 MB/s | 861 kB     00:00    
(7/224): NsightSystems-linux-public-2019.5.2.16-b54ef97.rpm                                                                                              55 MB/s | 109 MB     00:01    
(8/224): cuda-cuobjdump-10-2-10.2.89-1.x86_64.rpm                                                                                                       7.8 MB/s | 106 kB     00:00    
(9/224): cuda-cupti-10-2-10.2.89-1.x86_64.rpm                                                                                                            45 MB/s |  15 MB     00:00    
(10/224): cuda-curand-10-2-10.2.89-1.x86_64.rpm                                                                                                          45 MB/s |  42 MB     00:00    
(11/224): cuda-curand-dev-10-2-10.2.89-1.x86_64.rpm                                                                                                      39 MB/s |  43 MB     00:01    
(12/224): cuda-cufft-10-2-10.2.89-1.x86_64.rpm                                                                                                           22 MB/s | 108 MB     00:05    
(13/224): cuda-cusolver-dev-10-2-10.2.89-1.x86_64.rpm                                                                                                    36 MB/s |  29 MB     00:00    
(14/224): cuda-cufft-dev-10-2-10.2.89-1.x86_64.rpm                                                                                                       27 MB/s | 206 MB     00:07    
(15/224): cuda-cusolver-10-2-10.2.89-1.x86_64.rpm                                                                                                        31 MB/s | 129 MB     00:04    
(16/224): cuda-cusparse-10-2-10.2.89-1.x86_64.rpm                                                                                                        28 MB/s |  79 MB     00:02    
(17/224): cuda-demo-suite-10-2-10.2.89-1.x86_64.rpm                                                                                                      16 MB/s | 4.7 MB     00:00    
(18/224): cuda-driver-dev-10-2-10.2.89-1.x86_64.rpm                                                                                                     1.6 MB/s |  20 kB     00:00    
(19/224): cuda-drivers-440.33.01-1.x86_64.rpm                                                                                                           621 kB/s | 6.8 kB     00:00    
(20/224): cuda-gdb-10-2-10.2.89-1.x86_64.rpm                                                                                                             31 MB/s | 3.5 MB     00:00    
(21/224): cuda-libraries-10-2-10.2.89-1.x86_64.rpm                                                                                                      615 kB/s | 6.3 kB     00:00    
(22/224): cuda-libraries-dev-10-2-10.2.89-1.x86_64.rpm                                                                                                  627 kB/s | 6.4 kB     00:00    
(23/224): cuda-license-10-2-10.2.89-1.x86_64.rpm                                                                                                        2.0 MB/s |  22 kB     00:00    
(24/224): cuda-memcheck-10-2-10.2.89-1.x86_64.rpm                                                                                                       421 kB/s | 180 kB     00:00    
(25/224): cuda-misc-headers-10-2-10.2.89-1.x86_64.rpm                                                                                                    27 MB/s | 1.7 MB     00:00    
(26/224): cuda-cusparse-dev-10-2-10.2.89-1.x86_64.rpm                                                                                                    36 MB/s | 159 MB     00:04    
(27/224): cuda-npp-10-2-10.2.89-1.x86_64.rpm                                                                                                             26 MB/s |  86 MB     00:03    
(28/224): cuda-documentation-10-2-10.2.89-1.x86_64.rpm                                                                                                   29 MB/s | 132 MB     00:04    
(29/224): cuda-nsight-compute-10-2-10.2.89-1.x86_64.rpm                                                                                                 697 kB/s | 7.8 kB     00:00    
(30/224): cuda-nsight-systems-10-2-10.2.89-1.x86_64.rpm                                                                                                 691 kB/s | 7.3 kB     00:00    
(31/224): cuda-nvcc-10-2-10.2.89-1.x86_64.rpm                                                                                                            41 MB/s |  48 MB     00:01    
(32/224): cuda-nvdisasm-10-2-10.2.89-1.x86_64.rpm                                                                                                        41 MB/s |  21 MB     00:00    
(33/224): cuda-npp-dev-10-2-10.2.89-1.x86_64.rpm                                                                                                         28 MB/s |  86 MB     00:03    
(34/224): cuda-nvgraph-dev-10-2-10.2.89-1.x86_64.rpm                                                                                                     32 MB/s |  57 MB     00:01    
(35/224): cuda-nvgraph-10-2-10.2.89-1.x86_64.rpm                                                                                                         35 MB/s |  97 MB     00:02    
(36/224): cuda-nvjpeg-dev-10-2-10.2.89-1.x86_64.rpm                                                                                                      37 MB/s | 1.8 MB     00:00    
(37/224): cuda-nvml-dev-10-2-10.2.89-1.x86_64.rpm                                                                                                       6.0 MB/s |  71 kB     00:00    
(38/224): cuda-nvjpeg-10-2-10.2.89-1.x86_64.rpm                                                                                                         2.4 MB/s | 1.7 MB     00:00    
(39/224): cuda-nvprune-10-2-10.2.89-1.x86_64.rpm                                                                                                        3.7 MB/s |  49 kB     00:00    
(40/224): cuda-nvprof-10-2-10.2.89-1.x86_64.rpm                                                                                                          35 MB/s | 3.8 MB     00:00    
(41/224): cuda-nvrtc-dev-10-2-10.2.89-1.x86_64.rpm                                                                                                      1.0 MB/s |  14 kB     00:00    
(42/224): cuda-nvtx-10-2-10.2.89-1.x86_64.rpm                                                                                                           5.6 MB/s |  68 kB     00:00    
(43/224): cuda-nvrtc-10-2-10.2.89-1.x86_64.rpm                                                                                                           39 MB/s | 8.9 MB     00:00    
(44/224): cuda-runtime-10-2-10.2.89-1.x86_64.rpm                                                                                                        551 kB/s | 6.1 kB     00:00    
(45/224): cuda-samples-10-2-10.2.89-1.x86_64.rpm                                                                                                         44 MB/s |  89 MB     00:02    
(46/224): cuda-sanitizer-api-10-2-10.2.89-1.x86_64.rpm                                                                                                   38 MB/s | 3.5 MB     00:00    
(47/224): cuda-toolkit-10-2-10.2.89-1.x86_64.rpm                                                                                                        536 kB/s | 6.7 kB     00:00    
(48/224): cuda-tools-10-2-10.2.89-1.x86_64.rpm                                                                                                          628 kB/s | 6.0 kB     00:00    
(49/224): cuda-visual-tools-10-2-10.2.89-1.x86_64.rpm                                                                                                   603 kB/s | 6.8 kB     00:00    
(50/224): dnf-plugin-nvidia-1.1-1.el8.noarch.rpm                                                                                                        766 kB/s | 8.5 kB     00:00    
(51/224): kmod-nvidia-latest-dkms-440.33.01-1.el8.x86_64.rpm                                                                                             41 MB/s |  14 MB     00:00    
(52/224): cuda-nsight-10-2-10.2.89-1.x86_64.rpm                                                                                                          31 MB/s | 268 MB     00:08    
(53/224): libcublas10-10.2.2.89-1.x86_64.rpm                                                                                                             39 MB/s |  58 MB     00:01    
(54/224): libcublas-devel-10.2.2.89-1.x86_64.rpm                                                                                                         19 MB/s |  60 MB     00:03    
(55/224): cuda-nvvp-10-2-10.2.89-1.x86_64.rpm                                                                                                            19 MB/s | 114 MB     00:06    
(56/224): nvidia-driver-440.33.01-1.el8.x86_64.rpm                                                                                                       17 MB/s | 5.3 MB     00:00    
(57/224): nvidia-driver-NVML-440.33.01-1.el8.x86_64.rpm                                                                                                  16 MB/s | 523 kB     00:00    
(58/224): nvidia-driver-NvFBCOpenGL-440.33.01-1.el8.x86_64.rpm                                                                                           11 MB/s | 136 kB     00:00    
(59/224): nvidia-driver-cuda-440.33.01-1.el8.x86_64.rpm                                                                                                 723 kB/s | 392 kB     00:00    
(60/224): nvidia-driver-devel-440.33.01-1.el8.x86_64.rpm                                                                                                1.1 MB/s |  12 kB     00:00    
(61/224): nvidia-driver-cuda-libs-440.33.01-1.el8.x86_64.rpm                                                                                             54 MB/s |  34 MB     00:00    
(62/224): nvidia-kmod-common-440.33.01-1.el8.noarch.rpm                                                                                                 703 kB/s | 9.8 kB     00:00    
(63/224): nvidia-libXNVCtrl-440.33.01-1.el8.x86_64.rpm                                                                                                  5.0 MB/s |  58 kB     00:00    
(64/224): nvidia-libXNVCtrl-devel-440.33.01-1.el8.x86_64.rpm                                                                                            5.3 MB/s |  60 kB     00:00    
(65/224): nvidia-modprobe-440.33.01-1.el8.x86_64.rpm                                                                                                    6.4 MB/s |  77 kB     00:00    
(66/224): nvidia-persistenced-440.33.01-1.el8.x86_64.rpm                                                                                                9.0 MB/s | 111 kB     00:00    
(67/224): nvidia-settings-440.33.01-1.el8.x86_64.rpm                                                                                                    2.0 MB/s | 2.3 MB     00:01    
(68/224): nvidia-xconfig-440.33.01-1.el8.x86_64.rpm                                                                                                      15 MB/s | 319 kB     00:00    
(69/224): dkms-2.7.1-2.el8.noarch.rpm                                                                                                                   788 kB/s |  79 kB     00:00    
(70/224): nvidia-driver-libs-440.33.01-1.el8.x86_64.rpm                                                                                                  48 MB/s |  80 MB     00:01    
(71/224): make-4.2.1-9.el8.x86_64.rpm                                                                                                                   1.3 MB/s | 498 kB     00:00    
(72/224): libpkgconf-1.4.2-1.el8.x86_64.rpm                                                                                                             106 kB/s |  35 kB     00:00    
(73/224): libmodman-2.0.1-17.el8.x86_64.rpm                                                                                                              71 kB/s |  36 kB     00:00    
(74/224): pkgconf-m4-1.4.2-1.el8.noarch.rpm                                                                                                              50 kB/s |  17 kB     00:00    
(75/224): pkgconf-1.4.2-1.el8.x86_64.rpm                                                                                                                102 kB/s |  38 kB     00:00    
(76/224): libproxy-0.4.15-5.2.el8.x86_64.rpm                                                                                                            219 kB/s |  74 kB     00:00    
(77/224): avahi-libs-0.7-19.el8.x86_64.rpm                                                                                                              208 kB/s |  63 kB     00:00    
(78/224): glib-networking-2.56.1-1.1.el8.x86_64.rpm                                                                                                     408 kB/s | 155 kB     00:00    
(79/224): libxcrypt-devel-4.1.1-4.el8.x86_64.rpm                                                                                                         84 kB/s |  25 kB     00:00    
(80/224): libsoup-2.62.3-1.el8.x86_64.rpm                                                                                                               904 kB/s | 424 kB     00:00    
(81/224): nsight-compute-2019.4.0-2019.4.0.12-1.x86_64.rpm                                                                                               47 MB/s | 257 MB     00:05    
(82/224): fontpackages-filesystem-1.44-22.el8.noarch.rpm                                                                                                 21 kB/s |  16 kB     00:00    
(83/224): libgusb-0.3.0-1.el8.x86_64.rpm                                                                                                                 88 kB/s |  49 kB     00:00    
(84/224): libpciaccess-0.14-1.el8.x86_64.rpm                                                                                                            111 kB/s |  32 kB     00:00    
(85/224): lksctp-tools-1.0.18-3.el8.x86_64.rpm                                                                                                          309 kB/s | 100 kB     00:00    
(86/224): tar-1.30-4.el8.x86_64.rpm                                                                                                                     2.1 MB/s | 838 kB     00:00    
(87/224): fontconfig-2.13.1-3.el8.x86_64.rpm                                                                                                            849 kB/s | 275 kB     00:00    
(88/224): zlib-devel-1.2.11-10.el8.x86_64.rpm                                                                                                           173 kB/s |  56 kB     00:00    
(89/224): binutils-2.30-58.el8.x86_64.rpm                                                                                                                15 MB/s | 5.7 MB     00:00    
(90/224): elfutils-libelf-devel-0.176-5.el8.x86_64.rpm                                                                                                  178 kB/s |  54 kB     00:00    
(91/224): gdk-pixbuf2-2.36.12-5.el8.x86_64.rpm                                                                                                          1.4 MB/s | 467 kB     00:00    
(92/224): gsettings-desktop-schemas-3.32.0-3.el8.x86_64.rpm                                                                                             1.9 MB/s | 632 kB     00:00    
(93/224): glibc-devel-2.28-72.el8.x86_64.rpm                                                                                                            2.9 MB/s | 1.0 MB     00:00    
(94/224): pkgconf-pkg-config-1.4.2-1.el8.x86_64.rpm                                                                                                      38 kB/s |  15 kB     00:00    
(95/224): cups-libs-2.2.6-28.el8.x86_64.rpm                                                                                                             1.3 MB/s | 433 kB     00:00    
(96/224): glibc-headers-2.28-72.el8.x86_64.rpm                                                                                                          1.4 MB/s | 469 kB     00:00    
(97/224): kernel-headers-4.18.0-147.0.3.el8_1.x86_64.rpm                                                                                                6.9 MB/s | 2.7 MB     00:00    
(98/224): libX11-common-1.6.7-1.el8.noarch.rpm                                                                                                          298 kB/s | 157 kB     00:00    
(99/224): opencl-filesystem-1.0-6.el8.noarch.rpm                                                                                                         26 kB/s | 8.5 kB     00:00    
(100/224): adwaita-icon-theme-3.28.0-2.el8.noarch.rpm                                                                                                    20 MB/s |  11 MB     00:00    
(101/224): adwaita-cursor-theme-3.28.0-2.el8.noarch.rpm                                                                                                 2.1 MB/s | 647 kB     00:00    
(102/224): xorg-x11-proto-devel-2018.4-1.el8.noarch.rpm                                                                                                 716 kB/s | 283 kB     00:00    
(103/224): javapackages-filesystem-5.3.0-1.module+el8+2447+6f56d9a6.noarch.rpm                                                                           90 kB/s |  30 kB     00:00    
(104/224): abattis-cantarell-fonts-0.0.25-4.el8.noarch.rpm                                                                                              524 kB/s | 155 kB     00:00    
(105/224): libXdmcp-1.1.2-11.el8.x86_64.rpm                                                                                                             125 kB/s |  40 kB     00:00    
(106/224): xorg-x11-fonts-Type1-7.5-19.el8.noarch.rpm                                                                                                   1.5 MB/s | 522 kB     00:00    
(107/224): libglvnd-opengl-1.0.1-0.9.git5baa1e5.el8.x86_64.rpm                                                                                           88 kB/s |  48 kB     00:00    
(108/224): copy-jdk-configs-3.7-1.el8.noarch.rpm                                                                                                         93 kB/s |  27 kB     00:00    
(109/224): hicolor-icon-theme-0.17-2.el8.noarch.rpm                                                                                                     125 kB/s |  48 kB     00:00    
(110/224): libwacom-data-0.31-1.el8.noarch.rpm                                                                                                          222 kB/s |  76 kB     00:00    
(111/224): libxcb-1.13-5.el8.x86_64.rpm                                                                                                                 563 kB/s | 230 kB     00:00    
(112/224): lcms2-2.9-2.el8.x86_64.rpm                                                                                                                   463 kB/s | 165 kB     00:00    
(113/224): mesa-libGLU-devel-9.0.0-15.el8.x86_64.rpm                                                                                                     45 kB/s |  15 kB     00:00    
(114/224): gl-manpages-1.1-15.20161227.el8.noarch.rpm                                                                                                   2.2 MB/s | 1.2 MB     00:00    
(115/224): libXi-devel-1.7.9-7.el8.x86_64.rpm                                                                                                           383 kB/s | 111 kB     00:00    
(116/224): libXdamage-devel-1.1.4-14.el8.x86_64.rpm                                                                                                      46 kB/s |  15 kB     00:00    
(117/224): jbigkit-libs-2.1-14.el8.x86_64.rpm                                                                                                           147 kB/s |  55 kB     00:00    
(118/224): libXext-1.3.3-9.el8.x86_64.rpm                                                                                                               153 kB/s |  45 kB     00:00    
(119/224): libXi-1.7.9-7.el8.x86_64.rpm                                                                                                                 148 kB/s |  49 kB     00:00    
(120/224): ocl-icd-2.2.12-1.el8.x86_64.rpm                                                                                                              134 kB/s |  51 kB     00:00    
(121/224): libXtst-1.2.3-7.el8.x86_64.rpm                                                                                                                75 kB/s |  22 kB     00:00    
(122/224): libXinerama-1.1.4-1.el8.x86_64.rpm                                                                                                            46 kB/s |  16 kB     00:00    
(123/224): libglvnd-egl-1.0.1-0.9.git5baa1e5.el8.x86_64.rpm                                                                                             139 kB/s |  50 kB     00:00    
(124/224): libglvnd-core-devel-1.0.1-0.9.git5baa1e5.el8.x86_64.rpm                                                                                       88 kB/s |  24 kB     00:00    
(125/224): libmpc-1.0.2-9.el8.x86_64.rpm                                                                                                                157 kB/s |  59 kB     00:00    
(126/224): xorg-x11-xkb-utils-7.7-27.el8.x86_64.rpm                                                                                                     371 kB/s | 114 kB     00:00    
(127/224): libvdpau-1.1.1-7.el8.x86_64.rpm                                                                                                              131 kB/s |  40 kB     00:00    
(128/224): at-spi2-core-2.28.0-1.el8.x86_64.rpm                                                                                                         396 kB/s | 169 kB     00:00    
(129/224): ttmkfdir-3.0.9-54.el8.x86_64.rpm                                                                                                             194 kB/s |  62 kB     00:00    
(130/224): graphite2-1.3.10-10.el8.x86_64.rpm                                                                                                           392 kB/s | 122 kB     00:00    
(131/224): libXfixes-devel-5.0.3-7.el8.x86_64.rpm                                                                                                        65 kB/s |  19 kB     00:00    
(132/224): libXrandr-1.5.1-7.el8.x86_64.rpm                                                                                                             110 kB/s |  33 kB     00:00    
(133/224): libXcursor-1.1.15-3.el8.x86_64.rpm                                                                                                            71 kB/s |  36 kB     00:00    
(134/224): at-spi2-atk-2.26.2-1.el8.x86_64.rpm                                                                                                          221 kB/s |  89 kB     00:00    
(135/224): xorg-x11-drv-libinput-0.28.0-2.el8.x86_64.rpm                                                                                                161 kB/s |  50 kB     00:00    
(136/224): libwayland-egl-1.15.0-1.el8.x86_64.rpm                                                                                                        54 kB/s |  19 kB     00:00    
(137/224): libX11-devel-1.6.7-1.el8.x86_64.rpm                                                                                                          2.7 MB/s | 977 kB     00:00    
(138/224): libXfont2-2.0.3-2.el8.x86_64.rpm                                                                                                             487 kB/s | 149 kB     00:00    
(139/224): jasper-libs-2.0.14-4.el8.x86_64.rpm                                                                                                          519 kB/s | 167 kB     00:00    
(140/224): libSM-1.2.3-1.el8.x86_64.rpm                                                                                                                 152 kB/s |  48 kB     00:00    
(141/224): libwayland-server-1.15.0-1.el8.x86_64.rpm                                                                                                    152 kB/s |  45 kB     00:00    
(142/224): libwayland-cursor-1.15.0-1.el8.x86_64.rpm                                                                                                     81 kB/s |  26 kB     00:00    
(143/224): libxkbfile-1.0.9-9.el8.x86_64.rpm                                                                                                            263 kB/s |  86 kB     00:00    
(144/224): libXft-2.3.2-10.el8.x86_64.rpm                                                                                                               189 kB/s |  66 kB     00:00    
(145/224): libXfixes-5.0.3-7.el8.x86_64.rpm                                                                                                              82 kB/s |  25 kB     00:00    
(146/224): cairo-gobject-1.15.12-3.el8.x86_64.rpm                                                                                                       113 kB/s |  33 kB     00:00    
(147/224): libglvnd-1.0.1-0.9.git5baa1e5.el8.x86_64.rpm                                                                                                 302 kB/s |  96 kB     00:00    
(148/224): dconf-0.28.0-3.el8.x86_64.rpm                                                                                                                231 kB/s | 109 kB     00:00    
(149/224): libXau-1.0.8-13.el8.x86_64.rpm                                                                                                               111 kB/s |  36 kB     00:00    
(150/224): libglvnd-gles-1.0.1-0.9.git5baa1e5.el8.x86_64.rpm                                                                                             88 kB/s |  41 kB     00:00    
(151/224): freeglut-3.0.0-8.el8.x86_64.rpm                                                                                                              507 kB/s | 191 kB     00:00    
(152/224): libepoxy-1.5.2-1.el8.x86_64.rpm                                                                                                              498 kB/s | 225 kB     00:00    
(153/224): freeglut-devel-3.0.0-8.el8.x86_64.rpm                                                                                                        327 kB/s | 121 kB     00:00    
(154/224): egl-wayland-1.1.2-1.el8.x86_64.rpm                                                                                                            87 kB/s |  33 kB     00:00    
(155/224): xorg-x11-drv-vesa-2.4.0-3.el8.x86_64.rpm                                                                                                     103 kB/s |  31 kB     00:00    
(156/224): libwacom-0.31-1.el8.x86_64.rpm                                                                                                               127 kB/s |  42 kB     00:00    
(157/224): libXxf86vm-1.1.4-9.el8.x86_64.rpm                                                                                                             56 kB/s |  19 kB     00:00    
(158/224): xorg-x11-drv-fbdev-0.5.0-2.el8.x86_64.rpm                                                                                                     56 kB/s |  27 kB     00:00    
(159/224): libthai-0.1.27-2.el8.x86_64.rpm                                                                                                              459 kB/s | 203 kB     00:00    
(160/224): colord-libs-1.4.2-1.el8.x86_64.rpm                                                                                                           741 kB/s | 236 kB     00:00    
(161/224): rest-0.8.1-2.el8.x86_64.rpm                                                                                                                  207 kB/s |  71 kB     00:00    
(162/224): libXdamage-1.1.4-14.el8.x86_64.rpm                                                                                                            75 kB/s |  27 kB     00:00    
(163/224): libXmu-devel-1.1.2-12.el8.x86_64.rpm                                                                                                          85 kB/s |  25 kB     00:00    
(164/224): libSM-devel-1.2.3-1.el8.x86_64.rpm                                                                                                            62 kB/s |  18 kB     00:00    
(165/224): cairo-1.15.12-3.el8.x86_64.rpm                                                                                                               2.1 MB/s | 721 kB     00:00    
(166/224): harfbuzz-1.7.5-3.el8.x86_64.rpm                                                                                                              742 kB/s | 294 kB     00:00    
(167/224): libXxf86vm-devel-1.1.4-9.el8.x86_64.rpm                                                                                                       53 kB/s |  20 kB     00:00    
(168/224): mesa-libGLU-9.0.0-15.el8.x86_64.rpm                                                                                                          587 kB/s | 185 kB     00:00    
(169/224): libXcomposite-0.4.4-14.el8.x86_64.rpm                                                                                                        101 kB/s |  29 kB     00:00    
(170/224): libwayland-client-1.15.0-1.el8.x86_64.rpm                                                                                                    107 kB/s |  39 kB     00:00    
(171/224): libfontenc-1.1.3-8.el8.x86_64.rpm                                                                                                             87 kB/s |  37 kB     00:00    
(172/224): libX11-xcb-1.6.7-1.el8.x86_64.rpm                                                                                                             28 kB/s |  14 kB     00:00    
(173/224): libxcb-devel-1.13-5.el8.x86_64.rpm                                                                                                           2.0 MB/s | 1.1 MB     00:00    
(174/224): libX11-1.6.7-1.el8.x86_64.rpm                                                                                                                1.2 MB/s | 612 kB     00:00    
(175/224): fribidi-1.0.4-6.el8.x86_64.rpm                                                                                                               246 kB/s |  89 kB     00:00    
(176/224): libXrender-0.9.10-7.el8.x86_64.rpm                                                                                                            94 kB/s |  33 kB     00:00    
(177/224): libdatrie-0.2.9-7.el8.x86_64.rpm                                                                                                             106 kB/s |  33 kB     00:00    
(178/224): atk-2.28.1-1.el8.x86_64.rpm                                                                                                                  671 kB/s | 272 kB     00:00    
(179/224): libxshmfence-1.3-2.el8.x86_64.rpm                                                                                                             43 kB/s |  13 kB     00:00    
(180/224): giflib-5.1.4-3.el8.x86_64.rpm                                                                                                                165 kB/s |  51 kB     00:00    
(181/224): gtk2-2.24.32-4.el8.x86_64.rpm                                                                                                                8.6 MB/s | 3.4 MB     00:00    
(182/224): libXext-devel-1.3.3-9.el8.x86_64.rpm                                                                                                         234 kB/s |  80 kB     00:00    
(183/224): libevdev-1.5.9-5.el8.x86_64.rpm                                                                                                              132 kB/s |  42 kB     00:00    
(184/224): isl-0.16.1-6.el8.x86_64.rpm                                                                                                                  2.2 MB/s | 841 kB     00:00    
(185/224): libXau-devel-1.0.8-13.el8.x86_64.rpm                                                                                                          54 kB/s |  20 kB     00:00    
(186/224): libXmu-1.1.2-12.el8.x86_64.rpm                                                                                                               197 kB/s |  74 kB     00:00    
(187/224): pixman-0.36.0-1.el8.x86_64.rpm                                                                                                               556 kB/s | 257 kB     00:00    
(188/224): mtdev-1.1.5-12.el8.x86_64.rpm                                                                                                                 72 kB/s |  24 kB     00:00    
(189/224): libglvnd-glx-1.0.1-0.9.git5baa1e5.el8.x86_64.rpm                                                                                             391 kB/s | 131 kB     00:00    
(190/224): xorg-x11-font-utils-7.5-40.el8.x86_64.rpm                                                                                                    292 kB/s | 103 kB     00:00    
(191/224): libglvnd-devel-1.0.1-0.9.git5baa1e5.el8.x86_64.rpm                                                                                            38 kB/s |  16 kB     00:00    
(192/224): libXt-1.1.5-12.el8.x86_64.rpm                                                                                                                525 kB/s | 185 kB     00:00    
(193/224): tzdata-java-2019c-1.el8.noarch.rpm                                                                                                           517 kB/s | 189 kB     00:00    
(194/224): mesa-libEGL-19.1.4-2.el8.x86_64.rpm                                                                                                          449 kB/s | 131 kB     00:00    
(195/224): mesa-libGL-devel-19.1.4-2.el8.x86_64.rpm                                                                                                     519 kB/s | 177 kB     00:00    
(196/224): libjpeg-turbo-1.5.3-10.el8.x86_64.rpm                                                                                                        468 kB/s | 156 kB     00:00    
(197/224): mesa-vulkan-drivers-19.1.4-2.el8.x86_64.rpm                                                                                                  7.1 MB/s | 2.6 MB     00:00    
(198/224): gcc-8.3.1-4.5.el8.x86_64.rpm                                                                                                                  25 MB/s |  23 MB     00:00    
(199/224): mesa-libglapi-19.1.4-2.el8.x86_64.rpm                                                                                                        160 kB/s |  61 kB     00:00    
(200/224): alsa-lib-1.1.9-4.el8.x86_64.rpm                                                                                                              1.4 MB/s | 429 kB     00:00    
(201/224): libXt-devel-1.1.5-12.el8.x86_64.rpm                                                                                                          1.4 MB/s | 452 kB     00:00    
(202/224): xorg-x11-server-common-1.20.3-11.el8.x86_64.rpm                                                                                              125 kB/s |  40 kB     00:00    
(203/224): gcc-c++-8.3.1-4.5.el8.x86_64.rpm                                                                                                              15 MB/s |  12 MB     00:00    
(204/224): xorg-x11-server-Xorg-1.20.3-11.el8.x86_64.rpm                                                                                                3.3 MB/s | 1.5 MB     00:00    
(205/224): cpp-8.3.1-4.5.el8.x86_64.rpm                                                                                                                  20 MB/s |  10 MB     00:00    
(206/224): pango-1.42.4-6.el8.x86_64.rpm                                                                                                                937 kB/s | 298 kB     00:00    
(207/224): gtk-update-icon-cache-3.22.30-4.el8.x86_64.rpm                                                                                                95 kB/s |  33 kB     00:00    
(208/224): libtiff-4.0.9-15.el8.x86_64.rpm                                                                                                              594 kB/s | 188 kB     00:00    
(209/224): mesa-libgbm-19.1.4-2.el8.x86_64.rpm                                                                                                          186 kB/s |  55 kB     00:00    
(210/224): libdrm-2.4.98-2.el8.x86_64.rpm                                                                                                               530 kB/s | 165 kB     00:00    
(211/224): lua-5.3.4-11.el8.x86_64.rpm                                                                                                                  674 kB/s | 193 kB     00:00    
(212/224): libICE-devel-1.0.9-15.el8.x86_64.rpm                                                                                                         193 kB/s |  55 kB     00:00    
(213/224): mesa-khr-devel-19.1.4-2.el8.x86_64.rpm                                                                                                       107 kB/s |  33 kB     00:00    
(214/224): libdrm-devel-2.4.98-2.el8.x86_64.rpm                                                                                                         479 kB/s | 156 kB     00:00    
(215/224): vulkan-loader-1.1.114.0-3.el8.x86_64.rpm                                                                                                     389 kB/s | 113 kB     00:00    
(216/224): java-1.8.0-openjdk-1.8.0.232.b09-2.el8_1.x86_64.rpm                                                                                          963 kB/s | 317 kB     00:00    
(217/224): gdk-pixbuf2-modules-2.36.12-5.el8.x86_64.rpm                                                                                                 390 kB/s | 109 kB     00:00    
(218/224): mesa-libGL-19.1.4-2.el8.x86_64.rpm                                                                                                           552 kB/s | 184 kB     00:00    
(219/224): llvm-libs-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64.rpm                                                                                     23 MB/s |  18 MB     00:00    
(220/224): gtk3-3.22.30-4.el8.x86_64.rpm                                                                                                                4.4 MB/s | 4.5 MB     00:01    
(221/224): java-1.8.0-openjdk-headless-1.8.0.232.b09-2.el8_1.x86_64.rpm                                                                                  28 MB/s |  33 MB     00:01    
(222/224): libinput-1.13.2-1.el8.x86_64.rpm                                                                                                             639 kB/s | 198 kB     00:00    
(223/224): libstdc++-devel-8.3.1-4.5.el8.x86_64.rpm                                                                                                     4.4 MB/s | 2.0 MB     00:00    
(224/224): libICE-1.0.9-15.el8.x86_64.rpm                                                                                                               138 kB/s |  74 kB     00:00    
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                    55 MB/s | 2.6 GB     00:47     
warning: /var/cache/dnf/cuda-3a207caebcd365bb/packages/NsightSystems-linux-public-2019.5.2.16-b54ef97.rpm: Header V4 RSA/SHA512 Signature, key ID 7fa2af80: NOKEY
cuda                                                                                                                                                     88 kB/s | 1.6 kB     00:00    
Importing GPG key 0x7FA2AF80:
 Userid     : "cudatools <cudatools@nvidia.com>"
 Fingerprint: AE09 FE4B BD22 3A84 B2CC FCE3 F60F 4B3D 7FA2 AF80
 From       : http://developer.download.nvidia.com/compute/cuda/repos/rhel8/x86_64/7fa2af80.pub
Key imported successfully
warning: /var/cache/dnf/epel-fafd94c310c51e1e/packages/dkms-2.7.1-2.el8.noarch.rpm: Header V3 RSA/SHA256 Signature, key ID 2f86d6a1: NOKEY
Extra Packages for Enterprise Linux 8 - x86_64                                                                                                          1.6 MB/s | 1.6 kB     00:00    
Importing GPG key 0x2F86D6A1:
 Userid     : "Fedora EPEL (8) <epel@fedoraproject.org>"
 Fingerprint: 94E2 79EB 8D8F 25B2 1810 ADF1 21EA 45AB 2F86 D6A1
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-8
Key imported successfully
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Running scriptlet: copy-jdk-configs-3.7-1.el8.noarch                                                                                                                              1/1 
  Running scriptlet: java-1.8.0-openjdk-headless-1:1.8.0.232.b09-2.el8_1.x86_64                                                                                                     1/1 
  Running scriptlet: cuda-drivers-440.33.01-1.x86_64                                                                                                                                1/1 
Removing existing driver runfile install
/var/tmp/rpm-tmp.ZEVFtv: line 3: nvidia-uninstall: command not found

  Preparing        :                                                                                                                                                                1/1 
  Running scriptlet: cuda-license-10-2-10.2.89-1.x86_64                                                                                                                           1/224 
  Installing       : cuda-license-10-2-10.2.89-1.x86_64                                                                                                                           1/224 
  Running scriptlet: cuda-license-10-2-10.2.89-1.x86_64                                                                                                                           1/224 
*** LICENSE AGREEMENT ***
By using this software you agree to fully comply with the terms and 
conditions of the EULA (End User License Agreement). The EULA is located
at /usr/local/cuda-10.2/doc/EULA.txt. The EULA can also be found at
http://docs.nvidia.com/cuda/eula/index.html. If you do not agree to the
terms and conditions of the EULA, do not use the software.

  Installing       : libglvnd-1:1.0.1-0.9.git5baa1e5.el8.x86_64                                                                                                                   2/224 
  Installing       : libjpeg-turbo-1.5.3-10.el8.x86_64                                                                                                                            3/224 
  Installing       : libwayland-client-1.15.0-1.el8.x86_64                                                                                                                        4/224 
  Installing       : gdk-pixbuf2-2.36.12-5.el8.x86_64                                                                                                                             5/224 
  Running scriptlet: gdk-pixbuf2-2.36.12-5.el8.x86_64                                                                                                                             5/224 
  Installing       : nvidia-driver-cuda-libs-3:440.33.01-1.el8.x86_64                                                                                                             6/224 
  Running scriptlet: nvidia-driver-cuda-libs-3:440.33.01-1.el8.x86_64                                                                                                             6/224 
  Installing       : cuda-driver-dev-10-2-10.2.89-1.x86_64                                                                                                                        7/224 
  Installing       : cuda-nvml-dev-10-2-10.2.89-1.x86_64                                                                                                                          8/224 
  Installing       : libICE-1.0.9-15.el8.x86_64                                                                                                                                   9/224 
  Installing       : pixman-0.36.0-1.el8.x86_64                                                                                                                                  10/224 
  Installing       : libxshmfence-1.3-2.el8.x86_64                                                                                                                               11/224 
  Installing       : atk-2.28.1-1.el8.x86_64                                                                                                                                     12/224 
  Installing       : libX11-xcb-1.6.7-1.el8.x86_64                                                                                                                               13/224 
  Installing       : cuda-nvdisasm-10-2-10.2.89-1.x86_64                                                                                                                         14/224 
  Installing       : mesa-libglapi-19.1.4-2.el8.x86_64                                                                                                                           15/224 
  Running scriptlet: mesa-libglapi-19.1.4-2.el8.x86_64                                                                                                                           15/224 
  Installing       : libXau-1.0.8-13.el8.x86_64                                                                                                                                  16/224 
  Installing       : libxcb-1.13-5.el8.x86_64                                                                                                                                    17/224 
  Installing       : libwayland-server-1.15.0-1.el8.x86_64                                                                                                                       18/224 
  Installing       : libmpc-1.0.2-9.el8.x86_64                                                                                                                                   19/224 
  Running scriptlet: libmpc-1.0.2-9.el8.x86_64                                                                                                                                   19/224 
  Installing       : libSM-1.2.3-1.el8.x86_64                                                                                                                                    20/224 
  Installing       : gtk-update-icon-cache-3.22.30-4.el8.x86_64                                                                                                                  21/224 
  Installing       : libglvnd-opengl-1:1.0.1-0.9.git5baa1e5.el8.x86_64                                                                                                           22/224 
  Installing       : cuda-cudart-10-2-10.2.89-1.x86_64                                                                                                                           23/224 
  Running scriptlet: cuda-cudart-10-2-10.2.89-1.x86_64                                                                                                                           23/224 
  Installing       : cuda-cudart-dev-10-2-10.2.89-1.x86_64                                                                                                                       24/224 
  Installing       : cuda-cufft-10-2-10.2.89-1.x86_64                                                                                                                            25/224 
  Running scriptlet: cuda-cufft-10-2-10.2.89-1.x86_64                                                                                                                            25/224 
  Installing       : cuda-cufft-dev-10-2-10.2.89-1.x86_64                                                                                                                        26/224 
  Installing       : cuda-cuobjdump-10-2-10.2.89-1.x86_64                                                                                                                        27/224 
  Installing       : cuda-curand-10-2-10.2.89-1.x86_64                                                                                                                           28/224 
  Running scriptlet: cuda-curand-10-2-10.2.89-1.x86_64                                                                                                                           28/224 
  Installing       : cuda-curand-dev-10-2-10.2.89-1.x86_64                                                                                                                       29/224 
  Installing       : cuda-cusolver-10-2-10.2.89-1.x86_64                                                                                                                         30/224 
  Running scriptlet: cuda-cusolver-10-2-10.2.89-1.x86_64                                                                                                                         30/224 
  Installing       : cuda-cusolver-dev-10-2-10.2.89-1.x86_64                                                                                                                     31/224 
  Installing       : cuda-cusparse-10-2-10.2.89-1.x86_64                                                                                                                         32/224 
  Running scriptlet: cuda-cusparse-10-2-10.2.89-1.x86_64                                                                                                                         32/224 
  Installing       : cuda-cusparse-dev-10-2-10.2.89-1.x86_64                                                                                                                     33/224 
  Installing       : cuda-misc-headers-10-2-10.2.89-1.x86_64                                                                                                                     34/224 
  Installing       : cuda-npp-10-2-10.2.89-1.x86_64                                                                                                                              35/224 
  Running scriptlet: cuda-npp-10-2-10.2.89-1.x86_64                                                                                                                              35/224 
  Installing       : cuda-npp-dev-10-2-10.2.89-1.x86_64                                                                                                                          36/224 
  Installing       : cuda-nvgraph-10-2-10.2.89-1.x86_64                                                                                                                          37/224 
  Running scriptlet: cuda-nvgraph-10-2-10.2.89-1.x86_64                                                                                                                          37/224 
  Installing       : cuda-nvgraph-dev-10-2-10.2.89-1.x86_64                                                                                                                      38/224 
  Installing       : cuda-nvjpeg-10-2-10.2.89-1.x86_64                                                                                                                           39/224 
  Running scriptlet: cuda-nvjpeg-10-2-10.2.89-1.x86_64                                                                                                                           39/224 
  Installing       : cuda-nvjpeg-dev-10-2-10.2.89-1.x86_64                                                                                                                       40/224 
  Installing       : cuda-nvprof-10-2-10.2.89-1.x86_64                                                                                                                           41/224 
  Installing       : cuda-nvrtc-10-2-10.2.89-1.x86_64                                                                                                                            42/224 
  Running scriptlet: cuda-nvrtc-10-2-10.2.89-1.x86_64                                                                                                                            42/224 
  Installing       : cuda-nvrtc-dev-10-2-10.2.89-1.x86_64                                                                                                                        43/224 
  Installing       : libcublas10-10.2.2.89-1.x86_64                                                                                                                              44/224 
  Running scriptlet: libcublas10-10.2.2.89-1.x86_64                                                                                                                              44/224 
  Installing       : libcublas-devel-10.2.2.89-1.x86_64                                                                                                                          45/224 
  Installing       : libfontenc-1.1.3-8.el8.x86_64                                                                                                                               46/224 
  Installing       : libepoxy-1.5.2-1.el8.x86_64                                                                                                                                 47/224 
  Installing       : hicolor-icon-theme-0.17-2.el8.noarch                                                                                                                        48/224 
  Installing       : kernel-headers-4.18.0-147.0.3.el8_1.x86_64                                                                                                                  49/224 
  Running scriptlet: glibc-headers-2.28-72.el8.x86_64                                                                                                                            50/224 
  Installing       : glibc-headers-2.28-72.el8.x86_64                                                                                                                            50/224 
  Installing       : libpciaccess-0.14-1.el8.x86_64                                                                                                                              51/224 
  Installing       : libdrm-2.4.98-2.el8.x86_64                                                                                                                                  52/224 
  Installing       : mesa-libgbm-19.1.4-2.el8.x86_64                                                                                                                             53/224 
  Running scriptlet: mesa-libgbm-19.1.4-2.el8.x86_64                                                                                                                             53/224 
  Installing       : libglvnd-egl-1:1.0.1-0.9.git5baa1e5.el8.x86_64                                                                                                              54/224 
  Installing       : mesa-libEGL-19.1.4-2.el8.x86_64                                                                                                                             55/224 
  Installing       : libglvnd-gles-1:1.0.1-0.9.git5baa1e5.el8.x86_64                                                                                                             56/224 
  Installing       : fontpackages-filesystem-1.44-22.el8.noarch                                                                                                                  57/224 
  Installing       : abattis-cantarell-fonts-0.0.25-4.el8.noarch                                                                                                                 58/224 
  Installing       : fontconfig-2.13.1-3.el8.x86_64                                                                                                                              59/224 
  Running scriptlet: fontconfig-2.13.1-3.el8.x86_64                                                                                                                              59/224 
  Installing       : gsettings-desktop-schemas-3.32.0-3.el8.x86_64                                                                                                               60/224 
  Installing       : egl-wayland-1.1.2-1.el8.x86_64                                                                                                                              61/224 
  Installing       : libXfont2-2.0.3-2.el8.x86_64                                                                                                                                62/224 
  Installing       : cuda-libraries-dev-10-2-10.2.89-1.x86_64                                                                                                                    63/224 
  Installing       : cuda-libraries-10-2-10.2.89-1.x86_64                                                                                                                        64/224 
  Installing       : cuda-gdb-10-2-10.2.89-1.x86_64                                                                                                                              65/224 
  Installing       : cpp-8.3.1-4.5.el8.x86_64                                                                                                                                    66/224 
  Running scriptlet: cpp-8.3.1-4.5.el8.x86_64                                                                                                                                    66/224 
  Installing       : libwayland-cursor-1.15.0-1.el8.x86_64                                                                                                                       67/224 
  Installing       : jasper-libs-2.0.14-4.el8.x86_64                                                                                                                             68/224 
  Installing       : cuda-memcheck-10-2-10.2.89-1.x86_64                                                                                                                         69/224 
  Installing       : cuda-nvprune-10-2-10.2.89-1.x86_64                                                                                                                          70/224 
  Installing       : cuda-nvtx-10-2-10.2.89-1.x86_64                                                                                                                             71/224 
  Installing       : cuda-sanitizer-api-10-2-10.2.89-1.x86_64                                                                                                                    72/224 
  Installing       : libstdc++-devel-8.3.1-4.5.el8.x86_64                                                                                                                        73/224 
  Installing       : llvm-libs-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64                                                                                                       74/224 
  Installing       : vulkan-loader-1.1.114.0-3.el8.x86_64                                                                                                                        75/224 
  Installing       : mesa-vulkan-drivers-19.1.4-2.el8.x86_64                                                                                                                     76/224 
  Installing       : mesa-khr-devel-19.1.4-2.el8.x86_64                                                                                                                          77/224 
  Installing       : lua-5.3.4-11.el8.x86_64                                                                                                                                     78/224 
  Installing       : copy-jdk-configs-3.7-1.el8.noarch                                                                                                                           79/224 
  Installing       : alsa-lib-1.1.9-4.el8.x86_64                                                                                                                                 80/224 
  Running scriptlet: alsa-lib-1.1.9-4.el8.x86_64                                                                                                                                 80/224 
  Installing       : tzdata-java-2019c-1.el8.noarch                                                                                                                              81/224 
  Installing       : mtdev-1.1.5-12.el8.x86_64                                                                                                                                   82/224 
  Running scriptlet: mtdev-1.1.5-12.el8.x86_64                                                                                                                                   82/224 
  Installing       : isl-0.16.1-6.el8.x86_64                                                                                                                                     83/224 
  Running scriptlet: isl-0.16.1-6.el8.x86_64                                                                                                                                     83/224 
  Installing       : libevdev-1.5.9-5.el8.x86_64                                                                                                                                 84/224 
  Installing       : giflib-5.1.4-3.el8.x86_64                                                                                                                                   85/224 
  Installing       : libdatrie-0.2.9-7.el8.x86_64                                                                                                                                86/224 
  Running scriptlet: libdatrie-0.2.9-7.el8.x86_64                                                                                                                                86/224 
  Installing       : libthai-0.1.27-2.el8.x86_64                                                                                                                                 87/224 
  Running scriptlet: libthai-0.1.27-2.el8.x86_64                                                                                                                                 87/224 
  Installing       : fribidi-1.0.4-6.el8.x86_64                                                                                                                                  88/224 
  Installing       : dconf-0.28.0-3.el8.x86_64                                                                                                                                   89/224 
  Installing       : libwayland-egl-1.15.0-1.el8.x86_64                                                                                                                          90/224 
  Installing       : graphite2-1.3.10-10.el8.x86_64                                                                                                                              91/224 
  Installing       : harfbuzz-1.7.5-3.el8.x86_64                                                                                                                                 92/224 
  Running scriptlet: harfbuzz-1.7.5-3.el8.x86_64                                                                                                                                 92/224 
  Installing       : ttmkfdir-3.0.9-54.el8.x86_64                                                                                                                                93/224 
  Installing       : ocl-icd-2.2.12-1.el8.x86_64                                                                                                                                 94/224 
  Running scriptlet: ocl-icd-2.2.12-1.el8.x86_64                                                                                                                                 94/224 
  Installing       : jbigkit-libs-2.1-14.el8.x86_64                                                                                                                              95/224 
  Running scriptlet: jbigkit-libs-2.1-14.el8.x86_64                                                                                                                              95/224 
  Installing       : libtiff-4.0.9-15.el8.x86_64                                                                                                                                 96/224 
  Installing       : gdk-pixbuf2-modules-2.36.12-5.el8.x86_64                                                                                                                    97/224 
  Installing       : lcms2-2.9-2.el8.x86_64                                                                                                                                      98/224 
  Running scriptlet: lcms2-2.9-2.el8.x86_64                                                                                                                                      98/224 
  Installing       : gl-manpages-1.1-15.20161227.el8.noarch                                                                                                                      99/224 
  Installing       : libwacom-data-0.31-1.el8.noarch                                                                                                                            100/224 
  Installing       : libwacom-0.31-1.el8.x86_64                                                                                                                                 101/224 
  Installing       : libinput-1.13.2-1.el8.x86_64                                                                                                                               102/224 
  Running scriptlet: libinput-1.13.2-1.el8.x86_64                                                                                                                               102/224 
  Installing       : libXdmcp-1.1.2-11.el8.x86_64                                                                                                                               103/224 
  Installing       : javapackages-filesystem-5.3.0-1.module+el8+2447+6f56d9a6.noarch                                                                                            104/224 
  Installing       : adwaita-cursor-theme-3.28.0-2.el8.noarch                                                                                                                   105/224 
  Installing       : adwaita-icon-theme-3.28.0-2.el8.noarch                                                                                                                     106/224 
  Installing       : opencl-filesystem-1.0-6.el8.noarch                                                                                                                         107/224 
  Running scriptlet: nvidia-persistenced-3:440.33.01-1.el8.x86_64                                                                                                               108/224 
  Installing       : nvidia-persistenced-3:440.33.01-1.el8.x86_64                                                                                                               108/224 
  Running scriptlet: nvidia-persistenced-3:440.33.01-1.el8.x86_64                                                                                                               108/224 
  Installing       : nvidia-driver-cuda-3:440.33.01-1.el8.x86_64                                                                                                                109/224 
  Installing       : libX11-common-1.6.7-1.el8.noarch                                                                                                                           110/224 
  Installing       : libX11-1.6.7-1.el8.x86_64                                                                                                                                  111/224 
  Installing       : libXext-1.3.3-9.el8.x86_64                                                                                                                                 112/224 
  Installing       : libXrender-0.9.10-7.el8.x86_64                                                                                                                             113/224 
  Installing       : cairo-1.15.12-3.el8.x86_64                                                                                                                                 114/224 
  Installing       : libXi-1.7.9-7.el8.x86_64                                                                                                                                   115/224 
  Installing       : libXfixes-5.0.3-7.el8.x86_64                                                                                                                               116/224 
  Installing       : libXdamage-1.1.4-14.el8.x86_64                                                                                                                             117/224 
  Installing       : libXxf86vm-1.1.4-9.el8.x86_64                                                                                                                              118/224 
  Installing       : nvidia-libXNVCtrl-3:440.33.01-1.el8.x86_64                                                                                                                 119/224 
  Installing       : libXcomposite-0.4.4-14.el8.x86_64                                                                                                                          120/224 
  Installing       : libglvnd-glx-1:1.0.1-0.9.git5baa1e5.el8.x86_64                                                                                                             121/224 
  Installing       : mesa-libGL-19.1.4-2.el8.x86_64                                                                                                                             122/224 
  Installing       : nvidia-driver-NvFBCOpenGL-3:440.33.01-1.el8.x86_64                                                                                                         123/224 
  Running scriptlet: nvidia-driver-NvFBCOpenGL-3:440.33.01-1.el8.x86_64                                                                                                         123/224 
  Installing       : libXcursor-1.1.15-3.el8.x86_64                                                                                                                             124/224 
  Installing       : libXtst-1.2.3-7.el8.x86_64                                                                                                                                 125/224 
  Installing       : cairo-gobject-1.15.12-3.el8.x86_64                                                                                                                         126/224 
  Installing       : libXrandr-1.5.1-7.el8.x86_64                                                                                                                               127/224 
  Installing       : libXinerama-1.1.4-1.el8.x86_64                                                                                                                             128/224 
  Installing       : libvdpau-1.1.1-7.el8.x86_64                                                                                                                                129/224 
  Running scriptlet: libvdpau-1.1.1-7.el8.x86_64                                                                                                                                129/224 
  Installing       : nvidia-driver-libs-3:440.33.01-1.el8.x86_64                                                                                                                130/224 
  Running scriptlet: nvidia-driver-libs-3:440.33.01-1.el8.x86_64                                                                                                                130/224 
  Installing       : libXt-1.1.5-12.el8.x86_64                                                                                                                                  131/224 
  Installing       : libXmu-1.1.2-12.el8.x86_64                                                                                                                                 132/224 
  Installing       : nvidia-driver-devel-3:440.33.01-1.el8.x86_64                                                                                                               133/224 
  Installing       : at-spi2-core-2.28.0-1.el8.x86_64                                                                                                                           134/224 
  Running scriptlet: at-spi2-core-2.28.0-1.el8.x86_64                                                                                                                           134/224 
  Installing       : at-spi2-atk-2.26.2-1.el8.x86_64                                                                                                                            135/224 
  Running scriptlet: at-spi2-atk-2.26.2-1.el8.x86_64                                                                                                                            135/224 
  Installing       : freeglut-3.0.0-8.el8.x86_64                                                                                                                                136/224 
  Running scriptlet: freeglut-3.0.0-8.el8.x86_64                                                                                                                                136/224 
  Installing       : mesa-libGLU-9.0.0-15.el8.x86_64                                                                                                                            137/224 
  Installing       : libXft-2.3.2-10.el8.x86_64                                                                                                                                 138/224 
  Installing       : pango-1.42.4-6.el8.x86_64                                                                                                                                  139/224 
  Running scriptlet: pango-1.42.4-6.el8.x86_64                                                                                                                                  139/224 
  Installing       : libxkbfile-1.0.9-9.el8.x86_64                                                                                                                              140/224 
  Installing       : xorg-x11-xkb-utils-7.7-27.el8.x86_64                                                                                                                       141/224 
  Installing       : xorg-x11-server-common-1.20.3-11.el8.x86_64                                                                                                                142/224 
  Installing       : xorg-x11-drv-libinput-0.28.0-2.el8.x86_64                                                                                                                  143/224 
  Installing       : xorg-x11-drv-vesa-2.4.0-3.el8.x86_64                                                                                                                       144/224 
  Installing       : xorg-x11-drv-fbdev-0.5.0-2.el8.x86_64                                                                                                                      145/224 
  Installing       : xorg-x11-server-Xorg-1.20.3-11.el8.x86_64                                                                                                                  146/224 
  Installing       : binutils-2.30-58.el8.x86_64                                                                                                                                147/224 
  Running scriptlet: binutils-2.30-58.el8.x86_64                                                                                                                                147/224 
  Installing       : lksctp-tools-1.0.18-3.el8.x86_64                                                                                                                           148/224 
  Running scriptlet: lksctp-tools-1.0.18-3.el8.x86_64                                                                                                                           148/224 
  Installing       : tar-2:1.30-4.el8.x86_64                                                                                                                                    149/224 
  Running scriptlet: tar-2:1.30-4.el8.x86_64                                                                                                                                    149/224 
  Installing       : libgusb-0.3.0-1.el8.x86_64                                                                                                                                 150/224 
  Installing       : colord-libs-1.4.2-1.el8.x86_64                                                                                                                             151/224 
  Installing       : avahi-libs-0.7-19.el8.x86_64                                                                                                                               152/224 
  Installing       : cups-libs-1:2.2.6-28.el8.x86_64                                                                                                                            153/224 
  Installing       : gtk2-2.24.32-4.el8.x86_64                                                                                                                                  154/224 
  Running scriptlet: gtk2-2.24.32-4.el8.x86_64                                                                                                                                  154/224 
  Installing       : java-1.8.0-openjdk-headless-1:1.8.0.232.b09-2.el8_1.x86_64                                                                                                 155/224 
  Running scriptlet: java-1.8.0-openjdk-headless-1:1.8.0.232.b09-2.el8_1.x86_64                                                                                                 155/224 
  Installing       : pkgconf-m4-1.4.2-1.el8.noarch                                                                                                                              156/224 
  Installing       : libmodman-2.0.1-17.el8.x86_64                                                                                                                              157/224 
  Running scriptlet: libmodman-2.0.1-17.el8.x86_64                                                                                                                              157/224 
  Installing       : libproxy-0.4.15-5.2.el8.x86_64                                                                                                                             158/224 
  Running scriptlet: libproxy-0.4.15-5.2.el8.x86_64                                                                                                                             158/224 
  Installing       : glib-networking-2.56.1-1.1.el8.x86_64                                                                                                                      159/224 
  Installing       : libsoup-2.62.3-1.el8.x86_64                                                                                                                                160/224 
  Installing       : rest-0.8.1-2.el8.x86_64                                                                                                                                    161/224 
  Running scriptlet: rest-0.8.1-2.el8.x86_64                                                                                                                                    161/224 
  Installing       : gtk3-3.22.30-4.el8.x86_64                                                                                                                                  162/224 
  Installing       : libpkgconf-1.4.2-1.el8.x86_64                                                                                                                              163/224 
  Installing       : pkgconf-1.4.2-1.el8.x86_64                                                                                                                                 164/224 
  Installing       : pkgconf-pkg-config-1.4.2-1.el8.x86_64                                                                                                                      165/224 
  Installing       : xorg-x11-proto-devel-2018.4-1.el8.noarch                                                                                                                   166/224 
  Installing       : libICE-devel-1.0.9-15.el8.x86_64                                                                                                                           167/224 
  Installing       : libSM-devel-1.2.3-1.el8.x86_64                                                                                                                             168/224 
  Installing       : libXau-devel-1.0.8-13.el8.x86_64                                                                                                                           169/224 
  Installing       : libxcb-devel-1.13-5.el8.x86_64                                                                                                                             170/224 
  Installing       : libX11-devel-1.6.7-1.el8.x86_64                                                                                                                            171/224 
  Installing       : libXext-devel-1.3.3-9.el8.x86_64                                                                                                                           172/224 
  Installing       : libXfixes-devel-5.0.3-7.el8.x86_64                                                                                                                         173/224 
  Installing       : libXdamage-devel-1.1.4-14.el8.x86_64                                                                                                                       174/224 
  Installing       : libXi-devel-1.7.9-7.el8.x86_64                                                                                                                             175/224 
  Installing       : libXxf86vm-devel-1.1.4-9.el8.x86_64                                                                                                                        176/224 
  Installing       : nvidia-libXNVCtrl-devel-3:440.33.01-1.el8.x86_64                                                                                                           177/224 
  Installing       : libXt-devel-1.1.5-12.el8.x86_64                                                                                                                            178/224 
  Installing       : libXmu-devel-1.1.2-12.el8.x86_64                                                                                                                           179/224 
  Installing       : glibc-devel-2.28-72.el8.x86_64                                                                                                                             180/224 
  Running scriptlet: glibc-devel-2.28-72.el8.x86_64                                                                                                                             180/224 
  Installing       : libxcrypt-devel-4.1.1-4.el8.x86_64                                                                                                                         181/224 
  Installing       : gcc-8.3.1-4.5.el8.x86_64                                                                                                                                   182/224 
  Running scriptlet: gcc-8.3.1-4.5.el8.x86_64                                                                                                                                   182/224 
  Installing       : gcc-c++-8.3.1-4.5.el8.x86_64                                                                                                                               183/224 
  Installing       : cuda-nvcc-10-2-10.2.89-1.x86_64                                                                                                                            184/224 
  Installing       : cuda-compiler-10-2-10.2.89-1.x86_64                                                                                                                        185/224 
  Installing       : cuda-cupti-10-2-10.2.89-1.x86_64                                                                                                                           186/224 
  Installing       : cuda-command-line-tools-10-2-10.2.89-1.x86_64                                                                                                              187/224 
  Installing       : zlib-devel-1.2.11-10.el8.x86_64                                                                                                                            188/224 
  Installing       : elfutils-libelf-devel-0.176-5.el8.x86_64                                                                                                                   189/224 
  Installing       : dkms-2.7.1-2.el8.noarch                                                                                                                                    190/224 
  Running scriptlet: dkms-2.7.1-2.el8.noarch                                                                                                                                    190/224 
  Installing       : libglvnd-core-devel-1:1.0.1-0.9.git5baa1e5.el8.x86_64                                                                                                      191/224 
  Installing       : libglvnd-devel-1:1.0.1-0.9.git5baa1e5.el8.x86_64                                                                                                           192/224 
  Installing       : xorg-x11-font-utils-1:7.5-40.el8.x86_64                                                                                                                    193/224 
  Installing       : xorg-x11-fonts-Type1-7.5-19.el8.noarch                                                                                                                     194/224 
  Running scriptlet: xorg-x11-fonts-Type1-7.5-19.el8.noarch                                                                                                                     194/224 
  Installing       : java-1.8.0-openjdk-1:1.8.0.232.b09-2.el8_1.x86_64                                                                                                          195/224 
  Running scriptlet: java-1.8.0-openjdk-1:1.8.0.232.b09-2.el8_1.x86_64                                                                                                          195/224 
  Installing       : cuda-nsight-10-2-10.2.89-1.x86_64                                                                                                                          196/224 
  Installing       : cuda-nvvp-10-2-10.2.89-1.x86_64                                                                                                                            197/224 
  Installing       : libdrm-devel-2.4.98-2.el8.x86_64                                                                                                                           198/224 
  Installing       : mesa-libGL-devel-19.1.4-2.el8.x86_64                                                                                                                       199/224 
  Installing       : mesa-libGLU-devel-9.0.0-15.el8.x86_64                                                                                                                      200/224 
  Installing       : freeglut-devel-3.0.0-8.el8.x86_64                                                                                                                          201/224 
  Installing       : make-1:4.2.1-9.el8.x86_64                                                                                                                                  202/224 
  Running scriptlet: make-1:4.2.1-9.el8.x86_64                                                                                                                                  202/224 
  Installing       : cuda-samples-10-2-10.2.89-1.x86_64                                                                                                                         203/224 
  Installing       : cuda-documentation-10-2-10.2.89-1.x86_64                                                                                                                   204/224 
  Installing       : dnf-plugin-nvidia-1.1-1.el8.noarch                                                                                                                         205/224 
  Installing       : kmod-nvidia-latest-dkms-3:440.33.01-1.el8.x86_64                                                                                                           206/224 
  Running scriptlet: kmod-nvidia-latest-dkms-3:440.33.01-1.el8.x86_64                                                                                                           206/224 
  Installing       : nvidia-kmod-common-3:440.33.01-1.el8.noarch                                                                                                                207/224 
  Running scriptlet: nvidia-kmod-common-3:440.33.01-1.el8.noarch                                                                                                                207/224 
  Installing       : nvidia-driver-3:440.33.01-1.el8.x86_64                                                                                                                     208/224 
  Installing       : nvidia-driver-NVML-3:440.33.01-1.el8.x86_64                                                                                                                209/224 
  Running scriptlet: nvidia-driver-NVML-3:440.33.01-1.el8.x86_64                                                                                                                209/224 
  Installing       : nvidia-modprobe-3:440.33.01-1.el8.x86_64                                                                                                                   210/224 
  Installing       : nvidia-settings-3:440.33.01-1.el8.x86_64                                                                                                                   211/224 
  Installing       : nvidia-xconfig-3:440.33.01-1.el8.x86_64                                                                                                                    212/224 
  Installing       : cuda-drivers-440.33.01-1.x86_64                                                                                                                            213/224 
  Installing       : cuda-runtime-10-2-10.2.89-1.x86_64                                                                                                                         214/224 
  Installing       : cuda-demo-suite-10-2-10.2.89-1.x86_64                                                                                                                      215/224 
  Installing       : nsight-systems-2019.5.2-2019.5.2.16_b54ef97-0.x86_64                                                                                                       216/224 
  Running scriptlet: nsight-systems-2019.5.2-2019.5.2.16_b54ef97-0.x86_64                                                                                                       216/224 
  Installing       : cuda-nsight-systems-10-2-10.2.89-1.x86_64                                                                                                                  217/224 
  Installing       : nsight-compute-2019.4.0-2019.4.0.12-1.x86_64                                                                                                               218/224 
  Installing       : cuda-nsight-compute-10-2-10.2.89-1.x86_64                                                                                                                  219/224 
  Installing       : cuda-visual-tools-10-2-10.2.89-1.x86_64                                                                                                                    220/224 
  Installing       : cuda-tools-10-2-10.2.89-1.x86_64                                                                                                                           221/224 
  Installing       : cuda-toolkit-10-2-10.2.89-1.x86_64                                                                                                                         222/224 
  Installing       : cuda-10-2-10.2.89-1.x86_64                                                                                                                                 223/224 
  Installing       : cuda-10.2.89-1.x86_64                                                                                                                                      224/224 
  Running scriptlet: copy-jdk-configs-3.7-1.el8.noarch                                                                                                                          224/224 
  Running scriptlet: dconf-0.28.0-3.el8.x86_64                                                                                                                                  224/224 
  Running scriptlet: java-1.8.0-openjdk-1:1.8.0.232.b09-2.el8_1.x86_64                                                                                                          224/224 
  Running scriptlet: cuda-nsight-10-2-10.2.89-1.x86_64                                                                                                                          224/224 
warning: %posttrans(cuda-nsight-10-2-10.2.89-1.x86_64) scriptlet failed, exit status 127

Error in POSTTRANS scriptlet in rpm package cuda-nsight-10-2
  Running scriptlet: cuda-nvvp-10-2-10.2.89-1.x86_64                                                                                                                            224/224 
warning: %posttrans(cuda-nvvp-10-2-10.2.89-1.x86_64) scriptlet failed, exit status 127

Error in POSTTRANS scriptlet in rpm package cuda-nvvp-10-2
  Running scriptlet: nsight-compute-2019.4.0-2019.4.0.12-1.x86_64                                                                                                               224/224 
warning: %posttrans(nsight-compute-2019.4.0-2019.4.0.12-1.x86_64) scriptlet failed, exit status 127

Error in POSTTRANS scriptlet in rpm package nsight-compute-2019.4.0
  Running scriptlet: cuda-toolkit-10-2-10.2.89-1.x86_64                                                                                                                         224/224 
  Running scriptlet: cuda-10.2.89-1.x86_64                                                                                                                                      224/224 
  Running scriptlet: gdk-pixbuf2-2.36.12-5.el8.x86_64                                                                                                                           224/224 
  Running scriptlet: hicolor-icon-theme-0.17-2.el8.noarch                                                                                                                       224/224 
  Running scriptlet: fontconfig-2.13.1-3.el8.x86_64                                                                                                                             224/224 
  Running scriptlet: adwaita-icon-theme-3.28.0-2.el8.noarch                                                                                                                     224/224 
  Verifying        : nsight-systems-2019.5.2-2019.5.2.16_b54ef97-0.x86_64                                                                                                         1/224 
  Verifying        : cuda-10-2-10.2.89-1.x86_64                                                                                                                                   2/224 
  Verifying        : cuda-10.2.89-1.x86_64                                                                                                                                        3/224 
  Verifying        : cuda-command-line-tools-10-2-10.2.89-1.x86_64                                                                                                                4/224 
  Verifying        : cuda-compiler-10-2-10.2.89-1.x86_64                                                                                                                          5/224 
  Verifying        : cuda-cudart-10-2-10.2.89-1.x86_64                                                                                                                            6/224 
  Verifying        : cuda-cudart-dev-10-2-10.2.89-1.x86_64                                                                                                                        7/224 
  Verifying        : cuda-cufft-10-2-10.2.89-1.x86_64                                                                                                                             8/224 
  Verifying        : cuda-cufft-dev-10-2-10.2.89-1.x86_64                                                                                                                         9/224 
  Verifying        : cuda-cuobjdump-10-2-10.2.89-1.x86_64                                                                                                                        10/224 
  Verifying        : cuda-cupti-10-2-10.2.89-1.x86_64                                                                                                                            11/224 
  Verifying        : cuda-curand-10-2-10.2.89-1.x86_64                                                                                                                           12/224 
  Verifying        : cuda-curand-dev-10-2-10.2.89-1.x86_64                                                                                                                       13/224 
  Verifying        : cuda-cusolver-10-2-10.2.89-1.x86_64                                                                                                                         14/224 
  Verifying        : cuda-cusolver-dev-10-2-10.2.89-1.x86_64                                                                                                                     15/224 
  Verifying        : cuda-cusparse-10-2-10.2.89-1.x86_64                                                                                                                         16/224 
  Verifying        : cuda-cusparse-dev-10-2-10.2.89-1.x86_64                                                                                                                     17/224 
  Verifying        : cuda-demo-suite-10-2-10.2.89-1.x86_64                                                                                                                       18/224 
  Verifying        : cuda-documentation-10-2-10.2.89-1.x86_64                                                                                                                    19/224 
  Verifying        : cuda-driver-dev-10-2-10.2.89-1.x86_64                                                                                                                       20/224 
  Verifying        : cuda-drivers-440.33.01-1.x86_64                                                                                                                             21/224 
  Verifying        : cuda-gdb-10-2-10.2.89-1.x86_64                                                                                                                              22/224 
  Verifying        : cuda-libraries-10-2-10.2.89-1.x86_64                                                                                                                        23/224 
  Verifying        : cuda-libraries-dev-10-2-10.2.89-1.x86_64                                                                                                                    24/224 
  Verifying        : cuda-license-10-2-10.2.89-1.x86_64                                                                                                                          25/224 
  Verifying        : cuda-memcheck-10-2-10.2.89-1.x86_64                                                                                                                         26/224 
  Verifying        : cuda-misc-headers-10-2-10.2.89-1.x86_64                                                                                                                     27/224 
  Verifying        : cuda-npp-10-2-10.2.89-1.x86_64                                                                                                                              28/224 
  Verifying        : cuda-npp-dev-10-2-10.2.89-1.x86_64                                                                                                                          29/224 
  Verifying        : cuda-nsight-10-2-10.2.89-1.x86_64                                                                                                                           30/224 
  Verifying        : cuda-nsight-compute-10-2-10.2.89-1.x86_64                                                                                                                   31/224 
  Verifying        : cuda-nsight-systems-10-2-10.2.89-1.x86_64                                                                                                                   32/224 
  Verifying        : cuda-nvcc-10-2-10.2.89-1.x86_64                                                                                                                             33/224 
  Verifying        : cuda-nvdisasm-10-2-10.2.89-1.x86_64                                                                                                                         34/224 
  Verifying        : cuda-nvgraph-10-2-10.2.89-1.x86_64                                                                                                                          35/224 
  Verifying        : cuda-nvgraph-dev-10-2-10.2.89-1.x86_64                                                                                                                      36/224 
  Verifying        : cuda-nvjpeg-10-2-10.2.89-1.x86_64                                                                                                                           37/224 
  Verifying        : cuda-nvjpeg-dev-10-2-10.2.89-1.x86_64                                                                                                                       38/224 
  Verifying        : cuda-nvml-dev-10-2-10.2.89-1.x86_64                                                                                                                         39/224 
  Verifying        : cuda-nvprof-10-2-10.2.89-1.x86_64                                                                                                                           40/224 
  Verifying        : cuda-nvprune-10-2-10.2.89-1.x86_64                                                                                                                          41/224 
  Verifying        : cuda-nvrtc-10-2-10.2.89-1.x86_64                                                                                                                            42/224 
  Verifying        : cuda-nvrtc-dev-10-2-10.2.89-1.x86_64                                                                                                                        43/224 
  Verifying        : cuda-nvtx-10-2-10.2.89-1.x86_64                                                                                                                             44/224 
  Verifying        : cuda-nvvp-10-2-10.2.89-1.x86_64                                                                                                                             45/224 
  Verifying        : cuda-runtime-10-2-10.2.89-1.x86_64                                                                                                                          46/224 
  Verifying        : cuda-samples-10-2-10.2.89-1.x86_64                                                                                                                          47/224 
  Verifying        : cuda-sanitizer-api-10-2-10.2.89-1.x86_64                                                                                                                    48/224 
  Verifying        : cuda-toolkit-10-2-10.2.89-1.x86_64                                                                                                                          49/224 
  Verifying        : cuda-tools-10-2-10.2.89-1.x86_64                                                                                                                            50/224 
  Verifying        : cuda-visual-tools-10-2-10.2.89-1.x86_64                                                                                                                     51/224 
  Verifying        : dnf-plugin-nvidia-1.1-1.el8.noarch                                                                                                                          52/224 
  Verifying        : kmod-nvidia-latest-dkms-3:440.33.01-1.el8.x86_64                                                                                                            53/224 
  Verifying        : libcublas-devel-10.2.2.89-1.x86_64                                                                                                                          54/224 
  Verifying        : libcublas10-10.2.2.89-1.x86_64                                                                                                                              55/224 
  Verifying        : nsight-compute-2019.4.0-2019.4.0.12-1.x86_64                                                                                                                56/224 
  Verifying        : nvidia-driver-3:440.33.01-1.el8.x86_64                                                                                                                      57/224 
  Verifying        : nvidia-driver-NVML-3:440.33.01-1.el8.x86_64                                                                                                                 58/224 
  Verifying        : nvidia-driver-NvFBCOpenGL-3:440.33.01-1.el8.x86_64                                                                                                          59/224 
  Verifying        : nvidia-driver-cuda-3:440.33.01-1.el8.x86_64                                                                                                                 60/224 
  Verifying        : nvidia-driver-cuda-libs-3:440.33.01-1.el8.x86_64                                                                                                            61/224 
  Verifying        : nvidia-driver-devel-3:440.33.01-1.el8.x86_64                                                                                                                62/224 
  Verifying        : nvidia-driver-libs-3:440.33.01-1.el8.x86_64                                                                                                                 63/224 
  Verifying        : nvidia-kmod-common-3:440.33.01-1.el8.noarch                                                                                                                 64/224 
  Verifying        : nvidia-libXNVCtrl-3:440.33.01-1.el8.x86_64                                                                                                                  65/224 
  Verifying        : nvidia-libXNVCtrl-devel-3:440.33.01-1.el8.x86_64                                                                                                            66/224 
  Verifying        : nvidia-modprobe-3:440.33.01-1.el8.x86_64                                                                                                                    67/224 
  Verifying        : nvidia-persistenced-3:440.33.01-1.el8.x86_64                                                                                                                68/224 
  Verifying        : nvidia-settings-3:440.33.01-1.el8.x86_64                                                                                                                    69/224 
  Verifying        : nvidia-xconfig-3:440.33.01-1.el8.x86_64                                                                                                                     70/224 
  Verifying        : dkms-2.7.1-2.el8.noarch                                                                                                                                     71/224 
  Verifying        : make-1:4.2.1-9.el8.x86_64                                                                                                                                   72/224 
  Verifying        : libpkgconf-1.4.2-1.el8.x86_64                                                                                                                               73/224 
  Verifying        : libmodman-2.0.1-17.el8.x86_64                                                                                                                               74/224 
  Verifying        : pkgconf-m4-1.4.2-1.el8.noarch                                                                                                                               75/224 
  Verifying        : pkgconf-1.4.2-1.el8.x86_64                                                                                                                                  76/224 
  Verifying        : libproxy-0.4.15-5.2.el8.x86_64                                                                                                                              77/224 
  Verifying        : glib-networking-2.56.1-1.1.el8.x86_64                                                                                                                       78/224 
  Verifying        : avahi-libs-0.7-19.el8.x86_64                                                                                                                                79/224 
  Verifying        : libxcrypt-devel-4.1.1-4.el8.x86_64                                                                                                                          80/224 
  Verifying        : libsoup-2.62.3-1.el8.x86_64                                                                                                                                 81/224 
  Verifying        : fontpackages-filesystem-1.44-22.el8.noarch                                                                                                                  82/224 
  Verifying        : libgusb-0.3.0-1.el8.x86_64                                                                                                                                  83/224 
  Verifying        : tar-2:1.30-4.el8.x86_64                                                                                                                                     84/224 
  Verifying        : lksctp-tools-1.0.18-3.el8.x86_64                                                                                                                            85/224 
  Verifying        : libpciaccess-0.14-1.el8.x86_64                                                                                                                              86/224 
  Verifying        : fontconfig-2.13.1-3.el8.x86_64                                                                                                                              87/224 
  Verifying        : zlib-devel-1.2.11-10.el8.x86_64                                                                                                                             88/224 
  Verifying        : binutils-2.30-58.el8.x86_64                                                                                                                                 89/224 
  Verifying        : elfutils-libelf-devel-0.176-5.el8.x86_64                                                                                                                    90/224 
  Verifying        : gdk-pixbuf2-2.36.12-5.el8.x86_64                                                                                                                            91/224 
  Verifying        : gsettings-desktop-schemas-3.32.0-3.el8.x86_64                                                                                                               92/224 
  Verifying        : glibc-devel-2.28-72.el8.x86_64                                                                                                                              93/224 
  Verifying        : pkgconf-pkg-config-1.4.2-1.el8.x86_64                                                                                                                       94/224 
  Verifying        : cups-libs-1:2.2.6-28.el8.x86_64                                                                                                                             95/224 
  Verifying        : glibc-headers-2.28-72.el8.x86_64                                                                                                                            96/224 
  Verifying        : kernel-headers-4.18.0-147.0.3.el8_1.x86_64                                                                                                                  97/224 
  Verifying        : libX11-common-1.6.7-1.el8.noarch                                                                                                                            98/224 
  Verifying        : adwaita-icon-theme-3.28.0-2.el8.noarch                                                                                                                      99/224 
  Verifying        : opencl-filesystem-1.0-6.el8.noarch                                                                                                                         100/224 
  Verifying        : adwaita-cursor-theme-3.28.0-2.el8.noarch                                                                                                                   101/224 
  Verifying        : xorg-x11-proto-devel-2018.4-1.el8.noarch                                                                                                                   102/224 
  Verifying        : javapackages-filesystem-5.3.0-1.module+el8+2447+6f56d9a6.noarch                                                                                            103/224 
  Verifying        : abattis-cantarell-fonts-0.0.25-4.el8.noarch                                                                                                                104/224 
  Verifying        : libXdmcp-1.1.2-11.el8.x86_64                                                                                                                               105/224 
  Verifying        : libglvnd-opengl-1:1.0.1-0.9.git5baa1e5.el8.x86_64                                                                                                          106/224 
  Verifying        : xorg-x11-fonts-Type1-7.5-19.el8.noarch                                                                                                                     107/224 
  Verifying        : copy-jdk-configs-3.7-1.el8.noarch                                                                                                                          108/224 
  Verifying        : hicolor-icon-theme-0.17-2.el8.noarch                                                                                                                       109/224 
  Verifying        : libxcb-1.13-5.el8.x86_64                                                                                                                                   110/224 
  Verifying        : libwacom-data-0.31-1.el8.noarch                                                                                                                            111/224 
  Verifying        : gl-manpages-1.1-15.20161227.el8.noarch                                                                                                                     112/224 
  Verifying        : lcms2-2.9-2.el8.x86_64                                                                                                                                     113/224 
  Verifying        : mesa-libGLU-devel-9.0.0-15.el8.x86_64                                                                                                                      114/224 
  Verifying        : libXdamage-devel-1.1.4-14.el8.x86_64                                                                                                                       115/224 
  Verifying        : jbigkit-libs-2.1-14.el8.x86_64                                                                                                                             116/224 
  Verifying        : libXi-devel-1.7.9-7.el8.x86_64                                                                                                                             117/224 
  Verifying        : libXi-1.7.9-7.el8.x86_64                                                                                                                                   118/224 
  Verifying        : libXext-1.3.3-9.el8.x86_64                                                                                                                                 119/224 
  Verifying        : ocl-icd-2.2.12-1.el8.x86_64                                                                                                                                120/224 
  Verifying        : libXtst-1.2.3-7.el8.x86_64                                                                                                                                 121/224 
  Verifying        : libXinerama-1.1.4-1.el8.x86_64                                                                                                                             122/224 
  Verifying        : libglvnd-egl-1:1.0.1-0.9.git5baa1e5.el8.x86_64                                                                                                             123/224 
  Verifying        : libmpc-1.0.2-9.el8.x86_64                                                                                                                                  124/224 
  Verifying        : libglvnd-core-devel-1:1.0.1-0.9.git5baa1e5.el8.x86_64                                                                                                      125/224 
  Verifying        : xorg-x11-xkb-utils-7.7-27.el8.x86_64                                                                                                                       126/224 
  Verifying        : libvdpau-1.1.1-7.el8.x86_64                                                                                                                                127/224 
  Verifying        : at-spi2-core-2.28.0-1.el8.x86_64                                                                                                                           128/224 
  Verifying        : ttmkfdir-3.0.9-54.el8.x86_64                                                                                                                               129/224 
  Verifying        : graphite2-1.3.10-10.el8.x86_64                                                                                                                             130/224 
  Verifying        : libXfixes-devel-5.0.3-7.el8.x86_64                                                                                                                         131/224 
  Verifying        : libXcursor-1.1.15-3.el8.x86_64                                                                                                                             132/224 
  Verifying        : libXrandr-1.5.1-7.el8.x86_64                                                                                                                               133/224 
  Verifying        : at-spi2-atk-2.26.2-1.el8.x86_64                                                                                                                            134/224 
  Verifying        : xorg-x11-drv-libinput-0.28.0-2.el8.x86_64                                                                                                                  135/224 
  Verifying        : libwayland-egl-1.15.0-1.el8.x86_64                                                                                                                         136/224 
  Verifying        : libX11-devel-1.6.7-1.el8.x86_64                                                                                                                            137/224 
  Verifying        : libXfont2-2.0.3-2.el8.x86_64                                                                                                                               138/224 
  Verifying        : jasper-libs-2.0.14-4.el8.x86_64                                                                                                                            139/224 
  Verifying        : libSM-1.2.3-1.el8.x86_64                                                                                                                                   140/224 
  Verifying        : libwayland-server-1.15.0-1.el8.x86_64                                                                                                                      141/224 
  Verifying        : libwayland-cursor-1.15.0-1.el8.x86_64                                                                                                                      142/224 
  Verifying        : libXft-2.3.2-10.el8.x86_64                                                                                                                                 143/224 
  Verifying        : libxkbfile-1.0.9-9.el8.x86_64                                                                                                                              144/224 
  Verifying        : libXfixes-5.0.3-7.el8.x86_64                                                                                                                               145/224 
  Verifying        : libglvnd-1:1.0.1-0.9.git5baa1e5.el8.x86_64                                                                                                                 146/224 
  Verifying        : cairo-gobject-1.15.12-3.el8.x86_64                                                                                                                         147/224 
  Verifying        : dconf-0.28.0-3.el8.x86_64                                                                                                                                  148/224 
  Verifying        : libglvnd-gles-1:1.0.1-0.9.git5baa1e5.el8.x86_64                                                                                                            149/224 
  Verifying        : libXau-1.0.8-13.el8.x86_64                                                                                                                                 150/224 
  Verifying        : freeglut-3.0.0-8.el8.x86_64                                                                                                                                151/224 
  Verifying        : libepoxy-1.5.2-1.el8.x86_64                                                                                                                                152/224 
  Verifying        : freeglut-devel-3.0.0-8.el8.x86_64                                                                                                                          153/224 
  Verifying        : egl-wayland-1.1.2-1.el8.x86_64                                                                                                                             154/224 
  Verifying        : xorg-x11-drv-vesa-2.4.0-3.el8.x86_64                                                                                                                       155/224 
  Verifying        : libwacom-0.31-1.el8.x86_64                                                                                                                                 156/224 
  Verifying        : libXxf86vm-1.1.4-9.el8.x86_64                                                                                                                              157/224 
  Verifying        : xorg-x11-drv-fbdev-0.5.0-2.el8.x86_64                                                                                                                      158/224 
  Verifying        : libthai-0.1.27-2.el8.x86_64                                                                                                                                159/224 
  Verifying        : colord-libs-1.4.2-1.el8.x86_64                                                                                                                             160/224 
  Verifying        : rest-0.8.1-2.el8.x86_64                                                                                                                                    161/224 
  Verifying        : libXdamage-1.1.4-14.el8.x86_64                                                                                                                             162/224 
  Verifying        : libXmu-devel-1.1.2-12.el8.x86_64                                                                                                                           163/224 
  Verifying        : libSM-devel-1.2.3-1.el8.x86_64                                                                                                                             164/224 
  Verifying        : cairo-1.15.12-3.el8.x86_64                                                                                                                                 165/224 
  Verifying        : harfbuzz-1.7.5-3.el8.x86_64                                                                                                                                166/224 
  Verifying        : libXxf86vm-devel-1.1.4-9.el8.x86_64                                                                                                                        167/224 
  Verifying        : mesa-libGLU-9.0.0-15.el8.x86_64                                                                                                                            168/224 
  Verifying        : libXcomposite-0.4.4-14.el8.x86_64                                                                                                                          169/224 
  Verifying        : libfontenc-1.1.3-8.el8.x86_64                                                                                                                              170/224 
  Verifying        : libwayland-client-1.15.0-1.el8.x86_64                                                                                                                      171/224 
  Verifying        : libX11-xcb-1.6.7-1.el8.x86_64                                                                                                                              172/224 
  Verifying        : libxcb-devel-1.13-5.el8.x86_64                                                                                                                             173/224 
  Verifying        : libX11-1.6.7-1.el8.x86_64                                                                                                                                  174/224 
  Verifying        : fribidi-1.0.4-6.el8.x86_64                                                                                                                                 175/224 
  Verifying        : libXrender-0.9.10-7.el8.x86_64                                                                                                                             176/224 
  Verifying        : atk-2.28.1-1.el8.x86_64                                                                                                                                    177/224 
  Verifying        : libdatrie-0.2.9-7.el8.x86_64                                                                                                                               178/224 
  Verifying        : gtk2-2.24.32-4.el8.x86_64                                                                                                                                  179/224 
  Verifying        : libxshmfence-1.3-2.el8.x86_64                                                                                                                              180/224 
  Verifying        : giflib-5.1.4-3.el8.x86_64                                                                                                                                  181/224 
  Verifying        : libXext-devel-1.3.3-9.el8.x86_64                                                                                                                           182/224 
  Verifying        : libevdev-1.5.9-5.el8.x86_64                                                                                                                                183/224 
  Verifying        : isl-0.16.1-6.el8.x86_64                                                                                                                                    184/224 
  Verifying        : libXau-devel-1.0.8-13.el8.x86_64                                                                                                                           185/224 
  Verifying        : pixman-0.36.0-1.el8.x86_64                                                                                                                                 186/224 
  Verifying        : libXmu-1.1.2-12.el8.x86_64                                                                                                                                 187/224 
  Verifying        : mtdev-1.1.5-12.el8.x86_64                                                                                                                                  188/224 
  Verifying        : xorg-x11-font-utils-1:7.5-40.el8.x86_64                                                                                                                    189/224 
  Verifying        : libglvnd-glx-1:1.0.1-0.9.git5baa1e5.el8.x86_64                                                                                                             190/224 
  Verifying        : libglvnd-devel-1:1.0.1-0.9.git5baa1e5.el8.x86_64                                                                                                           191/224 
  Verifying        : libXt-1.1.5-12.el8.x86_64                                                                                                                                  192/224 
  Verifying        : tzdata-java-2019c-1.el8.noarch                                                                                                                             193/224 
  Verifying        : gcc-8.3.1-4.5.el8.x86_64                                                                                                                                   194/224 
  Verifying        : mesa-libEGL-19.1.4-2.el8.x86_64                                                                                                                            195/224 
  Verifying        : mesa-libGL-devel-19.1.4-2.el8.x86_64                                                                                                                       196/224 
  Verifying        : libjpeg-turbo-1.5.3-10.el8.x86_64                                                                                                                          197/224 
  Verifying        : mesa-vulkan-drivers-19.1.4-2.el8.x86_64                                                                                                                    198/224 
  Verifying        : mesa-libglapi-19.1.4-2.el8.x86_64                                                                                                                          199/224 
  Verifying        : alsa-lib-1.1.9-4.el8.x86_64                                                                                                                                200/224 
  Verifying        : gcc-c++-8.3.1-4.5.el8.x86_64                                                                                                                               201/224 
  Verifying        : libXt-devel-1.1.5-12.el8.x86_64                                                                                                                            202/224 
  Verifying        : xorg-x11-server-common-1.20.3-11.el8.x86_64                                                                                                                203/224 
  Verifying        : xorg-x11-server-Xorg-1.20.3-11.el8.x86_64                                                                                                                  204/224 
  Verifying        : cpp-8.3.1-4.5.el8.x86_64                                                                                                                                   205/224 
  Verifying        : gtk-update-icon-cache-3.22.30-4.el8.x86_64                                                                                                                 206/224 
  Verifying        : pango-1.42.4-6.el8.x86_64                                                                                                                                  207/224 
  Verifying        : libtiff-4.0.9-15.el8.x86_64                                                                                                                                208/224 
  Verifying        : mesa-libgbm-19.1.4-2.el8.x86_64                                                                                                                            209/224 
  Verifying        : libdrm-2.4.98-2.el8.x86_64                                                                                                                                 210/224 
  Verifying        : lua-5.3.4-11.el8.x86_64                                                                                                                                    211/224 
  Verifying        : libICE-devel-1.0.9-15.el8.x86_64                                                                                                                           212/224 
  Verifying        : mesa-khr-devel-19.1.4-2.el8.x86_64                                                                                                                         213/224 
  Verifying        : libdrm-devel-2.4.98-2.el8.x86_64                                                                                                                           214/224 
  Verifying        : vulkan-loader-1.1.114.0-3.el8.x86_64                                                                                                                       215/224 
  Verifying        : java-1.8.0-openjdk-1:1.8.0.232.b09-2.el8_1.x86_64                                                                                                          216/224 
  Verifying        : gdk-pixbuf2-modules-2.36.12-5.el8.x86_64                                                                                                                   217/224 
  Verifying        : mesa-libGL-19.1.4-2.el8.x86_64                                                                                                                             218/224 
  Verifying        : gtk3-3.22.30-4.el8.x86_64                                                                                                                                  219/224 
  Verifying        : java-1.8.0-openjdk-headless-1:1.8.0.232.b09-2.el8_1.x86_64                                                                                                 220/224 
  Verifying        : llvm-libs-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64                                                                                                      221/224 
  Verifying        : libstdc++-devel-8.3.1-4.5.el8.x86_64                                                                                                                       222/224 
  Verifying        : libinput-1.13.2-1.el8.x86_64                                                                                                                               223/224 
  Verifying        : libICE-1.0.9-15.el8.x86_64                                                                                                                                 224/224 
Installed products updated.

Installed:
  cuda-10.2.89-1.x86_64                                        dconf-0.28.0-3.el8.x86_64                               gtk2-2.24.32-4.el8.x86_64                                        
  nsight-systems-2019.5.2-2019.5.2.16_b54ef97-0.x86_64         cuda-10-2-10.2.89-1.x86_64                              cuda-command-line-tools-10-2-10.2.89-1.x86_64                    
  cuda-compiler-10-2-10.2.89-1.x86_64                          cuda-cudart-10-2-10.2.89-1.x86_64                       cuda-cudart-dev-10-2-10.2.89-1.x86_64                            
  cuda-cufft-10-2-10.2.89-1.x86_64                             cuda-cufft-dev-10-2-10.2.89-1.x86_64                    cuda-cuobjdump-10-2-10.2.89-1.x86_64                             
  cuda-cupti-10-2-10.2.89-1.x86_64                             cuda-curand-10-2-10.2.89-1.x86_64                       cuda-curand-dev-10-2-10.2.89-1.x86_64                            
  cuda-cusolver-10-2-10.2.89-1.x86_64                          cuda-cusolver-dev-10-2-10.2.89-1.x86_64                 cuda-cusparse-10-2-10.2.89-1.x86_64                              
  cuda-cusparse-dev-10-2-10.2.89-1.x86_64                      cuda-demo-suite-10-2-10.2.89-1.x86_64                   cuda-documentation-10-2-10.2.89-1.x86_64                         
  cuda-driver-dev-10-2-10.2.89-1.x86_64                        cuda-drivers-440.33.01-1.x86_64                         cuda-gdb-10-2-10.2.89-1.x86_64                                   
  cuda-libraries-10-2-10.2.89-1.x86_64                         cuda-libraries-dev-10-2-10.2.89-1.x86_64                cuda-license-10-2-10.2.89-1.x86_64                               
  cuda-memcheck-10-2-10.2.89-1.x86_64                          cuda-misc-headers-10-2-10.2.89-1.x86_64                 cuda-npp-10-2-10.2.89-1.x86_64                                   
  cuda-npp-dev-10-2-10.2.89-1.x86_64                           cuda-nsight-10-2-10.2.89-1.x86_64                       cuda-nsight-compute-10-2-10.2.89-1.x86_64                        
  cuda-nsight-systems-10-2-10.2.89-1.x86_64                    cuda-nvcc-10-2-10.2.89-1.x86_64                         cuda-nvdisasm-10-2-10.2.89-1.x86_64                              
  cuda-nvgraph-10-2-10.2.89-1.x86_64                           cuda-nvgraph-dev-10-2-10.2.89-1.x86_64                  cuda-nvjpeg-10-2-10.2.89-1.x86_64                                
  cuda-nvjpeg-dev-10-2-10.2.89-1.x86_64                        cuda-nvml-dev-10-2-10.2.89-1.x86_64                     cuda-nvprof-10-2-10.2.89-1.x86_64                                
  cuda-nvprune-10-2-10.2.89-1.x86_64                           cuda-nvrtc-10-2-10.2.89-1.x86_64                        cuda-nvrtc-dev-10-2-10.2.89-1.x86_64                             
  cuda-nvtx-10-2-10.2.89-1.x86_64                              cuda-nvvp-10-2-10.2.89-1.x86_64                         cuda-runtime-10-2-10.2.89-1.x86_64                               
  cuda-samples-10-2-10.2.89-1.x86_64                           cuda-sanitizer-api-10-2-10.2.89-1.x86_64                cuda-toolkit-10-2-10.2.89-1.x86_64                               
  cuda-tools-10-2-10.2.89-1.x86_64                             cuda-visual-tools-10-2-10.2.89-1.x86_64                 dnf-plugin-nvidia-1.1-1.el8.noarch                               
  kmod-nvidia-latest-dkms-3:440.33.01-1.el8.x86_64             libcublas-devel-10.2.2.89-1.x86_64                      libcublas10-10.2.2.89-1.x86_64                                   
  nsight-compute-2019.4.0-2019.4.0.12-1.x86_64                 nvidia-driver-3:440.33.01-1.el8.x86_64                  nvidia-driver-NVML-3:440.33.01-1.el8.x86_64                      
  nvidia-driver-NvFBCOpenGL-3:440.33.01-1.el8.x86_64           nvidia-driver-cuda-3:440.33.01-1.el8.x86_64             nvidia-driver-cuda-libs-3:440.33.01-1.el8.x86_64                 
  nvidia-driver-devel-3:440.33.01-1.el8.x86_64                 nvidia-driver-libs-3:440.33.01-1.el8.x86_64             nvidia-kmod-common-3:440.33.01-1.el8.noarch                      
  nvidia-libXNVCtrl-3:440.33.01-1.el8.x86_64                   nvidia-libXNVCtrl-devel-3:440.33.01-1.el8.x86_64        nvidia-modprobe-3:440.33.01-1.el8.x86_64                         
  nvidia-persistenced-3:440.33.01-1.el8.x86_64                 nvidia-settings-3:440.33.01-1.el8.x86_64                nvidia-xconfig-3:440.33.01-1.el8.x86_64                          
  dkms-2.7.1-2.el8.noarch                                      make-1:4.2.1-9.el8.x86_64                               libpkgconf-1.4.2-1.el8.x86_64                                    
  libmodman-2.0.1-17.el8.x86_64                                pkgconf-m4-1.4.2-1.el8.noarch                           pkgconf-1.4.2-1.el8.x86_64                                       
  libproxy-0.4.15-5.2.el8.x86_64                               glib-networking-2.56.1-1.1.el8.x86_64                   avahi-libs-0.7-19.el8.x86_64                                     
  libxcrypt-devel-4.1.1-4.el8.x86_64                           libsoup-2.62.3-1.el8.x86_64                             fontpackages-filesystem-1.44-22.el8.noarch                       
  libgusb-0.3.0-1.el8.x86_64                                   tar-2:1.30-4.el8.x86_64                                 lksctp-tools-1.0.18-3.el8.x86_64                                 
  libpciaccess-0.14-1.el8.x86_64                               fontconfig-2.13.1-3.el8.x86_64                          zlib-devel-1.2.11-10.el8.x86_64                                  
  binutils-2.30-58.el8.x86_64                                  elfutils-libelf-devel-0.176-5.el8.x86_64                gdk-pixbuf2-2.36.12-5.el8.x86_64                                 
  gsettings-desktop-schemas-3.32.0-3.el8.x86_64                glibc-devel-2.28-72.el8.x86_64                          pkgconf-pkg-config-1.4.2-1.el8.x86_64                            
  cups-libs-1:2.2.6-28.el8.x86_64                              glibc-headers-2.28-72.el8.x86_64                        kernel-headers-4.18.0-147.0.3.el8_1.x86_64                       
  libX11-common-1.6.7-1.el8.noarch                             adwaita-icon-theme-3.28.0-2.el8.noarch                  opencl-filesystem-1.0-6.el8.noarch                               
  adwaita-cursor-theme-3.28.0-2.el8.noarch                     xorg-x11-proto-devel-2018.4-1.el8.noarch                javapackages-filesystem-5.3.0-1.module+el8+2447+6f56d9a6.noarch  
  abattis-cantarell-fonts-0.0.25-4.el8.noarch                  libXdmcp-1.1.2-11.el8.x86_64                            libglvnd-opengl-1:1.0.1-0.9.git5baa1e5.el8.x86_64                
  xorg-x11-fonts-Type1-7.5-19.el8.noarch                       copy-jdk-configs-3.7-1.el8.noarch                       hicolor-icon-theme-0.17-2.el8.noarch                             
  libxcb-1.13-5.el8.x86_64                                     libwacom-data-0.31-1.el8.noarch                         gl-manpages-1.1-15.20161227.el8.noarch                           
  lcms2-2.9-2.el8.x86_64                                       mesa-libGLU-devel-9.0.0-15.el8.x86_64                   libXdamage-devel-1.1.4-14.el8.x86_64                             
  jbigkit-libs-2.1-14.el8.x86_64                               libXi-devel-1.7.9-7.el8.x86_64                          libXi-1.7.9-7.el8.x86_64                                         
  libXext-1.3.3-9.el8.x86_64                                   ocl-icd-2.2.12-1.el8.x86_64                             libXtst-1.2.3-7.el8.x86_64                                       
  libXinerama-1.1.4-1.el8.x86_64                               libglvnd-egl-1:1.0.1-0.9.git5baa1e5.el8.x86_64          libmpc-1.0.2-9.el8.x86_64                                        
  libglvnd-core-devel-1:1.0.1-0.9.git5baa1e5.el8.x86_64        xorg-x11-xkb-utils-7.7-27.el8.x86_64                    libvdpau-1.1.1-7.el8.x86_64                                      
  at-spi2-core-2.28.0-1.el8.x86_64                             ttmkfdir-3.0.9-54.el8.x86_64                            graphite2-1.3.10-10.el8.x86_64                                   
  libXfixes-devel-5.0.3-7.el8.x86_64                           libXcursor-1.1.15-3.el8.x86_64                          libXrandr-1.5.1-7.el8.x86_64                                     
  at-spi2-atk-2.26.2-1.el8.x86_64                              xorg-x11-drv-libinput-0.28.0-2.el8.x86_64               libwayland-egl-1.15.0-1.el8.x86_64                               
  libX11-devel-1.6.7-1.el8.x86_64                              libXfont2-2.0.3-2.el8.x86_64                            jasper-libs-2.0.14-4.el8.x86_64                                  
  libSM-1.2.3-1.el8.x86_64                                     libwayland-server-1.15.0-1.el8.x86_64                   libwayland-cursor-1.15.0-1.el8.x86_64                            
  libXft-2.3.2-10.el8.x86_64                                   libxkbfile-1.0.9-9.el8.x86_64                           libXfixes-5.0.3-7.el8.x86_64                                     
  libglvnd-1:1.0.1-0.9.git5baa1e5.el8.x86_64                   cairo-gobject-1.15.12-3.el8.x86_64                      libglvnd-gles-1:1.0.1-0.9.git5baa1e5.el8.x86_64                  
  libXau-1.0.8-13.el8.x86_64                                   freeglut-3.0.0-8.el8.x86_64                             libepoxy-1.5.2-1.el8.x86_64                                      
  freeglut-devel-3.0.0-8.el8.x86_64                            egl-wayland-1.1.2-1.el8.x86_64                          xorg-x11-drv-vesa-2.4.0-3.el8.x86_64                             
  libwacom-0.31-1.el8.x86_64                                   libXxf86vm-1.1.4-9.el8.x86_64                           xorg-x11-drv-fbdev-0.5.0-2.el8.x86_64                            
  libthai-0.1.27-2.el8.x86_64                                  colord-libs-1.4.2-1.el8.x86_64                          rest-0.8.1-2.el8.x86_64                                          
  libXdamage-1.1.4-14.el8.x86_64                               libXmu-devel-1.1.2-12.el8.x86_64                        libSM-devel-1.2.3-1.el8.x86_64                                   
  cairo-1.15.12-3.el8.x86_64                                   harfbuzz-1.7.5-3.el8.x86_64                             libXxf86vm-devel-1.1.4-9.el8.x86_64                              
  mesa-libGLU-9.0.0-15.el8.x86_64                              libXcomposite-0.4.4-14.el8.x86_64                       libfontenc-1.1.3-8.el8.x86_64                                    
  libwayland-client-1.15.0-1.el8.x86_64                        libX11-xcb-1.6.7-1.el8.x86_64                           libxcb-devel-1.13-5.el8.x86_64                                   
  libX11-1.6.7-1.el8.x86_64                                    fribidi-1.0.4-6.el8.x86_64                              libXrender-0.9.10-7.el8.x86_64                                   
  atk-2.28.1-1.el8.x86_64                                      libdatrie-0.2.9-7.el8.x86_64                            libxshmfence-1.3-2.el8.x86_64                                    
  giflib-5.1.4-3.el8.x86_64                                    libXext-devel-1.3.3-9.el8.x86_64                        libevdev-1.5.9-5.el8.x86_64                                      
  isl-0.16.1-6.el8.x86_64                                      libXau-devel-1.0.8-13.el8.x86_64                        pixman-0.36.0-1.el8.x86_64                                       
  libXmu-1.1.2-12.el8.x86_64                                   mtdev-1.1.5-12.el8.x86_64                               xorg-x11-font-utils-1:7.5-40.el8.x86_64                          
  libglvnd-glx-1:1.0.1-0.9.git5baa1e5.el8.x86_64               libglvnd-devel-1:1.0.1-0.9.git5baa1e5.el8.x86_64        libXt-1.1.5-12.el8.x86_64                                        
  tzdata-java-2019c-1.el8.noarch                               gcc-8.3.1-4.5.el8.x86_64                                mesa-libEGL-19.1.4-2.el8.x86_64                                  
  mesa-libGL-devel-19.1.4-2.el8.x86_64                         libjpeg-turbo-1.5.3-10.el8.x86_64                       mesa-vulkan-drivers-19.1.4-2.el8.x86_64                          
  mesa-libglapi-19.1.4-2.el8.x86_64                            alsa-lib-1.1.9-4.el8.x86_64                             gcc-c++-8.3.1-4.5.el8.x86_64                                     
  libXt-devel-1.1.5-12.el8.x86_64                              xorg-x11-server-common-1.20.3-11.el8.x86_64             xorg-x11-server-Xorg-1.20.3-11.el8.x86_64                        
  cpp-8.3.1-4.5.el8.x86_64                                     gtk-update-icon-cache-3.22.30-4.el8.x86_64              pango-1.42.4-6.el8.x86_64                                        
  libtiff-4.0.9-15.el8.x86_64                                  mesa-libgbm-19.1.4-2.el8.x86_64                         libdrm-2.4.98-2.el8.x86_64                                       
  lua-5.3.4-11.el8.x86_64                                      libICE-devel-1.0.9-15.el8.x86_64                        mesa-khr-devel-19.1.4-2.el8.x86_64                               
  libdrm-devel-2.4.98-2.el8.x86_64                             vulkan-loader-1.1.114.0-3.el8.x86_64                    java-1.8.0-openjdk-1:1.8.0.232.b09-2.el8_1.x86_64                
  gdk-pixbuf2-modules-2.36.12-5.el8.x86_64                     mesa-libGL-19.1.4-2.el8.x86_64                          gtk3-3.22.30-4.el8.x86_64                                        
  java-1.8.0-openjdk-headless-1:1.8.0.232.b09-2.el8_1.x86_64   llvm-libs-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64   libstdc++-devel-8.3.1-4.5.el8.x86_64                             
  libinput-1.13.2-1.el8.x86_64                                 libICE-1.0.9-15.el8.x86_64                             

Complete!

Reboot your node:

[egallen@lab0 ~]$ sudo systemctl reboot

Success the drivers are installed and the NVIDIA System Management Interface is reporting a positive status:

[egallen@lab0 ~]$ nvidia-smi 
Sun Dec 15 16:09:04 2019       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 440.33.01    Driver Version: 440.33.01    CUDA Version: 10.2     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  Tesla T4            Off  | 00000000:01:00.0 Off |                    0 |
| N/A   38C    P0    20W /  70W |      0MiB / 15109MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|  No running processes found                                                 |
+-----------------------------------------------------------------------------+

Monitor interactively the driver status:

[egallen@lab0 ~]$ nvidia-smi -q -g 0 -d UTILIZATION -l

==============NVSMI LOG==============

Timestamp                           : Sun Dec 15 17:20:16 2019
Driver Version                      : 440.33.01
CUDA Version                        : 10.2

Attached GPUs                       : 1
GPU 00000000:01:00.0
    Utilization
        Gpu                         : 0 %
        Memory                      : 0 %
        Encoder                     : 0 %
        Decoder                     : 0 %
    GPU Utilization Samples
        Duration                    : 9.84 sec
        Number of Samples           : 50
        Max                         : 4 %
        Min                         : 0 %
        Avg                         : 0 %
    Memory Utilization Samples
        Duration                    : 9.84 sec
        Number of Samples           : 50
        Max                         : 0 %
        Min                         : 0 %
        Avg                         : 0 %
    ENC Utilization Samples
        Duration                    : 9.84 sec
        Number of Samples           : 50
        Max                         : 0 %
        Min                         : 0 %
        Avg                         : 0 %
    DEC Utilization Samples
        Duration                    : 9.84 sec
        Number of Samples           : 50
        Max                         : 0 %
        Min                         : 0 %
        Avg                         : 0 %

The nvidia modules are available:

[egallen@lab0 ~]$ lsmod | grep -i nvidia
nvidia_drm             49152  0
nvidia_modeset       1114112  1 nvidia_drm
nvidia              19927040  1 nvidia_modeset
ipmi_msghandler       110592  1 nvidia
drm_kms_helper        217088  2 nvidia_drm,i915
drm                   524288  4 drm_kms_helper,nvidia_drm,i915

Nouveau modules are removed:

[egallen@lab0 ~]$ lsmod | grep -i nouveau
[egallen@lab0 ~]$ 

Nouveau is disabled in the grub configuration:

[root@lab0 etc]# cat /etc/default/grub | grep nouveau
GRUB_CMDLINE_LINUX="crashkernel=auto resume=/dev/mapper/rhel-swap rd.lvm.lv=rhel/root rd.lvm.lv=rhel/swap rhgb quiet rd.driver.blacklist=nouveau"

dkms nvidia is installed:

[egallen@lab0 ~]$ dkms status
nvidia, 440.33.01, 4.18.0-147.0.3.el8_1.x86_64, x86_64: installed

A DKMS log file is available to check action done during installation:

[egallen@lab0 ~]$ cat /var/lib/dkms/nvidia/440.33.01/4.18.0-147.0.3.el8_1.x86_64/x86_64/log/make.log 
DKMS make.log for nvidia-440.33.01 for kernel 4.18.0-147.0.3.el8_1.x86_64 (x86_64)
Sun Dec 15 16:05:16 CET 2019
make[1]: Entering directory '/usr/src/kernels/4.18.0-147.0.3.el8_1.x86_64'
  SYMLINK /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-kernel.o
  SYMLINK /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset/nv-modeset-kernel.o
 CONFTEST: hash__remap_4k_pfn
 CONFTEST: set_pages_uc
 CONFTEST: list_is_first
 CONFTEST: set_memory_uc
 CONFTEST: set_memory_array_uc
 CONFTEST: acquire_console_sem
 CONFTEST: console_lock
 CONFTEST: ioremap_cache
 CONFTEST: ioremap_wc
 CONFTEST: acpi_walk_namespace
 CONFTEST: sg_alloc_table
 CONFTEST: pci_get_domain_bus_and_slot
 CONFTEST: get_num_physpages
 CONFTEST: efi_enabled
 CONFTEST: pde_data
 CONFTEST: proc_remove
 CONFTEST: pm_vt_switch_required
 CONFTEST: xen_ioemu_inject_msi
 CONFTEST: phys_to_dma
 CONFTEST: get_dma_ops
 CONFTEST: write_cr4
 CONFTEST: of_get_property
 CONFTEST: of_find_node_by_phandle
 CONFTEST: of_node_to_nid
 CONFTEST: pnv_pci_get_npu_dev
 CONFTEST: of_get_ibm_chip_id
 CONFTEST: node_end_pfn
 CONFTEST: pci_bus_address
 CONFTEST: pci_stop_and_remove_bus_device
 CONFTEST: pci_remove_bus_device
 CONFTEST: register_cpu_notifier
 CONFTEST: cpuhp_setup_state
 CONFTEST: dma_map_resource
 CONFTEST: backlight_device_register
 CONFTEST: timer_setup
 CONFTEST: pci_enable_msix_range
 CONFTEST: do_gettimeofday
 CONFTEST: kernel_read
 CONFTEST: kernel_write
 CONFTEST: kthread_create_on_node
 CONFTEST: of_find_matching_node
 CONFTEST: dev_is_pci
 CONFTEST: dma_direct_map_resource
 CONFTEST: tegra_get_platform
 CONFTEST: flush_cache_all
 CONFTEST: vmf_insert_pfn
 CONFTEST: address_space_init_once
 CONFTEST: kbasename
 CONFTEST: vzalloc
 CONFTEST: wait_on_bit_lock_argument_count
 CONFTEST: bitmap_clear
 CONFTEST: usleep_range
 CONFTEST: radix_tree_empty
 CONFTEST: radix_tree_replace_slot
 CONFTEST: pnv_npu2_init_context
 CONFTEST: cpumask_of_node
 CONFTEST: drm_dev_unref
 CONFTEST: drm_reinit_primary_mode_group
 CONFTEST: get_user_pages_remote
 CONFTEST: get_user_pages
 CONFTEST: drm_gem_object_lookup
 CONFTEST: drm_atomic_state_ref_counting
 CONFTEST: drm_driver_has_gem_prime_res_obj
 CONFTEST: drm_atomic_helper_connector_dpms
 CONFTEST: drm_connector_funcs_have_mode_in_name
 CONFTEST: drm_framebuffer_get
 CONFTEST: drm_gem_object_get
 CONFTEST: drm_dev_put
 CONFTEST: is_export_symbol_gpl_of_node_to_nid
 CONFTEST: is_export_symbol_present_swiotlb_map_sg_attrs
 CONFTEST: is_export_symbol_present_swiotlb_dma_ops
 CONFTEST: is_export_symbol_present_kthread_create_on_node
 CONFTEST: acpi_op_remove
 CONFTEST: outer_flush_all
 CONFTEST: file_operations
 CONFTEST: file_inode
 CONFTEST: kuid_t
 CONFTEST: dma_ops
 CONFTEST: swiotlb_dma_ops
 CONFTEST: noncoherent_swiotlb_dma_ops
 CONFTEST: vm_fault_has_address
 CONFTEST: backlight_properties_type
 CONFTEST: vm_insert_pfn_prot
 CONFTEST: vmf_insert_pfn_prot
 CONFTEST: vm_ops_fault_removed_vma_arg
 CONFTEST: vmbus_channel_has_ringbuffer_page
 CONFTEST: device_driver_of_match_table
 CONFTEST: device_of_node
 CONFTEST: node_states_n_memory
 CONFTEST: kmem_cache_has_kobj_remove_work
 CONFTEST: sysfs_slab_unlink
 CONFTEST: address_space
 CONFTEST: backing_dev_info
 CONFTEST: mm_context_t
 CONFTEST: drm_bus_present
 CONFTEST: drm_bus_has_bus_type
 CONFTEST: drm_bus_has_get_irq
 CONFTEST: drm_bus_has_get_name
 CONFTEST: drm_driver_has_legacy_dev_list
 CONFTEST: drm_driver_has_set_busid
 CONFTEST: drm_crtc_state_has_connectors_changed
 CONFTEST: drm_init_function_args
 CONFTEST: drm_helper_mode_fill_fb_struct
 CONFTEST: drm_master_drop_has_from_release_arg
 CONFTEST: drm_driver_unload_has_int_return_type
 CONFTEST: drm_atomic_helper_crtc_destroy_state_has_crtc_arg
 CONFTEST: drm_crtc_helper_funcs_has_atomic_enable
 CONFTEST: drm_mode_object_find_has_file_priv_arg
 CONFTEST: dma_buf_owner
 CONFTEST: drm_connector_list_iter
 CONFTEST: drm_atomic_helper_swap_state_has_stall_arg
 CONFTEST: drm_driver_prime_flag_present
 CONFTEST: dom0_kernel_present
 CONFTEST: nvidia_vgpu_hyperv_available
 CONFTEST: nvidia_vgpu_kvm_build
 CONFTEST: nvidia_grid_build
 CONFTEST: nvidia_grid_csp_build
 CONFTEST: pm_runtime_available
 CONFTEST: drm_available
 CONFTEST: drm_atomic_available
 CONFTEST: is_export_symbol_gpl_refcount_inc
 CONFTEST: is_export_symbol_gpl_refcount_dec_and_test
 CONFTEST: drm_alpha_blending_available
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-frontend.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-pci.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-acpi.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-cray.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-dma.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-i2c.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-mempool.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-mmap.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-p2p.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-pat.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-procfs.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-usermap.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-vm.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-vtophys.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-interface.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-mlock.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-pci.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-registry.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-usermap.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-modeset-interface.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-pci-table.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-kthread-q.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-memdbg.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-ibmnpu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-report-err.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-rsync.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-msi.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv_uvm_interface.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nvlink_linux.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/linux_nvswitch.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm_utils.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm_common.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm_linux.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/nvstatus.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/nvCpuUuid.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/nv-kthread-q.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/nv-kthread-q-selftest.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_tools.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_global.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_gpu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_gpu_isr.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_procfs.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_va_space.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_va_space_mm.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_gpu_semaphore.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_mem.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_rm_mem.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_channel.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_lock.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_hal.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_range_tree.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_range_allocator.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_va_range.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_va_block.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_range_group.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_gpu_replayable_faults.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_gpu_non_replayable_faults.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_gpu_access_counters.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_events.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_module.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_mmu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pte_batch.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_tlb_batch.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_push.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pushbuffer.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_thread_context.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_tracker.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_kepler.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_kepler_ce.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_kepler_host.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_kepler_mmu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_maxwell.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_maxwell_host.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pascal.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pascal_ce.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pascal_host.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pascal_mmu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pascal_fault_buffer.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_volta_host.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_volta_mmu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_volta.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_volta_fault_buffer.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_volta_access_counter_buffer.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_turing.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_turing_mmu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_turing_host.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_policy.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_utils.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_kvmalloc.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pmm_sysmem.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pmm_gpu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_migrate.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_populate_pageable.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_migrate_pageable.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_map_external.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_user_channel.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_hmm.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_heuristics.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_thrashing.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_prefetch.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_ats_ibm.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_ats_faults.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_test_rng.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_range_tree_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_range_allocator_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_gpu_semaphore_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_mem_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_rm_mem_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_page_tree_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_tracker_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_push_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_channel_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_ce_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_lock_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_utils_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_kvmalloc_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pmm_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pmm_sysmem_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_events_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_module_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_get_rm_ptes_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_fault_buffer_flush_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_mmu_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_peer_identity_mappings_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_va_block_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_range_group_tree_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_thread_context_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset/nvidia-modeset-linux.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset/nv-kthread-q.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-drv.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-utils.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-crtc.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-encoder.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-connector.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-gem.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-fb.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-modeset.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-prime-fence.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-linux.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-helper.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nv-pci-table.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-gem-nvkms-memory.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-gem-user-memory.o
ld -r -o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-interface.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-frontend.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-pci.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-acpi.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-cray.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-dma.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-i2c.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-mempool.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-mmap.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-p2p.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-pat.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-procfs.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-usermap.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-vm.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-vtophys.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-interface.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-mlock.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-pci.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-registry.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-usermap.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-modeset-interface.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-pci-table.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-kthread-q.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-memdbg.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-ibmnpu.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-report-err.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-rsync.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-msi.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv_uvm_interface.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nvlink_linux.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/linux_nvswitch.o
ld -r -o /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset/nv-modeset-interface.o /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset/nvidia-modeset-linux.o /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset/nv-kthread-q.o
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia.o
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm.o
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset.o
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm.o
  Building modules, stage 2.
  MODPOST 4 modules
  CC      /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm.mod.o
  CC      /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset.mod.o
  CC      /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm.mod.o
  CC      /var/lib/dkms/nvidia/440.33.01/build/nvidia.mod.o
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm.ko
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset.ko
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm.ko
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia.ko
make[1]: Leaving directory '/usr/src/kernels/4.18.0-147.0.3.el8_1.x86_64'
[egallen@lab0 ~]$ cat /var/lib/dkms/nvidia/440.33.01/4.18.0-147.0.3.el8_1.x86_64/x86_64/log/make.log | wc -l
292
[egallen@lab0 ~]$ cat /var/lib/dkms/nvidia/440.33.01/4.18.0-147.0.3.el8_1.x86_64/x86_64/log/make.log
DKMS make.log for nvidia-440.33.01 for kernel 4.18.0-147.0.3.el8_1.x86_64 (x86_64)
Sun Dec 15 16:05:16 CET 2019
make[1]: Entering directory '/usr/src/kernels/4.18.0-147.0.3.el8_1.x86_64'
  SYMLINK /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-kernel.o
  SYMLINK /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset/nv-modeset-kernel.o
 CONFTEST: hash__remap_4k_pfn
 CONFTEST: set_pages_uc
 CONFTEST: list_is_first
 CONFTEST: set_memory_uc
 CONFTEST: set_memory_array_uc
 CONFTEST: acquire_console_sem
 CONFTEST: console_lock
 CONFTEST: ioremap_cache
 CONFTEST: ioremap_wc
 CONFTEST: acpi_walk_namespace
 CONFTEST: sg_alloc_table
 CONFTEST: pci_get_domain_bus_and_slot
 CONFTEST: get_num_physpages
 CONFTEST: efi_enabled
 CONFTEST: pde_data
 CONFTEST: proc_remove
 CONFTEST: pm_vt_switch_required
 CONFTEST: xen_ioemu_inject_msi
 CONFTEST: phys_to_dma
 CONFTEST: get_dma_ops
 CONFTEST: write_cr4
 CONFTEST: of_get_property
 CONFTEST: of_find_node_by_phandle
 CONFTEST: of_node_to_nid
 CONFTEST: pnv_pci_get_npu_dev
 CONFTEST: of_get_ibm_chip_id
 CONFTEST: node_end_pfn
 CONFTEST: pci_bus_address
 CONFTEST: pci_stop_and_remove_bus_device
 CONFTEST: pci_remove_bus_device
 CONFTEST: register_cpu_notifier
 CONFTEST: cpuhp_setup_state
 CONFTEST: dma_map_resource
 CONFTEST: backlight_device_register
 CONFTEST: timer_setup
 CONFTEST: pci_enable_msix_range
 CONFTEST: do_gettimeofday
 CONFTEST: kernel_read
 CONFTEST: kernel_write
 CONFTEST: kthread_create_on_node
 CONFTEST: of_find_matching_node
 CONFTEST: dev_is_pci
 CONFTEST: dma_direct_map_resource
 CONFTEST: tegra_get_platform
 CONFTEST: flush_cache_all
 CONFTEST: vmf_insert_pfn
 CONFTEST: address_space_init_once
 CONFTEST: kbasename
 CONFTEST: vzalloc
 CONFTEST: wait_on_bit_lock_argument_count
 CONFTEST: bitmap_clear
 CONFTEST: usleep_range
 CONFTEST: radix_tree_empty
 CONFTEST: radix_tree_replace_slot
 CONFTEST: pnv_npu2_init_context
 CONFTEST: cpumask_of_node
 CONFTEST: drm_dev_unref
 CONFTEST: drm_reinit_primary_mode_group
 CONFTEST: get_user_pages_remote
 CONFTEST: get_user_pages
 CONFTEST: drm_gem_object_lookup
 CONFTEST: drm_atomic_state_ref_counting
 CONFTEST: drm_driver_has_gem_prime_res_obj
 CONFTEST: drm_atomic_helper_connector_dpms
 CONFTEST: drm_connector_funcs_have_mode_in_name
 CONFTEST: drm_framebuffer_get
 CONFTEST: drm_gem_object_get
 CONFTEST: drm_dev_put
 CONFTEST: is_export_symbol_gpl_of_node_to_nid
 CONFTEST: is_export_symbol_present_swiotlb_map_sg_attrs
 CONFTEST: is_export_symbol_present_swiotlb_dma_ops
 CONFTEST: is_export_symbol_present_kthread_create_on_node
 CONFTEST: acpi_op_remove
 CONFTEST: outer_flush_all
 CONFTEST: file_operations
 CONFTEST: file_inode
 CONFTEST: kuid_t
 CONFTEST: dma_ops
 CONFTEST: swiotlb_dma_ops
 CONFTEST: noncoherent_swiotlb_dma_ops
 CONFTEST: vm_fault_has_address
 CONFTEST: backlight_properties_type
 CONFTEST: vm_insert_pfn_prot
 CONFTEST: vmf_insert_pfn_prot
 CONFTEST: vm_ops_fault_removed_vma_arg
 CONFTEST: vmbus_channel_has_ringbuffer_page
 CONFTEST: device_driver_of_match_table
 CONFTEST: device_of_node
 CONFTEST: node_states_n_memory
 CONFTEST: kmem_cache_has_kobj_remove_work
 CONFTEST: sysfs_slab_unlink
 CONFTEST: address_space
 CONFTEST: backing_dev_info
 CONFTEST: mm_context_t
 CONFTEST: drm_bus_present
 CONFTEST: drm_bus_has_bus_type
 CONFTEST: drm_bus_has_get_irq
 CONFTEST: drm_bus_has_get_name
 CONFTEST: drm_driver_has_legacy_dev_list
 CONFTEST: drm_driver_has_set_busid
 CONFTEST: drm_crtc_state_has_connectors_changed
 CONFTEST: drm_init_function_args
 CONFTEST: drm_helper_mode_fill_fb_struct
 CONFTEST: drm_master_drop_has_from_release_arg
 CONFTEST: drm_driver_unload_has_int_return_type
 CONFTEST: drm_atomic_helper_crtc_destroy_state_has_crtc_arg
 CONFTEST: drm_crtc_helper_funcs_has_atomic_enable
 CONFTEST: drm_mode_object_find_has_file_priv_arg
 CONFTEST: dma_buf_owner
 CONFTEST: drm_connector_list_iter
 CONFTEST: drm_atomic_helper_swap_state_has_stall_arg
 CONFTEST: drm_driver_prime_flag_present
 CONFTEST: dom0_kernel_present
 CONFTEST: nvidia_vgpu_hyperv_available
 CONFTEST: nvidia_vgpu_kvm_build
 CONFTEST: nvidia_grid_build
 CONFTEST: nvidia_grid_csp_build
 CONFTEST: pm_runtime_available
 CONFTEST: drm_available
 CONFTEST: drm_atomic_available
 CONFTEST: is_export_symbol_gpl_refcount_inc
 CONFTEST: is_export_symbol_gpl_refcount_dec_and_test
 CONFTEST: drm_alpha_blending_available
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-frontend.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-pci.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-acpi.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-cray.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-dma.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-i2c.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-mempool.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-mmap.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-p2p.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-pat.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-procfs.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-usermap.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-vm.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-vtophys.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-interface.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-mlock.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-pci.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-registry.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-usermap.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-modeset-interface.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-pci-table.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-kthread-q.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-memdbg.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-ibmnpu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-report-err.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-rsync.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-msi.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv_uvm_interface.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/nvlink_linux.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia/linux_nvswitch.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm_utils.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm_common.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm_linux.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/nvstatus.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/nvCpuUuid.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/nv-kthread-q.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/nv-kthread-q-selftest.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_tools.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_global.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_gpu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_gpu_isr.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_procfs.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_va_space.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_va_space_mm.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_gpu_semaphore.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_mem.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_rm_mem.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_channel.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_lock.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_hal.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_range_tree.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_range_allocator.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_va_range.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_va_block.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_range_group.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_gpu_replayable_faults.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_gpu_non_replayable_faults.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_gpu_access_counters.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_events.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_module.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_mmu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pte_batch.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_tlb_batch.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_push.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pushbuffer.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_thread_context.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_tracker.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_kepler.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_kepler_ce.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_kepler_host.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_kepler_mmu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_maxwell.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_maxwell_host.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pascal.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pascal_ce.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pascal_host.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pascal_mmu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pascal_fault_buffer.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_volta_host.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_volta_mmu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_volta.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_volta_fault_buffer.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_volta_access_counter_buffer.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_turing.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_turing_mmu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_turing_host.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_policy.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_utils.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_kvmalloc.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pmm_sysmem.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pmm_gpu.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_migrate.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_populate_pageable.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_migrate_pageable.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_map_external.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_user_channel.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_hmm.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_heuristics.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_thrashing.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_prefetch.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_ats_ibm.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_ats_faults.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_test_rng.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_range_tree_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_range_allocator_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_gpu_semaphore_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_mem_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_rm_mem_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_page_tree_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_tracker_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_push_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_channel_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_ce_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_lock_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_utils_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_kvmalloc_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pmm_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_pmm_sysmem_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_events_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_perf_module_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_get_rm_ptes_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_fault_buffer_flush_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_mmu_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_peer_identity_mappings_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_va_block_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_range_group_tree_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm/uvm8_thread_context_test.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset/nvidia-modeset-linux.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset/nv-kthread-q.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-drv.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-utils.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-crtc.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-encoder.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-connector.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-gem.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-fb.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-modeset.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-prime-fence.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-linux.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-helper.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nv-pci-table.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-gem-nvkms-memory.o
  CC [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm/nvidia-drm-gem-user-memory.o
ld -r -o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-interface.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-frontend.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-pci.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-acpi.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-cray.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-dma.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-i2c.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-mempool.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-mmap.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-p2p.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-pat.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-procfs.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-usermap.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-vm.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-vtophys.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-interface.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-mlock.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-pci.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-registry.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/os-usermap.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-modeset-interface.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-pci-table.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-kthread-q.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-memdbg.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-ibmnpu.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-report-err.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-rsync.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv-msi.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nv_uvm_interface.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/nvlink_linux.o /var/lib/dkms/nvidia/440.33.01/build/nvidia/linux_nvswitch.o
ld -r -o /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset/nv-modeset-interface.o /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset/nvidia-modeset-linux.o /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset/nv-kthread-q.o
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia.o
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm.o
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset.o
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm.o
  Building modules, stage 2.
  MODPOST 4 modules
  CC      /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm.mod.o
  CC      /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset.mod.o
  CC      /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm.mod.o
  CC      /var/lib/dkms/nvidia/440.33.01/build/nvidia.mod.o
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-drm.ko
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-modeset.ko
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia-uvm.ko
  LD [M]  /var/lib/dkms/nvidia/440.33.01/build/nvidia.ko
make[1]: Leaving directory '/usr/src/kernels/4.18.0-147.0.3.el8_1.x86_64'

Check nvidia and cuda packages installed:

[egallen@lab0 ~]$ dnf list installed | grep -E 'nvidia|cuda'
cuda.x86_64                                   10.2.89-1                              @cuda                            
cuda-10-2.x86_64                              10.2.89-1                              @cuda                            
cuda-command-line-tools-10-2.x86_64           10.2.89-1                              @cuda                            
cuda-compiler-10-2.x86_64                     10.2.89-1                              @cuda                            
cuda-cudart-10-2.x86_64                       10.2.89-1                              @cuda                            
cuda-cudart-dev-10-2.x86_64                   10.2.89-1                              @cuda                            
cuda-cufft-10-2.x86_64                        10.2.89-1                              @cuda                            
cuda-cufft-dev-10-2.x86_64                    10.2.89-1                              @cuda                            
cuda-cuobjdump-10-2.x86_64                    10.2.89-1                              @cuda                            
cuda-cupti-10-2.x86_64                        10.2.89-1                              @cuda                            
cuda-curand-10-2.x86_64                       10.2.89-1                              @cuda                            
cuda-curand-dev-10-2.x86_64                   10.2.89-1                              @cuda                            
cuda-cusolver-10-2.x86_64                     10.2.89-1                              @cuda                            
cuda-cusolver-dev-10-2.x86_64                 10.2.89-1                              @cuda                            
cuda-cusparse-10-2.x86_64                     10.2.89-1                              @cuda                            
cuda-cusparse-dev-10-2.x86_64                 10.2.89-1                              @cuda                            
cuda-demo-suite-10-2.x86_64                   10.2.89-1                              @cuda                            
cuda-documentation-10-2.x86_64                10.2.89-1                              @cuda                            
cuda-driver-dev-10-2.x86_64                   10.2.89-1                              @cuda                            
cuda-drivers.x86_64                           440.33.01-1                            @cuda                            
cuda-gdb-10-2.x86_64                          10.2.89-1                              @cuda                            
cuda-libraries-10-2.x86_64                    10.2.89-1                              @cuda                            
cuda-libraries-dev-10-2.x86_64                10.2.89-1                              @cuda                            
cuda-license-10-2.x86_64                      10.2.89-1                              @cuda                            
cuda-memcheck-10-2.x86_64                     10.2.89-1                              @cuda                            
cuda-misc-headers-10-2.x86_64                 10.2.89-1                              @cuda                            
cuda-npp-10-2.x86_64                          10.2.89-1                              @cuda                            
cuda-npp-dev-10-2.x86_64                      10.2.89-1                              @cuda                            
cuda-nsight-10-2.x86_64                       10.2.89-1                              @cuda                            
cuda-nsight-compute-10-2.x86_64               10.2.89-1                              @cuda                            
cuda-nsight-systems-10-2.x86_64               10.2.89-1                              @cuda                            
cuda-nvcc-10-2.x86_64                         10.2.89-1                              @cuda                            
cuda-nvdisasm-10-2.x86_64                     10.2.89-1                              @cuda                            
cuda-nvgraph-10-2.x86_64                      10.2.89-1                              @cuda                            
cuda-nvgraph-dev-10-2.x86_64                  10.2.89-1                              @cuda                            
cuda-nvjpeg-10-2.x86_64                       10.2.89-1                              @cuda                            
cuda-nvjpeg-dev-10-2.x86_64                   10.2.89-1                              @cuda                            
cuda-nvml-dev-10-2.x86_64                     10.2.89-1                              @cuda                            
cuda-nvprof-10-2.x86_64                       10.2.89-1                              @cuda                            
cuda-nvprune-10-2.x86_64                      10.2.89-1                              @cuda                            
cuda-nvrtc-10-2.x86_64                        10.2.89-1                              @cuda                            
cuda-nvrtc-dev-10-2.x86_64                    10.2.89-1                              @cuda                            
cuda-nvtx-10-2.x86_64                         10.2.89-1                              @cuda                            
cuda-nvvp-10-2.x86_64                         10.2.89-1                              @cuda                            
cuda-runtime-10-2.x86_64                      10.2.89-1                              @cuda                            
cuda-samples-10-2.x86_64                      10.2.89-1                              @cuda                            
cuda-sanitizer-api-10-2.x86_64                10.2.89-1                              @cuda                            
cuda-toolkit-10-2.x86_64                      10.2.89-1                              @cuda                            
cuda-tools-10-2.x86_64                        10.2.89-1                              @cuda                            
cuda-visual-tools-10-2.x86_64                 10.2.89-1                              @cuda                            
dnf-plugin-nvidia.noarch                      1.1-1.el8                              @cuda                            
kmod-nvidia-latest-dkms.x86_64                3:440.33.01-1.el8                      @cuda                            
libcublas-devel.x86_64                        10.2.2.89-1                            @cuda                            
libcublas10.x86_64                            10.2.2.89-1                            @cuda                            
nsight-compute-2019.4.0.x86_64                2019.4.0.12-1                          @cuda                            
nsight-systems-2019.5.2.x86_64                2019.5.2.16_b54ef97-0                  @cuda                            
nvidia-driver.x86_64                          3:440.33.01-1.el8                      @cuda                            
nvidia-driver-NVML.x86_64                     3:440.33.01-1.el8                      @cuda                            
nvidia-driver-NvFBCOpenGL.x86_64              3:440.33.01-1.el8                      @cuda                            
nvidia-driver-cuda.x86_64                     3:440.33.01-1.el8                      @cuda                            
nvidia-driver-cuda-libs.x86_64                3:440.33.01-1.el8                      @cuda                            
nvidia-driver-devel.x86_64                    3:440.33.01-1.el8                      @cuda                            
nvidia-driver-libs.x86_64                     3:440.33.01-1.el8                      @cuda                            
nvidia-kmod-common.noarch                     3:440.33.01-1.el8                      @cuda                            
nvidia-libXNVCtrl.x86_64                      3:440.33.01-1.el8                      @cuda                            
nvidia-libXNVCtrl-devel.x86_64                3:440.33.01-1.el8                      @cuda                            
nvidia-modprobe.x86_64                        3:440.33.01-1.el8                      @cuda                            
nvidia-persistenced.x86_64                    3:440.33.01-1.el8                      @cuda                            
nvidia-settings.x86_64                        3:440.33.01-1.el8                      @cuda                            
nvidia-xconfig.x86_64                         3:440.33.01-1.el8                      @cuda   

Check kernel modules installed:

[egallen@lab0 ~]$ dnf list installed|grep 'kernel'
kernel.x86_64                                 4.18.0-147.el8                         @anaconda                        
kernel.x86_64                                 4.18.0-147.0.3.el8_1                   @rhel-8-for-x86_64-baseos-rpms   
kernel-core.x86_64                            4.18.0-147.el8                         @anaconda                        
kernel-core.x86_64                            4.18.0-147.0.3.el8_1                   @rhel-8-for-x86_64-baseos-rpms   
kernel-devel.x86_64                           4.18.0-147.0.3.el8_1                   @rhel-8-for-x86_64-baseos-rpms   
kernel-headers.x86_64                         4.18.0-147.0.3.el8_1                   @rhel-8-for-x86_64-baseos-rpms   
kernel-modules.x86_64                         4.18.0-147.el8                         @anaconda                        
kernel-modules.x86_64                         4.18.0-147.0.3.el8_1                   @rhel-8-for-x86_64-baseos-rpms   
kernel-tools.x86_64                           4.18.0-147.0.3.el8_1                   @rhel-8-for-x86_64-baseos-rpms   
kernel-tools-libs.x86_64                      4.18.0-147.0.3.el8_1                   @rhel-8-for-x86_64-baseos-rpms 

SELinux is enabled:

[egallen@lab0 ~]$ getenforce
Enforcing

Enable GPU with podman

Now we will install podman, offical documentation: https://access.redhat.com/solutions/3650231

Since RHEL 8, the podman container engine is included in a module called container-tools. Instead of using a classic “dnf install” command we will use the container-tools module:

[egallen@lab0 ~]$ sudo dnf module install container-tools -y
Updating Subscription Management repositories.
Last metadata expiration check: 0:04:18 ago on Sun 15 Dec 2019 05:21:08 PM CET.
Dependencies resolved.
========================================================================================================================================================================================
 Package                                     Architecture          Version                                                        Repository                                       Size
========================================================================================================================================================================================
Installing group/module packages:
 oci-umount                                  x86_64                2:2.3.4-2.git87f9237.module+el8+2769+577ad176                  rhel-8-for-x86_64-appstream-rpms                 38 k
 oci-systemd-hook                            x86_64                1:0.1.15-2.git2d0b8a3.module+el8+2769+577ad176                 rhel-8-for-x86_64-appstream-rpms                 39 k
 slirp4netns                                 x86_64                0.3.0-4.module+el8.1.0+4306+1d917805                           rhel-8-for-x86_64-appstream-rpms                 83 k
 skopeo                                      x86_64                1:0.1.37-5.module+el8.1.0+4240+893c1ab8                        rhel-8-for-x86_64-appstream-rpms                5.3 M
 podman                                      x86_64                1.4.2-5.module+el8.1.0+4240+893c1ab8                           rhel-8-for-x86_64-appstream-rpms                 11 M
 buildah                                     x86_64                1.9.0-5.module+el8.1.0+4240+893c1ab8                           rhel-8-for-x86_64-appstream-rpms                6.4 M
 runc                                        x86_64                1.0.0-60.rc8.module+el8.1.0+4081+b29780af                      rhel-8-for-x86_64-appstream-rpms                2.5 M
 fuse-overlayfs                              x86_64                0.4.1-1.module+el8.1.0+4081+b29780af                           rhel-8-for-x86_64-appstream-rpms                 50 k
 container-selinux                           noarch                2:2.107-2.module+el8.1.0+4081+b29780af                         rhel-8-for-x86_64-appstream-rpms                 44 k
 containernetworking-plugins                 x86_64                0.8.1-2.module+el8.1.0+4081+b29780af                           rhel-8-for-x86_64-appstream-rpms                 20 M
Installing dependencies:
 fuse3-libs                                  x86_64                3.2.1-12.el8                                                   rhel-8-for-x86_64-baseos-rpms                    94 k
 python3-setools                             x86_64                4.2.2-1.el8                                                    rhel-8-for-x86_64-baseos-rpms                   600 k
 python3-audit                               x86_64                3.0-0.13.20190507gitf58ec40.el8                                rhel-8-for-x86_64-baseos-rpms                    85 k
 policycoreutils-python-utils                noarch                2.9-3.el8                                                      rhel-8-for-x86_64-baseos-rpms                   250 k
 python3-policycoreutils                     noarch                2.9-3.el8                                                      rhel-8-for-x86_64-baseos-rpms                   2.2 M
 checkpolicy                                 x86_64                2.9-1.el8                                                      rhel-8-for-x86_64-baseos-rpms                   346 k
 python3-libsemanage                         x86_64                2.9-1.el8                                                      rhel-8-for-x86_64-baseos-rpms                   127 k
 libnet                                      x86_64                1.1.6-15.el8                                                   rhel-8-for-x86_64-appstream-rpms                 67 k
 yajl                                        x86_64                2.1.0-10.el8                                                   rhel-8-for-x86_64-appstream-rpms                 41 k
 protobuf-c                                  x86_64                1.3.0-4.el8                                                    rhel-8-for-x86_64-appstream-rpms                 37 k
 containers-common                           x86_64                1:0.1.37-5.module+el8.1.0+4240+893c1ab8                        rhel-8-for-x86_64-appstream-rpms                 32 k
 podman-manpages                             noarch                1.4.2-5.module+el8.1.0+4240+893c1ab8                           rhel-8-for-x86_64-appstream-rpms                180 k
 ostree-libs                                 x86_64                2019.2-1.el8                                                   rhel-8-for-x86_64-appstream-rpms                389 k
 criu                                        x86_64                3.12-9.el8                                                     rhel-8-for-x86_64-appstream-rpms                482 k
Installing weak dependencies:
 libvarlink                                  x86_64                18-3.el8                                                       rhel-8-for-x86_64-baseos-rpms                    44 k
Installing module profiles:
 container-tools/common                                                                                                                                                                
Enabling module streams:
 container-tools                                                   rhel8                                                                                                               

Transaction Summary
========================================================================================================================================================================================
Install  25 Packages

Total download size: 51 M
Installed size: 189 M
Downloading Packages:
(1/25): python3-audit-3.0-0.13.20190507gitf58ec40.el8.x86_64.rpm                                                                                        225 kB/s |  85 kB     00:00    
(2/25): fuse3-libs-3.2.1-12.el8.x86_64.rpm                                                                                                              231 kB/s |  94 kB     00:00    
(3/25): python3-setools-4.2.2-1.el8.x86_64.rpm                                                                                                          1.2 MB/s | 600 kB     00:00    
(4/25): policycoreutils-python-utils-2.9-3.el8.noarch.rpm                                                                                               751 kB/s | 250 kB     00:00    
(5/25): python3-policycoreutils-2.9-3.el8.noarch.rpm                                                                                                    6.6 MB/s | 2.2 MB     00:00    
(6/25): checkpolicy-2.9-1.el8.x86_64.rpm                                                                                                                772 kB/s | 346 kB     00:00    
(7/25): python3-libsemanage-2.9-1.el8.x86_64.rpm                                                                                                        402 kB/s | 127 kB     00:00    
(8/25): libvarlink-18-3.el8.x86_64.rpm                                                                                                                  149 kB/s |  44 kB     00:00    
(9/25): libnet-1.1.6-15.el8.x86_64.rpm                                                                                                                  217 kB/s |  67 kB     00:00    
(10/25): protobuf-c-1.3.0-4.el8.x86_64.rpm                                                                                                              121 kB/s |  37 kB     00:00    
(11/25): yajl-2.1.0-10.el8.x86_64.rpm                                                                                                                    96 kB/s |  41 kB     00:00    
(12/25): oci-systemd-hook-0.1.15-2.git2d0b8a3.module+el8+2769+577ad176.x86_64.rpm                                                                       133 kB/s |  39 kB     00:00    
(13/25): slirp4netns-0.3.0-4.module+el8.1.0+4306+1d917805.x86_64.rpm                                                                                    248 kB/s |  83 kB     00:00    
(14/25): containers-common-0.1.37-5.module+el8.1.0+4240+893c1ab8.x86_64.rpm                                                                             105 kB/s |  32 kB     00:00    
(15/25): skopeo-0.1.37-5.module+el8.1.0+4240+893c1ab8.x86_64.rpm                                                                                        8.0 MB/s | 5.3 MB     00:00    
(16/25): podman-1.4.2-5.module+el8.1.0+4240+893c1ab8.x86_64.rpm                                                                                          19 MB/s |  11 MB     00:00    
(17/25): buildah-1.9.0-5.module+el8.1.0+4240+893c1ab8.x86_64.rpm                                                                                         11 MB/s | 6.4 MB     00:00    
(18/25): oci-umount-2.3.4-2.git87f9237.module+el8+2769+577ad176.x86_64.rpm                                                                               20 kB/s |  38 kB     00:01    
(19/25): runc-1.0.0-60.rc8.module+el8.1.0+4081+b29780af.x86_64.rpm                                                                                      5.7 MB/s | 2.5 MB     00:00    
(20/25): podman-manpages-1.4.2-5.module+el8.1.0+4240+893c1ab8.noarch.rpm                                                                                573 kB/s | 180 kB     00:00    
(21/25): ostree-libs-2019.2-1.el8.x86_64.rpm                                                                                                            1.3 MB/s | 389 kB     00:00    
(22/25): fuse-overlayfs-0.4.1-1.module+el8.1.0+4081+b29780af.x86_64.rpm                                                                                 155 kB/s |  50 kB     00:00    
(23/25): container-selinux-2.107-2.module+el8.1.0+4081+b29780af.noarch.rpm                                                                              128 kB/s |  44 kB     00:00    
(24/25): criu-3.12-9.el8.x86_64.rpm                                                                                                                     1.4 MB/s | 482 kB     00:00    
(25/25): containernetworking-plugins-0.8.1-2.module+el8.1.0+4081+b29780af.x86_64.rpm                                                                    8.5 MB/s |  20 MB     00:02    
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                   8.8 MB/s |  51 MB     00:05     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                                                                1/1 
  Installing       : ostree-libs-2019.2-1.el8.x86_64                                                                                                                               1/25 
  Installing       : slirp4netns-0.3.0-4.module+el8.1.0+4306+1d917805.x86_64                                                                                                       2/25 
  Installing       : yajl-2.1.0-10.el8.x86_64                                                                                                                                      3/25 
  Installing       : oci-systemd-hook-1:0.1.15-2.git2d0b8a3.module+el8+2769+577ad176.x86_64                                                                                        4/25 
  Installing       : containernetworking-plugins-0.8.1-2.module+el8.1.0+4081+b29780af.x86_64                                                                                       5/25 
  Installing       : podman-manpages-1.4.2-5.module+el8.1.0+4240+893c1ab8.noarch                                                                                                   6/25 
  Installing       : protobuf-c-1.3.0-4.el8.x86_64                                                                                                                                 7/25 
  Installing       : libnet-1.1.6-15.el8.x86_64                                                                                                                                    8/25 
  Running scriptlet: libnet-1.1.6-15.el8.x86_64                                                                                                                                    8/25 
  Installing       : criu-3.12-9.el8.x86_64                                                                                                                                        9/25 
  Installing       : libvarlink-18-3.el8.x86_64                                                                                                                                   10/25 
  Running scriptlet: libvarlink-18-3.el8.x86_64                                                                                                                                   10/25 
  Installing       : python3-libsemanage-2.9-1.el8.x86_64                                                                                                                         11/25 
  Installing       : checkpolicy-2.9-1.el8.x86_64                                                                                                                                 12/25 
  Installing       : python3-audit-3.0-0.13.20190507gitf58ec40.el8.x86_64                                                                                                         13/25 
  Installing       : python3-setools-4.2.2-1.el8.x86_64                                                                                                                           14/25 
  Installing       : python3-policycoreutils-2.9-3.el8.noarch                                                                                                                     15/25 
  Installing       : policycoreutils-python-utils-2.9-3.el8.noarch                                                                                                                16/25 
  Installing       : container-selinux-2:2.107-2.module+el8.1.0+4081+b29780af.noarch                                                                                              17/25 
  Running scriptlet: container-selinux-2:2.107-2.module+el8.1.0+4081+b29780af.noarch                                                                                              17/25 
  Installing       : runc-1.0.0-60.rc8.module+el8.1.0+4081+b29780af.x86_64                                                                                                        18/25 
  Installing       : fuse3-libs-3.2.1-12.el8.x86_64                                                                                                                               19/25 
  Running scriptlet: fuse3-libs-3.2.1-12.el8.x86_64                                                                                                                               19/25 
  Installing       : fuse-overlayfs-0.4.1-1.module+el8.1.0+4081+b29780af.x86_64                                                                                                   20/25 
  Installing       : containers-common-1:0.1.37-5.module+el8.1.0+4240+893c1ab8.x86_64                                                                                             21/25 
  Installing       : skopeo-1:0.1.37-5.module+el8.1.0+4240+893c1ab8.x86_64                                                                                                        22/25 
  Installing       : podman-1.4.2-5.module+el8.1.0+4240+893c1ab8.x86_64                                                                                                           23/25 
  Installing       : buildah-1.9.0-5.module+el8.1.0+4240+893c1ab8.x86_64                                                                                                          24/25 
  Installing       : oci-umount-2:2.3.4-2.git87f9237.module+el8+2769+577ad176.x86_64                                                                                              25/25 
  Running scriptlet: oci-umount-2:2.3.4-2.git87f9237.module+el8+2769+577ad176.x86_64                                                                                              25/25 
  Verifying        : fuse3-libs-3.2.1-12.el8.x86_64                                                                                                                                1/25 
  Verifying        : python3-setools-4.2.2-1.el8.x86_64                                                                                                                            2/25 
  Verifying        : python3-audit-3.0-0.13.20190507gitf58ec40.el8.x86_64                                                                                                          3/25 
  Verifying        : policycoreutils-python-utils-2.9-3.el8.noarch                                                                                                                 4/25 
  Verifying        : python3-policycoreutils-2.9-3.el8.noarch                                                                                                                      5/25 
  Verifying        : checkpolicy-2.9-1.el8.x86_64                                                                                                                                  6/25 
  Verifying        : python3-libsemanage-2.9-1.el8.x86_64                                                                                                                          7/25 
  Verifying        : libvarlink-18-3.el8.x86_64                                                                                                                                    8/25 
  Verifying        : libnet-1.1.6-15.el8.x86_64                                                                                                                                    9/25 
  Verifying        : yajl-2.1.0-10.el8.x86_64                                                                                                                                     10/25 
  Verifying        : protobuf-c-1.3.0-4.el8.x86_64                                                                                                                                11/25 
  Verifying        : oci-umount-2:2.3.4-2.git87f9237.module+el8+2769+577ad176.x86_64                                                                                              12/25 
  Verifying        : oci-systemd-hook-1:0.1.15-2.git2d0b8a3.module+el8+2769+577ad176.x86_64                                                                                       13/25 
  Verifying        : slirp4netns-0.3.0-4.module+el8.1.0+4306+1d917805.x86_64                                                                                                      14/25 
  Verifying        : skopeo-1:0.1.37-5.module+el8.1.0+4240+893c1ab8.x86_64                                                                                                        15/25 
  Verifying        : containers-common-1:0.1.37-5.module+el8.1.0+4240+893c1ab8.x86_64                                                                                             16/25 
  Verifying        : podman-1.4.2-5.module+el8.1.0+4240+893c1ab8.x86_64                                                                                                           17/25 
  Verifying        : buildah-1.9.0-5.module+el8.1.0+4240+893c1ab8.x86_64                                                                                                          18/25 
  Verifying        : runc-1.0.0-60.rc8.module+el8.1.0+4081+b29780af.x86_64                                                                                                        19/25 
  Verifying        : podman-manpages-1.4.2-5.module+el8.1.0+4240+893c1ab8.noarch                                                                                                  20/25 
  Verifying        : fuse-overlayfs-0.4.1-1.module+el8.1.0+4081+b29780af.x86_64                                                                                                   21/25 
  Verifying        : ostree-libs-2019.2-1.el8.x86_64                                                                                                                              22/25 
  Verifying        : container-selinux-2:2.107-2.module+el8.1.0+4081+b29780af.noarch                                                                                              23/25 
  Verifying        : criu-3.12-9.el8.x86_64                                                                                                                                       24/25 
  Verifying        : containernetworking-plugins-0.8.1-2.module+el8.1.0+4081+b29780af.x86_64                                                                                      25/25 
Installed products updated.

Installed:
  oci-umount-2:2.3.4-2.git87f9237.module+el8+2769+577ad176.x86_64                        oci-systemd-hook-1:0.1.15-2.git2d0b8a3.module+el8+2769+577ad176.x86_64                        
  slirp4netns-0.3.0-4.module+el8.1.0+4306+1d917805.x86_64                                skopeo-1:0.1.37-5.module+el8.1.0+4240+893c1ab8.x86_64                                         
  podman-1.4.2-5.module+el8.1.0+4240+893c1ab8.x86_64                                     buildah-1.9.0-5.module+el8.1.0+4240+893c1ab8.x86_64                                           
  runc-1.0.0-60.rc8.module+el8.1.0+4081+b29780af.x86_64                                  fuse-overlayfs-0.4.1-1.module+el8.1.0+4081+b29780af.x86_64                                    
  container-selinux-2:2.107-2.module+el8.1.0+4081+b29780af.noarch                        containernetworking-plugins-0.8.1-2.module+el8.1.0+4081+b29780af.x86_64                       
  libvarlink-18-3.el8.x86_64                                                             fuse3-libs-3.2.1-12.el8.x86_64                                                                
  python3-setools-4.2.2-1.el8.x86_64                                                     python3-audit-3.0-0.13.20190507gitf58ec40.el8.x86_64                                          
  policycoreutils-python-utils-2.9-3.el8.noarch                                          python3-policycoreutils-2.9-3.el8.noarch                                                      
  checkpolicy-2.9-1.el8.x86_64                                                           python3-libsemanage-2.9-1.el8.x86_64                                                          
  libnet-1.1.6-15.el8.x86_64                                                             yajl-2.1.0-10.el8.x86_64                                                                      
  protobuf-c-1.3.0-4.el8.x86_64                                                          containers-common-1:0.1.37-5.module+el8.1.0+4240+893c1ab8.x86_64                              
  podman-manpages-1.4.2-5.module+el8.1.0+4240+893c1ab8.noarch                            ostree-libs-2019.2-1.el8.x86_64                                                               
  criu-3.12-9.el8.x86_64                                                                

Complete!

Podman is installed:

[egallen@lab0 ~]$ podman --version
podman version 1.4.2-stable2

Run the basic hello-world:

[egallen@lab0 ~]$ sudo podman run hello-world

Hello from Docker!
This message shows that your installation appears to be working correctly.

To generate this message, Docker took the following steps:
 1. The Docker client contacted the Docker daemon.
 2. The Docker daemon pulled the "hello-world" image from the Docker Hub.
    (amd64)
 3. The Docker daemon created a new container from that image which runs the
    executable that produces the output you are currently reading.
 4. The Docker daemon streamed that output to the Docker client, which sent it
    to your terminal.

To try something more ambitious, you can run an Ubuntu container with:
 $ docker run -it ubuntu bash

Share images, automate workflows, and more with a free Docker ID:
 https://hub.docker.com/

For more examples and ideas, visit:
 https://docs.docker.com/get-started/

Go to https://ngc.nvidia.com/catalog/containers/nvidia:cuda/tags to get a NGC registry CUDA tag: NVIDIA Tesla

We can take 10.2-runtime-ubi8: NVIDIA Tesla

We need to enable the runtime hook, by default configuration containers cannot use the GPU:

[egallen@lab0 ~]$ sudo podman run --rm nvcr.io/nvidia/cuda:10.2-runtime-ubi8 nvidia-smi
Error: container_linux.go:345: starting container process caused "exec: \"nvidia-smi\": executable file not found in $PATH"
: OCI runtime error

Here we can download the nvidia-container-runtime https://nvidia.github.io/nvidia-container-runtime/.

Enable nvidia-container-runtime-hook repository:

[egallen@lab0 ~]$ curl -s -L https://nvidia.github.io/nvidia-container-runtime/gpgkey | sudo apt-key add -

[egallen@lab0 ~]$ distribution=$(. /etc/os-release;echo $ID$VERSION_ID)

[egallen@lab0 ~]$ echo $distribution
rhel8.1

[egallen@lab0 ~]$ curl -s -L https://nvidia.github.io/nvidia-container-runtime/$distribution/nvidia-container-runtime.repo | sudo tee /etc/yum.repos.d/nvidia-container-runtime.repo
[libnvidia-container]
name=libnvidia-container
baseurl=https://nvidia.github.io/libnvidia-container/centos7/$basearch
repo_gpgcheck=1
gpgcheck=0
enabled=1
gpgkey=https://nvidia.github.io/libnvidia-container/gpgkey
sslverify=1
sslcacert=/etc/pki/tls/certs/ca-bundle.crt

[nvidia-container-runtime]
name=nvidia-container-runtime
baseurl=https://nvidia.github.io/nvidia-container-runtime/centos7/$basearch
repo_gpgcheck=1
gpgcheck=0
enabled=1
gpgkey=https://nvidia.github.io/nvidia-container-runtime/gpgkey
sslverify=1
sslcacert=/etc/pki/tls/certs/ca-bundle.crt

Install NVIDIA container runtime hook:

[egallen@lab0 ~]$ sudo dnf install nvidia-container-runtime-hook
Updating Subscription Management repositories.
libnvidia-container   
nvidia-container-runtime                                                                                                                                 21 kB/s |  11 kB     00:00    
Dependencies resolved.
========================================================================================================================================================================================
 Package                                              Architecture                      Version                               Repository                                           Size
========================================================================================================================================================================================
Installing:
 nvidia-container-toolkit                             x86_64                            1.0.5-2                               nvidia-container-runtime                            616 k
Installing dependencies:
 libnvidia-container-tools                            x86_64                            1.0.5-1                               libnvidia-container                                  36 k
 libnvidia-container1                                 x86_64                            1.0.5-1                               libnvidia-container                                  77 k

Transaction Summary
========================================================================================================================================================================================
Install  3 Packages

Total download size: 729 k
Installed size: 2.1 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): libnvidia-container-tools-1.0.5-1.x86_64.rpm                                                                                                     120 kB/s |  36 kB     00:00    
(2/3): libnvidia-container1-1.0.5-1.x86_64.rpm                                                                                                          230 kB/s |  77 kB     00:00    
(3/3): nvidia-container-toolkit-1.0.5-2.x86_64.rpm                                                                                                      1.4 MB/s | 616 kB     00:00    
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                   1.7 MB/s | 729 kB     00:00     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                                                                1/1 
  Installing       : libnvidia-container1-1.0.5-1.x86_64                                                                                                                            1/3 
  Running scriptlet: libnvidia-container1-1.0.5-1.x86_64                                                                                                                            1/3 
  Installing       : libnvidia-container-tools-1.0.5-1.x86_64                                                                                                                       2/3 
  Installing       : nvidia-container-toolkit-1.0.5-2.x86_64                                                                                                                        3/3 
  Running scriptlet: nvidia-container-toolkit-1.0.5-2.x86_64                                                                                                                        3/3 
  Verifying        : libnvidia-container-tools-1.0.5-1.x86_64                                                                                                                       1/3 
  Verifying        : libnvidia-container1-1.0.5-1.x86_64                                                                                                                            2/3 
  Verifying        : nvidia-container-toolkit-1.0.5-2.x86_64                                                                                                                        3/3 
Installed products updated.

Installed:
  nvidia-container-toolkit-1.0.5-2.x86_64                       libnvidia-container-tools-1.0.5-1.x86_64                       libnvidia-container1-1.0.5-1.x86_64                      

Complete!

Success podman is ready to run Artificial Intelligence and Machine Learning workloads:

[egallen@lab0 ~]$ sudo podman run --rm nvcr.io/nvidia/cuda:10.2-runtime-ubi8 nvidia-smi
Sun Dec 15 17:23:54 2019       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 440.33.01    Driver Version: 440.33.01    CUDA Version: 10.2     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  Tesla T4            Off  | 00000000:01:00.0 Off |                    0 |
| N/A   34C    P0    16W /  70W |      0MiB / 15109MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|  No running processes found                                                 |
+-----------------------------------------------------------------------------+

NVIDIA Tesla T4 idle temperatures is at 34C with this motherboard and “custom” cooling.

[egallen@lab0 ~]$ sudo podman image ls -a
REPOSITORY                      TAG                 IMAGE ID       CREATED         SIZE
nvcr.io/nvidia/cuda             10.2-runtime-ubi8   7c056c682a7b   9 days ago      1.41 GB
docker.io/library/hello-world   latest              fce289e99eb9   11 months ago   6.14 kB

Try a TensorFlow run

Let's make a burn with NGC TensorFlow 19.11.

Clone TensorFlow benchmarks:


[egallen@lab0 ~]$ sudo mkdir /data
[egallen@lab0 data]$ cd /data
[egallen@lab0 data]$ git clone https://github.com/tensorflow/benchmarks.git

We can use NGC TensorFlow container from NVIDIA, we can pick the proper tag here, we will use 19.11-tf1-py3: https://ngc.nvidia.com/catalog/containers/nvidia:tensorflow

By default, tf_cnn_benchmarks will use all cores of all CPUs on the system if we pass –device=cpu (/cpu:0 represents all the CPUs). Run a Tensorflow benchmark with all the CPUs of the node:

[egallen@lab0 data]$ time sudo podman run --volume /data:/data -it nvcr.io/nvidia/tensorflow:19.11-tf1-py3 python3 /data/benchmarks/scripts/tf_cnn_benchmarks/tf_cnn_benchmarks.py --device=cpu --data_format=NHWC --batch_size=32 --model=resnet50 --variable_update=parameter_server
                                                                                                                                                
================
== TensorFlow ==
================

NVIDIA Release 19.11-tf1 (build 8788896)
TensorFlow Version 1.15.0

Container image Copyright (c) 2019, NVIDIA CORPORATION.  All rights reserved.
Copyright 2017-2019 The TensorFlow Authors.  All rights reserved.

Various files include modifications (c) NVIDIA CORPORATION.  All rights reserved.
NVIDIA modifications are covered by the license terms that apply to the underlying project or file.

NOTE: MOFED driver for multi-node communication was not detected.
      Multi-node communication performance may be reduced.

2019-12-16 08:39:35.105993: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcudart.so.10.2
WARNING:tensorflow:
The TensorFlow contrib module will not be included in TensorFlow 2.0.
For more information, please see:
  * https://github.com/tensorflow/community/blob/master/rfcs/20180907-contrib-sunset.md
  * https://github.com/tensorflow/addons
  * https://github.com/tensorflow/io (for I/O related ops)
If you depend on functionality not listed there, please file an issue.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/models/mobilenet.py:388: The name tf.nn.avg_pool is deprecated. Please use tf.nn.avg_pool2d instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/models/experimental/deepspeech.py:131: The name tf.nn.rnn_cell.RNNCell is deprecated. Please use tf.compat.v1.nn.rnn_cell.RNNCell instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:737: The name tf.ConfigProto is deprecated. Please use tf.compat.v1.ConfigProto instead.

W1216 08:39:36.597405 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:737: The name tf.ConfigProto is deprecated. Please use tf.compat.v1.ConfigProto instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:3531: The name tf.Session is deprecated. Please use tf.compat.v1.Session instead.

W1216 08:39:36.597609 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:3531: The name tf.Session is deprecated. Please use tf.compat.v1.Session instead.

2019-12-16 08:39:36.613408: I tensorflow/core/platform/profile_utils/cpu_utils.cc:94] CPU Frequency: 4200000000 Hz
2019-12-16 08:39:36.614010: I tensorflow/compiler/xla/service/service.cc:168] XLA service 0x5354b50 initialized for platform Host (this does not guarantee that XLA will be used). Devices:
2019-12-16 08:39:36.614021: I tensorflow/compiler/xla/service/service.cc:176]   StreamExecutor device (0): Host, Default Version
2019-12-16 08:39:36.615399: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcuda.so.1
2019-12-16 08:39:37.126960: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:39:37.127440: I tensorflow/compiler/xla/service/service.cc:168] XLA service 0x5351ec0 initialized for platform CUDA (this does not guarantee that XLA will be used). Devices:
2019-12-16 08:39:37.127453: I tensorflow/compiler/xla/service/service.cc:176]   StreamExecutor device (0): Tesla T4, Compute Capability 7.5
2019-12-16 08:39:37.127581: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:39:37.127966: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1618] Found device 0 with properties: 
name: Tesla T4 major: 7 minor: 5 memoryClockRate(GHz): 1.59
pciBusID: 0000:01:00.0
2019-12-16 08:39:37.127984: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcudart.so.10.2
2019-12-16 08:39:37.129228: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcublas.so.10
2019-12-16 08:39:37.130391: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcufft.so.10
2019-12-16 08:39:37.130592: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcurand.so.10
2019-12-16 08:39:37.131930: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcusolver.so.10
2019-12-16 08:39:37.132681: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcusparse.so.10
2019-12-16 08:39:37.135357: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcudnn.so.7
2019-12-16 08:39:37.135466: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:39:37.135924: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:39:37.136349: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1746] Adding visible gpu devices: 0
2019-12-16 08:39:37.136384: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcudart.so.10.2
2019-12-16 08:39:37.381441: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1159] Device interconnect StreamExecutor with strength 1 edge matrix:
2019-12-16 08:39:37.381481: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1165]      0 
2019-12-16 08:39:37.381486: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1178] 0:   N 
2019-12-16 08:39:37.381642: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:39:37.382084: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:39:37.382488: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1304] Created TensorFlow device (/job:localhost/replica:0/task:0/device:GPU:0 with 14003 MB memory) -> physical GPU (device: 0, name: Tesla T4, pci bus id: 0000:01:00.0, compute capability: 7.5)
TensorFlow:  1.15
Model:       resnet50
Dataset:     imagenet (synthetic)
Mode:        training
SingleSess:  False
Batch size:  32 global
             32 per device
Num batches: 100
Num epochs:  0.00
Devices:     ['/cpu:0']
NUMA bind:   False
Data format: NHWC
Optimizer:   sgd
Variables:   parameter_server
==========
WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2790: The name tf.set_random_seed is deprecated. Please use tf.compat.v1.set_random_seed instead.

W1216 08:39:37.384276 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2790: The name tf.set_random_seed is deprecated. Please use tf.compat.v1.set_random_seed instead.

Generating training model
WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2810: The name tf.train.get_or_create_global_step is deprecated. Please use tf.compat.v1.train.get_or_create_global_step instead.

W1216 08:39:37.384566 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2810: The name tf.train.get_or_create_global_step is deprecated. Please use tf.compat.v1.train.get_or_create_global_step instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/variable_mgr.py:220: The name tf.variable_scope is deprecated. Please use tf.compat.v1.variable_scope instead.

W1216 08:39:37.388102 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/variable_mgr.py:220: The name tf.variable_scope is deprecated. Please use tf.compat.v1.variable_scope instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/models/model.py:245: The name tf.truncated_normal is deprecated. Please use tf.random.truncated_normal instead.

W1216 08:39:37.388331 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/models/model.py:245: The name tf.truncated_normal is deprecated. Please use tf.random.truncated_normal instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/models/model.py:252: The name tf.random_uniform is deprecated. Please use tf.random.uniform instead.

W1216 08:39:37.392255 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/models/model.py:252: The name tf.random_uniform is deprecated. Please use tf.random.uniform instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:129: conv2d (from tensorflow.python.layers.convolutional) is deprecated and will be removed in a future version.
Instructions for updating:
Use `tf.keras.layers.Conv2D` instead.
W1216 08:39:37.396633 139914130491200 deprecation.py:323] From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:129: conv2d (from tensorflow.python.layers.convolutional) is deprecated and will be removed in a future version.
Instructions for updating:
Use `tf.keras.layers.Conv2D` instead.
WARNING:tensorflow:From /usr/local/lib/python3.6/dist-packages/tensorflow_core/python/layers/convolutional.py:424: Layer.apply (from tensorflow.python.keras.engine.base_layer) is deprecated and will be removed in a future version.
Instructions for updating:
Please use `layer.__call__` method instead.
W1216 08:39:37.397571 139914130491200 deprecation.py:323] From /usr/local/lib/python3.6/dist-packages/tensorflow_core/python/layers/convolutional.py:424: Layer.apply (from tensorflow.python.keras.engine.base_layer) is deprecated and will be removed in a future version.
Instructions for updating:
Please use `layer.__call__` method instead.
WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:261: max_pooling2d (from tensorflow.python.layers.pooling) is deprecated and will be removed in a future version.
Instructions for updating:
Use keras.layers.MaxPooling2D instead.
W1216 08:39:37.424758 139914130491200 deprecation.py:323] From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:261: max_pooling2d (from tensorflow.python.layers.pooling) is deprecated and will be removed in a future version.
Instructions for updating:
Use keras.layers.MaxPooling2D instead.
WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:120: The name tf.get_variable is deprecated. Please use tf.compat.v1.get_variable instead.

W1216 08:39:38.709852 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:120: The name tf.get_variable is deprecated. Please use tf.compat.v1.get_variable instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:334: The name tf.nn.xw_plus_b is deprecated. Please use tf.compat.v1.nn.xw_plus_b instead.

W1216 08:39:38.716611 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:334: The name tf.nn.xw_plus_b is deprecated. Please use tf.compat.v1.nn.xw_plus_b instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/models/model.py:319: The name tf.losses.sparse_softmax_cross_entropy is deprecated. Please use tf.compat.v1.losses.sparse_softmax_cross_entropy instead.

W1216 08:39:38.717865 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/models/model.py:319: The name tf.losses.sparse_softmax_cross_entropy is deprecated. Please use tf.compat.v1.losses.sparse_softmax_cross_entropy instead.

WARNING:tensorflow:From /usr/local/lib/python3.6/dist-packages/tensorflow_core/python/ops/losses/losses_impl.py:121: where (from tensorflow.python.ops.array_ops) is deprecated and will be removed in a future version.
Instructions for updating:
Use tf.where in 2.0, which has the same broadcast rule as np.where
W1216 08:39:38.724012 139914130491200 deprecation.py:323] From /usr/local/lib/python3.6/dist-packages/tensorflow_core/python/ops/losses/losses_impl.py:121: where (from tensorflow.python.ops.array_ops) is deprecated and will be removed in a future version.
Instructions for updating:
Use tf.where in 2.0, which has the same broadcast rule as np.where
WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/variable_mgr.py:147: The name tf.trainable_variables is deprecated. Please use tf.compat.v1.trainable_variables instead.

W1216 08:39:38.730463 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/variable_mgr.py:147: The name tf.trainable_variables is deprecated. Please use tf.compat.v1.trainable_variables instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2856: The name tf.get_collection is deprecated. Please use tf.compat.v1.get_collection instead.

W1216 08:39:39.126976 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2856: The name tf.get_collection is deprecated. Please use tf.compat.v1.get_collection instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2856: The name tf.GraphKeys is deprecated. Please use tf.compat.v1.GraphKeys instead.

W1216 08:39:39.127145 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2856: The name tf.GraphKeys is deprecated. Please use tf.compat.v1.GraphKeys instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/models/resnet_model.py:333: The name tf.train.piecewise_constant is deprecated. Please use tf.compat.v1.train.piecewise_constant instead.

W1216 08:39:39.138721 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/models/resnet_model.py:333: The name tf.train.piecewise_constant is deprecated. Please use tf.compat.v1.train.piecewise_constant instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:1237: The name tf.train.GradientDescentOptimizer is deprecated. Please use tf.compat.v1.train.GradientDescentOptimizer instead.

W1216 08:39:39.185851 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:1237: The name tf.train.GradientDescentOptimizer is deprecated. Please use tf.compat.v1.train.GradientDescentOptimizer instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2118: The name tf.train.get_global_step is deprecated. Please use tf.compat.v1.train.get_global_step instead.

W1216 08:39:39.276628 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2118: The name tf.train.get_global_step is deprecated. Please use tf.compat.v1.train.get_global_step instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2136: The name tf.local_variables_initializer is deprecated. Please use tf.compat.v1.local_variables_initializer instead.

W1216 08:39:39.277722 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2136: The name tf.local_variables_initializer is deprecated. Please use tf.compat.v1.local_variables_initializer instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2137: The name tf.tables_initializer is deprecated. Please use tf.compat.v1.tables_initializer instead.

W1216 08:39:39.278185 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2137: The name tf.tables_initializer is deprecated. Please use tf.compat.v1.tables_initializer instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2154: The name tf.summary.merge_all is deprecated. Please use tf.compat.v1.summary.merge_all instead.

W1216 08:39:39.279364 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2154: The name tf.summary.merge_all is deprecated. Please use tf.compat.v1.summary.merge_all instead.

Initializing graph
WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2211: The name tf.train.Saver is deprecated. Please use tf.compat.v1.train.Saver instead.

W1216 08:39:39.279520 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2211: The name tf.train.Saver is deprecated. Please use tf.compat.v1.train.Saver instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/variable_mgr.py:124: The name tf.global_variables is deprecated. Please use tf.compat.v1.global_variables instead.

W1216 08:39:39.279612 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/variable_mgr.py:124: The name tf.global_variables is deprecated. Please use tf.compat.v1.global_variables instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2240: The name tf.RunOptions is deprecated. Please use tf.compat.v1.RunOptions instead.

W1216 08:39:39.472222 139914130491200 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2240: The name tf.RunOptions is deprecated. Please use tf.compat.v1.RunOptions instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2266: Supervisor.__init__ (from tensorflow.python.training.supervisor) is deprecated and will be removed in a future version.
Instructions for updating:
Please switch to tf.train.MonitoredTrainingSession
W1216 08:39:39.472406 139914130491200 deprecation.py:323] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2266: Supervisor.__init__ (from tensorflow.python.training.supervisor) is deprecated and will be removed in a future version.
Instructions for updating:
Please switch to tf.train.MonitoredTrainingSession
2019-12-16 08:39:39.766808: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:39:39.767298: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1618] Found device 0 with properties: 
name: Tesla T4 major: 7 minor: 5 memoryClockRate(GHz): 1.59
pciBusID: 0000:01:00.0
2019-12-16 08:39:39.767335: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcudart.so.10.2
2019-12-16 08:39:39.767361: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcublas.so.10
2019-12-16 08:39:39.767371: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcufft.so.10
2019-12-16 08:39:39.767380: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcurand.so.10
2019-12-16 08:39:39.767390: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcusolver.so.10
2019-12-16 08:39:39.767400: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcusparse.so.10
2019-12-16 08:39:39.767409: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcudnn.so.7
2019-12-16 08:39:39.767457: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:39:39.767876: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:39:39.768243: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1746] Adding visible gpu devices: 0
2019-12-16 08:39:39.768261: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1159] Device interconnect StreamExecutor with strength 1 edge matrix:
2019-12-16 08:39:39.768266: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1165]      0 
2019-12-16 08:39:39.768270: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1178] 0:   N 
2019-12-16 08:39:39.768324: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:39:39.768725: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:39:39.769103: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1304] Created TensorFlow device (/job:localhost/replica:0/task:0/device:GPU:0 with 14003 MB memory) -> physical GPU (device: 0, name: Tesla T4, pci bus id: 0000:01:00.0, compute capability: 7.5)
INFO:tensorflow:Running local_init_op.
I1216 08:39:40.219716 139914130491200 session_manager.py:500] Running local_init_op.
INFO:tensorflow:Done running local_init_op.
I1216 08:39:40.284223 139914130491200 session_manager.py:502] Done running local_init_op.
Running warm up
Done warm up
Step	Img/sec	total_loss
1	images/sec: 7.0 +/- 0.0 (jitter = 0.0)	8.108
10	images/sec: 7.1 +/- 0.0 (jitter = 0.0)	8.122
20	images/sec: 7.1 +/- 0.0 (jitter = 0.0)	7.983
30	images/sec: 7.1 +/- 0.0 (jitter = 0.0)	7.780
40	images/sec: 7.1 +/- 0.0 (jitter = 0.0)	7.848
50	images/sec: 7.1 +/- 0.0 (jitter = 0.0)	7.779
60	images/sec: 7.1 +/- 0.0 (jitter = 0.0)	7.825
70	images/sec: 7.1 +/- 0.0 (jitter = 0.0)	7.839
80	images/sec: 7.1 +/- 0.0 (jitter = 0.0)	7.817
90	images/sec: 7.1 +/- 0.0 (jitter = 0.0)	7.647
100	images/sec: 7.1 +/- 0.0 (jitter = 0.0)	7.915
----------------------------------------------------------------
total images/sec: 7.07
----------------------------------------------------------------

real	8m28.115s
user	0m0.138s
sys	0m0.053s

Run a Tensorflow benchmark with the NVIDIA T4 GPU:

[egallen@lab0 data]$ time sudo podman run --volume /data:/data -it nvcr.io/nvidia/tensorflow:19.11-tf1-py3 python3 /data/benchmarks/scripts/tf_cnn_benchmarks/tf_cnn_benchmarks.py --num_gpus=1 --data_format=NHWC --batch_size=32 --model=resnet50 --variable_update=parameter_server
                                                                                                                                                
================
== TensorFlow ==
================

NVIDIA Release 19.11-tf1 (build 8788896)
TensorFlow Version 1.15.0

Container image Copyright (c) 2019, NVIDIA CORPORATION.  All rights reserved.
Copyright 2017-2019 The TensorFlow Authors.  All rights reserved.

Various files include modifications (c) NVIDIA CORPORATION.  All rights reserved.
NVIDIA modifications are covered by the license terms that apply to the underlying project or file.

NOTE: MOFED driver for multi-node communication was not detected.
      Multi-node communication performance may be reduced.

2019-12-16 08:48:38.144025: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcudart.so.10.2
WARNING:tensorflow:
The TensorFlow contrib module will not be included in TensorFlow 2.0.
For more information, please see:
  * https://github.com/tensorflow/community/blob/master/rfcs/20180907-contrib-sunset.md
  * https://github.com/tensorflow/addons
  * https://github.com/tensorflow/io (for I/O related ops)
If you depend on functionality not listed there, please file an issue.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/models/mobilenet.py:388: The name tf.nn.avg_pool is deprecated. Please use tf.nn.avg_pool2d instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/models/experimental/deepspeech.py:131: The name tf.nn.rnn_cell.RNNCell is deprecated. Please use tf.compat.v1.nn.rnn_cell.RNNCell instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:737: The name tf.ConfigProto is deprecated. Please use tf.compat.v1.ConfigProto instead.

W1216 08:48:39.634068 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:737: The name tf.ConfigProto is deprecated. Please use tf.compat.v1.ConfigProto instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:3531: The name tf.Session is deprecated. Please use tf.compat.v1.Session instead.

W1216 08:48:39.634273 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:3531: The name tf.Session is deprecated. Please use tf.compat.v1.Session instead.

2019-12-16 08:48:39.650397: I tensorflow/core/platform/profile_utils/cpu_utils.cc:94] CPU Frequency: 4200000000 Hz
2019-12-16 08:48:39.650516: I tensorflow/compiler/xla/service/service.cc:168] XLA service 0x668bd40 initialized for platform Host (this does not guarantee that XLA will be used). Devices:
2019-12-16 08:48:39.650528: I tensorflow/compiler/xla/service/service.cc:176]   StreamExecutor device (0): Host, Default Version
2019-12-16 08:48:39.652025: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcuda.so.1
2019-12-16 08:48:40.161619: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:48:40.162131: I tensorflow/compiler/xla/service/service.cc:168] XLA service 0x6621540 initialized for platform CUDA (this does not guarantee that XLA will be used). Devices:
2019-12-16 08:48:40.162144: I tensorflow/compiler/xla/service/service.cc:176]   StreamExecutor device (0): Tesla T4, Compute Capability 7.5
2019-12-16 08:48:40.162267: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:48:40.162643: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1618] Found device 0 with properties: 
name: Tesla T4 major: 7 minor: 5 memoryClockRate(GHz): 1.59
pciBusID: 0000:01:00.0
2019-12-16 08:48:40.162676: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcudart.so.10.2
2019-12-16 08:48:40.163811: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcublas.so.10
2019-12-16 08:48:40.164897: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcufft.so.10
2019-12-16 08:48:40.165091: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcurand.so.10
2019-12-16 08:48:40.166297: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcusolver.so.10
2019-12-16 08:48:40.166939: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcusparse.so.10
2019-12-16 08:48:40.169549: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcudnn.so.7
2019-12-16 08:48:40.169658: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:48:40.170087: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:48:40.170456: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1746] Adding visible gpu devices: 0
2019-12-16 08:48:40.170493: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcudart.so.10.2
2019-12-16 08:48:40.406276: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1159] Device interconnect StreamExecutor with strength 1 edge matrix:
2019-12-16 08:48:40.406318: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1165]      0 
2019-12-16 08:48:40.406324: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1178] 0:   N 
2019-12-16 08:48:40.406519: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:48:40.406954: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:48:40.407409: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1304] Created TensorFlow device (/job:localhost/replica:0/task:0/device:GPU:0 with 14003 MB memory) -> physical GPU (device: 0, name: Tesla T4, pci bus id: 0000:01:00.0, compute capability: 7.5)
TensorFlow:  1.15
Model:       resnet50
Dataset:     imagenet (synthetic)
Mode:        training
SingleSess:  False
Batch size:  32 global
             32 per device
Num batches: 100
Num epochs:  0.00
Devices:     ['/gpu:0']
NUMA bind:   False
Data format: NHWC
Optimizer:   sgd
Variables:   parameter_server
==========
WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2790: The name tf.set_random_seed is deprecated. Please use tf.compat.v1.set_random_seed instead.

W1216 08:48:40.409432 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2790: The name tf.set_random_seed is deprecated. Please use tf.compat.v1.set_random_seed instead.

Generating training model
WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2810: The name tf.train.get_or_create_global_step is deprecated. Please use tf.compat.v1.train.get_or_create_global_step instead.

W1216 08:48:40.409716 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2810: The name tf.train.get_or_create_global_step is deprecated. Please use tf.compat.v1.train.get_or_create_global_step instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/variable_mgr.py:220: The name tf.variable_scope is deprecated. Please use tf.compat.v1.variable_scope instead.

W1216 08:48:40.413261 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/variable_mgr.py:220: The name tf.variable_scope is deprecated. Please use tf.compat.v1.variable_scope instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/models/model.py:245: The name tf.truncated_normal is deprecated. Please use tf.random.truncated_normal instead.

W1216 08:48:40.413505 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/models/model.py:245: The name tf.truncated_normal is deprecated. Please use tf.random.truncated_normal instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/models/model.py:252: The name tf.random_uniform is deprecated. Please use tf.random.uniform instead.

W1216 08:48:40.417449 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/models/model.py:252: The name tf.random_uniform is deprecated. Please use tf.random.uniform instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:129: conv2d (from tensorflow.python.layers.convolutional) is deprecated and will be removed in a future version.
Instructions for updating:
Use `tf.keras.layers.Conv2D` instead.
W1216 08:48:40.421849 140512265873216 deprecation.py:323] From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:129: conv2d (from tensorflow.python.layers.convolutional) is deprecated and will be removed in a future version.
Instructions for updating:
Use `tf.keras.layers.Conv2D` instead.
WARNING:tensorflow:From /usr/local/lib/python3.6/dist-packages/tensorflow_core/python/layers/convolutional.py:424: Layer.apply (from tensorflow.python.keras.engine.base_layer) is deprecated and will be removed in a future version.
Instructions for updating:
Please use `layer.__call__` method instead.
W1216 08:48:40.422837 140512265873216 deprecation.py:323] From /usr/local/lib/python3.6/dist-packages/tensorflow_core/python/layers/convolutional.py:424: Layer.apply (from tensorflow.python.keras.engine.base_layer) is deprecated and will be removed in a future version.
Instructions for updating:
Please use `layer.__call__` method instead.
WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:261: max_pooling2d (from tensorflow.python.layers.pooling) is deprecated and will be removed in a future version.
Instructions for updating:
Use keras.layers.MaxPooling2D instead.
W1216 08:48:40.449749 140512265873216 deprecation.py:323] From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:261: max_pooling2d (from tensorflow.python.layers.pooling) is deprecated and will be removed in a future version.
Instructions for updating:
Use keras.layers.MaxPooling2D instead.
WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:120: The name tf.get_variable is deprecated. Please use tf.compat.v1.get_variable instead.

W1216 08:48:41.724167 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:120: The name tf.get_variable is deprecated. Please use tf.compat.v1.get_variable instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:334: The name tf.nn.xw_plus_b is deprecated. Please use tf.compat.v1.nn.xw_plus_b instead.

W1216 08:48:41.730736 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/convnet_builder.py:334: The name tf.nn.xw_plus_b is deprecated. Please use tf.compat.v1.nn.xw_plus_b instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/models/model.py:319: The name tf.losses.sparse_softmax_cross_entropy is deprecated. Please use tf.compat.v1.losses.sparse_softmax_cross_entropy instead.

W1216 08:48:41.731995 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/models/model.py:319: The name tf.losses.sparse_softmax_cross_entropy is deprecated. Please use tf.compat.v1.losses.sparse_softmax_cross_entropy instead.

WARNING:tensorflow:From /usr/local/lib/python3.6/dist-packages/tensorflow_core/python/ops/losses/losses_impl.py:121: where (from tensorflow.python.ops.array_ops) is deprecated and will be removed in a future version.
Instructions for updating:
Use tf.where in 2.0, which has the same broadcast rule as np.where
W1216 08:48:41.738033 140512265873216 deprecation.py:323] From /usr/local/lib/python3.6/dist-packages/tensorflow_core/python/ops/losses/losses_impl.py:121: where (from tensorflow.python.ops.array_ops) is deprecated and will be removed in a future version.
Instructions for updating:
Use tf.where in 2.0, which has the same broadcast rule as np.where
WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/variable_mgr.py:147: The name tf.trainable_variables is deprecated. Please use tf.compat.v1.trainable_variables instead.

W1216 08:48:41.744416 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/variable_mgr.py:147: The name tf.trainable_variables is deprecated. Please use tf.compat.v1.trainable_variables instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2856: The name tf.get_collection is deprecated. Please use tf.compat.v1.get_collection instead.

W1216 08:48:42.137453 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2856: The name tf.get_collection is deprecated. Please use tf.compat.v1.get_collection instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2856: The name tf.GraphKeys is deprecated. Please use tf.compat.v1.GraphKeys instead.

W1216 08:48:42.137614 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2856: The name tf.GraphKeys is deprecated. Please use tf.compat.v1.GraphKeys instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/models/resnet_model.py:333: The name tf.train.piecewise_constant is deprecated. Please use tf.compat.v1.train.piecewise_constant instead.

W1216 08:48:42.149061 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/models/resnet_model.py:333: The name tf.train.piecewise_constant is deprecated. Please use tf.compat.v1.train.piecewise_constant instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:1237: The name tf.train.GradientDescentOptimizer is deprecated. Please use tf.compat.v1.train.GradientDescentOptimizer instead.

W1216 08:48:42.195959 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:1237: The name tf.train.GradientDescentOptimizer is deprecated. Please use tf.compat.v1.train.GradientDescentOptimizer instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2118: The name tf.train.get_global_step is deprecated. Please use tf.compat.v1.train.get_global_step instead.

W1216 08:48:42.286501 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2118: The name tf.train.get_global_step is deprecated. Please use tf.compat.v1.train.get_global_step instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2136: The name tf.local_variables_initializer is deprecated. Please use tf.compat.v1.local_variables_initializer instead.

W1216 08:48:42.287627 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2136: The name tf.local_variables_initializer is deprecated. Please use tf.compat.v1.local_variables_initializer instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2137: The name tf.tables_initializer is deprecated. Please use tf.compat.v1.tables_initializer instead.

W1216 08:48:42.288069 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2137: The name tf.tables_initializer is deprecated. Please use tf.compat.v1.tables_initializer instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2154: The name tf.summary.merge_all is deprecated. Please use tf.compat.v1.summary.merge_all instead.

W1216 08:48:42.289203 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2154: The name tf.summary.merge_all is deprecated. Please use tf.compat.v1.summary.merge_all instead.

Initializing graph
WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2211: The name tf.train.Saver is deprecated. Please use tf.compat.v1.train.Saver instead.

W1216 08:48:42.289375 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2211: The name tf.train.Saver is deprecated. Please use tf.compat.v1.train.Saver instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/variable_mgr.py:124: The name tf.global_variables is deprecated. Please use tf.compat.v1.global_variables instead.

W1216 08:48:42.289470 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/variable_mgr.py:124: The name tf.global_variables is deprecated. Please use tf.compat.v1.global_variables instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2240: The name tf.RunOptions is deprecated. Please use tf.compat.v1.RunOptions instead.

W1216 08:48:42.481318 140512265873216 module_wrapper.py:139] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2240: The name tf.RunOptions is deprecated. Please use tf.compat.v1.RunOptions instead.

WARNING:tensorflow:From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2266: Supervisor.__init__ (from tensorflow.python.training.supervisor) is deprecated and will be removed in a future version.
Instructions for updating:
Please switch to tf.train.MonitoredTrainingSession
W1216 08:48:42.481497 140512265873216 deprecation.py:323] From /data/benchmarks/scripts/tf_cnn_benchmarks/benchmark_cnn.py:2266: Supervisor.__init__ (from tensorflow.python.training.supervisor) is deprecated and will be removed in a future version.
Instructions for updating:
Please switch to tf.train.MonitoredTrainingSession
2019-12-16 08:48:42.773993: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:48:42.774456: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1618] Found device 0 with properties: 
name: Tesla T4 major: 7 minor: 5 memoryClockRate(GHz): 1.59
pciBusID: 0000:01:00.0
2019-12-16 08:48:42.774492: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcudart.so.10.2
2019-12-16 08:48:42.774519: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcublas.so.10
2019-12-16 08:48:42.774531: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcufft.so.10
2019-12-16 08:48:42.774542: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcurand.so.10
2019-12-16 08:48:42.774554: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcusolver.so.10
2019-12-16 08:48:42.774566: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcusparse.so.10
2019-12-16 08:48:42.774581: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcudnn.so.7
2019-12-16 08:48:42.774626: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:48:42.775016: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:48:42.775376: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1746] Adding visible gpu devices: 0
2019-12-16 08:48:42.775396: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1159] Device interconnect StreamExecutor with strength 1 edge matrix:
2019-12-16 08:48:42.775402: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1165]      0 
2019-12-16 08:48:42.775406: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1178] 0:   N 
2019-12-16 08:48:42.775462: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:48:42.775846: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:983] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2019-12-16 08:48:42.776215: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1304] Created TensorFlow device (/job:localhost/replica:0/task:0/device:GPU:0 with 14003 MB memory) -> physical GPU (device: 0, name: Tesla T4, pci bus id: 0000:01:00.0, compute capability: 7.5)
INFO:tensorflow:Running local_init_op.
I1216 08:48:43.191928 140512265873216 session_manager.py:500] Running local_init_op.
INFO:tensorflow:Done running local_init_op.
I1216 08:48:43.237993 140512265873216 session_manager.py:502] Done running local_init_op.
Running warm up
2019-12-16 08:48:44.315112: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcublas.so.10
2019-12-16 08:48:44.468980: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcudnn.so.7
Done warm up
Step	Img/sec	total_loss
1	images/sec: 125.5 +/- 0.0 (jitter = 0.0)	8.108
10	images/sec: 123.5 +/- 0.3 (jitter = 0.9)	8.122
20	images/sec: 123.4 +/- 0.2 (jitter = 1.0)	7.983
30	images/sec: 123.2 +/- 0.2 (jitter = 0.8)	7.780
40	images/sec: 123.2 +/- 0.1 (jitter = 0.6)	7.849
50	images/sec: 123.0 +/- 0.1 (jitter = 0.7)	7.779
60	images/sec: 122.9 +/- 0.1 (jitter = 0.7)	7.825
70	images/sec: 122.9 +/- 0.1 (jitter = 0.6)	7.839
80	images/sec: 122.8 +/- 0.1 (jitter = 0.6)	7.818
90	images/sec: 122.7 +/- 0.1 (jitter = 0.7)	7.646
100	images/sec: 122.7 +/- 0.1 (jitter = 0.8)	7.915
----------------------------------------------------------------
total images/sec: 122.65
----------------------------------------------------------------

real	0m44.495s
user	0m0.115s
sys	0m0.046s

Here are the overall benchmarks results between CPU and GPU for:

  • model: resnet50
  • dataset: imagenet (synthetic)
  • mode: training
Device type Total run time (minutes) Total run time (seconds) Images/sec
CPU 8m28.115s 44.4 7.07
GPU 0m44.495s 508.1 122.65
Ratio 11.4 17.34

GPU resnet50 training is about 17.34 times faster than CPU training.